aboutsummaryrefslogtreecommitdiff
path: root/src/fs/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-11-24 23:09:36 +0000
committerChristian Grothoff <christian@grothoff.org>2012-11-24 23:09:36 +0000
commitffbcecfb3a225e8f592780c4a6eba56e6ae8a8f3 (patch)
tree1a5f0bf706cd5b4b39346853b19b1a89c86f28a5 /src/fs/Makefile.am
parenteb402314191286004d4b5450508080b3ef7b4e5b (diff)
downloadgnunet-ffbcecfb3a225e8f592780c4a6eba56e6ae8a8f3.tar.gz
gnunet-ffbcecfb3a225e8f592780c4a6eba56e6ae8a8f3.zip
-add multi-peer testcase for stream-based transfers (expected to fail right now), and option to disable anonymous transfers --- to force stream-based transfers
Diffstat (limited to 'src/fs/Makefile.am')
-rw-r--r--src/fs/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/fs/Makefile.am b/src/fs/Makefile.am
index 2164f9c6c..2ccb55e49 100644
--- a/src/fs/Makefile.am
+++ b/src/fs/Makefile.am
@@ -235,6 +235,7 @@ check_PROGRAMS = \
235 test_fs_uri \ 235 test_fs_uri \
236 test_gnunet_service_fs_migration \ 236 test_gnunet_service_fs_migration \
237 test_gnunet_service_fs_p2p \ 237 test_gnunet_service_fs_p2p \
238 test_gnunet_service_fs_p2p_stream \
238 $(FS_BENCHMARKS) 239 $(FS_BENCHMARKS)
239 240
240test_plugin_block_fs_SOURCES = \ 241test_plugin_block_fs_SOURCES = \
@@ -279,6 +280,7 @@ TESTS = \
279 test_fs_test_lib \ 280 test_fs_test_lib \
280 test_gnunet_service_fs_migration \ 281 test_gnunet_service_fs_migration \
281 test_gnunet_service_fs_p2p \ 282 test_gnunet_service_fs_p2p \
283 test_gnunet_service_fs_p2p_stream \
282 perf_gnunet_service_fs_p2p \ 284 perf_gnunet_service_fs_p2p \
283 perf_gnunet_service_fs_p2p_index \ 285 perf_gnunet_service_fs_p2p_index \
284 perf_gnunet_service_fs_p2p_respect \ 286 perf_gnunet_service_fs_p2p_respect \
@@ -433,6 +435,14 @@ test_gnunet_service_fs_p2p_LDADD = \
433 $(top_builddir)/src/fs/libgnunetfs.la \ 435 $(top_builddir)/src/fs/libgnunetfs.la \
434 $(top_builddir)/src/util/libgnunetutil.la 436 $(top_builddir)/src/util/libgnunetutil.la
435 437
438test_gnunet_service_fs_p2p_stream_SOURCES = \
439 test_gnunet_service_fs_p2p.c
440test_gnunet_service_fs_p2p_stream_LDADD = \
441 $(top_builddir)/src/fs/libgnunetfstest.a \
442 $(top_builddir)/src/testbed/libgnunettestbed.la \
443 $(top_builddir)/src/fs/libgnunetfs.la \
444 $(top_builddir)/src/util/libgnunetutil.la
445
436test_gnunet_service_fs_migration_SOURCES = \ 446test_gnunet_service_fs_migration_SOURCES = \
437 test_gnunet_service_fs_migration.c 447 test_gnunet_service_fs_migration.c
438test_gnunet_service_fs_migration_LDADD = \ 448test_gnunet_service_fs_migration_LDADD = \
@@ -513,6 +523,7 @@ EXTRA_DIST = \
513 test_fs_unindex_data.conf \ 523 test_fs_unindex_data.conf \
514 test_fs_uri_data.conf \ 524 test_fs_uri_data.conf \
515 test_gnunet_service_fs_migration_data.conf \ 525 test_gnunet_service_fs_migration_data.conf \
526 test_gnunet_service_fs_p2p_stream.conf \
516 test_gnunet_fs_idx_data.conf \ 527 test_gnunet_fs_idx_data.conf \
517 test_gnunet_fs_ns_data.conf \ 528 test_gnunet_fs_ns_data.conf \
518 test_gnunet_fs_psd_data.conf \ 529 test_gnunet_fs_psd_data.conf \