aboutsummaryrefslogtreecommitdiff
path: root/src/gns/Makefile.am
diff options
context:
space:
mode:
authorSchanzenbach, Martin <mschanzenbach@posteo.de>2019-03-12 09:36:17 +0100
committerSchanzenbach, Martin <mschanzenbach@posteo.de>2019-03-12 09:36:17 +0100
commit919bb8c92fa1b7cda53401ff2286b980ca0b12d8 (patch)
treeb0ab4ebf063c0ccb2a4b8095463d1e7a6884bf2e /src/gns/Makefile.am
parent76c6ccfdfe09891db424ead5209f041f0e71dc63 (diff)
downloadgnunet-919bb8c92fa1b7cda53401ff2286b980ca0b12d8.tar.gz
gnunet-919bb8c92fa1b7cda53401ff2286b980ca0b12d8.zip
move reclaim and gns back into subdirs
Diffstat (limited to 'src/gns/Makefile.am')
-rw-r--r--src/gns/Makefile.am24
1 files changed, 23 insertions, 1 deletions
diff --git a/src/gns/Makefile.am b/src/gns/Makefile.am
index 434d50f34..6ebbbcaff 100644
--- a/src/gns/Makefile.am
+++ b/src/gns/Makefile.am
@@ -89,9 +89,16 @@ bin_PROGRAMS += gnunet-bcd
89endif 89endif
90endif 90endif
91 91
92if HAVE_MHD
93if HAVE_JSON
94REST_PLUGIN = libgnunet_plugin_rest_gns.la
95endif
96endif
97
92plugin_LTLIBRARIES = \ 98plugin_LTLIBRARIES = \
93 libgnunet_plugin_block_gns.la \ 99 libgnunet_plugin_block_gns.la \
94 libgnunet_plugin_gnsrecord_gns.la 100 libgnunet_plugin_gnsrecord_gns.la \
101 $(REST_PLUGIN)
95 102
96 103
97bin_SCRIPTS = \ 104bin_SCRIPTS = \
@@ -104,6 +111,21 @@ gnunet-gns-proxy-setup-ca: gnunet-gns-proxy-setup-ca.in Makefile
104 $(do_subst) < $(srcdir)/gnunet-gns-proxy-setup-ca.in > gnunet-gns-proxy-setup-ca 111 $(do_subst) < $(srcdir)/gnunet-gns-proxy-setup-ca.in > gnunet-gns-proxy-setup-ca
105 chmod +x gnunet-gns-proxy-setup-ca 112 chmod +x gnunet-gns-proxy-setup-ca
106 113
114
115libgnunet_plugin_rest_gns_la_SOURCES = \
116 plugin_rest_gns.c
117libgnunet_plugin_rest_gns_la_LIBADD = \
118 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
119 libgnunetgns.la \
120 $(top_builddir)/src/rest/libgnunetrest.la \
121 $(top_builddir)/src/identity/libgnunetidentity.la \
122 $(top_builddir)/src/json/libgnunetjson.la \
123 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
124 $(LTLIBINTL) -ljansson -lmicrohttpd
125libgnunet_plugin_rest_gns_la_LDFLAGS = \
126 $(GN_PLUGIN_LDFLAGS)
127
128
107libgnunet_plugin_gnsrecord_gns_la_SOURCES = \ 129libgnunet_plugin_gnsrecord_gns_la_SOURCES = \
108 plugin_gnsrecord_gns.c 130 plugin_gnsrecord_gns.c
109libgnunet_plugin_gnsrecord_gns_la_LIBADD = \ 131libgnunet_plugin_gnsrecord_gns_la_LIBADD = \