aboutsummaryrefslogtreecommitdiff
path: root/src/gns/Makefile.am
diff options
context:
space:
mode:
authorSchanzenbach, Martin <mschanzenbach@posteo.de>2019-02-17 22:33:17 +0100
committerSchanzenbach, Martin <mschanzenbach@posteo.de>2019-02-17 22:33:17 +0100
commit003606cc941a4580d787c9970193bb22e307c413 (patch)
treefbf18951270628d70365c6ab83c723020cc491ed /src/gns/Makefile.am
parent09df88645767b8d20075cb3b6d1b2f400a75c605 (diff)
downloadgnunet-003606cc941a4580d787c9970193bb22e307c413.tar.gz
gnunet-003606cc941a4580d787c9970193bb22e307c413.zip
add openssl.cnf
Diffstat (limited to 'src/gns/Makefile.am')
-rw-r--r--src/gns/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/gns/Makefile.am b/src/gns/Makefile.am
index 1abc57d57..13f6a6e52 100644
--- a/src/gns/Makefile.am
+++ b/src/gns/Makefile.am
@@ -79,6 +79,9 @@ bin_PROGRAMS = \
79noinst_PROGRAMS = \ 79noinst_PROGRAMS = \
80 gnunet-gns-benchmark 80 gnunet-gns-benchmark
81 81
82pkgdata_DATA = \
83 openssl.cnf
84
82if HAVE_MHD 85if HAVE_MHD
83if LINUX 86if LINUX
84bin_PROGRAMS += gnunet-bcd 87bin_PROGRAMS += gnunet-bcd
@@ -91,6 +94,15 @@ plugin_LTLIBRARIES = \
91 libgnunet_plugin_block_gns.la \ 94 libgnunet_plugin_block_gns.la \
92 libgnunet_plugin_gnsrecord_gns.la 95 libgnunet_plugin_gnsrecord_gns.la
93 96
97xPFX=$(pkgdatadir)/openssl.cnf
98
99do_subst = $(SED) -e 's,[@]PREFIX[@],${xPFX},g'
100
101gnunet-gns-proxy-setup-ca: gnunet-gns-proxy-setup-ca.in
102 $(do_subst) < $(top_srcdir)/src/gns/gnunet-gns-proxy-setup-ca.in > gnunet-gns-proxy-setup-ca
103 chmod +x gnunet-gns-proxy-setup-ca
104
105
94 106
95libgnunet_plugin_gnsrecord_gns_la_SOURCES = \ 107libgnunet_plugin_gnsrecord_gns_la_SOURCES = \
96 plugin_gnsrecord_gns.c 108 plugin_gnsrecord_gns.c