aboutsummaryrefslogtreecommitdiff
path: root/src/gns/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2022-09-06 12:34:39 +0200
committerMartin Schanzenbach <schanzen@gnunet.org>2022-09-06 12:34:39 +0200
commitafea0eea1ecfa41150fdf9ee052acac75eee6534 (patch)
tree1bb24bac4340262b15640fadbdb7beb8a32f695c /src/gns/Makefile.am
parent1d4e7a0eec5ee96d878cdd0e4e3c62c0676bf2d0 (diff)
downloadgnunet-afea0eea1ecfa41150fdf9ee052acac75eee6534.tar.gz
gnunet-afea0eea1ecfa41150fdf9ee052acac75eee6534.zip
BUILD: Remove gnurl. Improve curl-gnutls detection
Diffstat (limited to 'src/gns/Makefile.am')
-rw-r--r--src/gns/Makefile.am25
1 files changed, 5 insertions, 20 deletions
diff --git a/src/gns/Makefile.am b/src/gns/Makefile.am
index d49e0c5c8..1fe6ce438 100644
--- a/src/gns/Makefile.am
+++ b/src/gns/Makefile.am
@@ -42,19 +42,8 @@ dist_pkgcfg_DATA = \
42lib_LTLIBRARIES = \ 42lib_LTLIBRARIES = \
43 libgnunetgns.la 43 libgnunetgns.la
44 44
45
46if HAVE_GNUTLS 45if HAVE_GNUTLS
47if HAVE_LIBGNURL 46DO_PROXY=gnunet-gns-proxy
48 DO_PROXY=gnunet-gns-proxy
49LIB_GNURL=@LIBGNURL@
50CPP_GNURL=@LIBGNURL_CPPFLAGS@
51else
52if HAVE_LIBCURL
53 DO_PROXY=gnunet-gns-proxy
54LIB_GNURL=@LIBCURL@
55CPP_GNURL=@LIBCURL_CPPFLAGS@
56endif
57endif
58endif 47endif
59 48
60libexec_PROGRAMS = \ 49libexec_PROGRAMS = \
@@ -177,7 +166,7 @@ endif
177 166
178gnunet_gns_proxy_SOURCES = \ 167gnunet_gns_proxy_SOURCES = \
179 gnunet-gns-proxy.c 168 gnunet-gns-proxy.c
180gnunet_gns_proxy_LDADD = $(MHD_LIBS) $(LIB_GNURL) -lgnutls \ 169gnunet_gns_proxy_LDADD = $(MHD_LIBS) @LIBCURL@ -lgnutls \
181 libgnunetgns.la \ 170 libgnunetgns.la \
182 $(top_builddir)/src/identity/libgnunetidentity.la \ 171 $(top_builddir)/src/identity/libgnunetidentity.la \
183 $(top_builddir)/src/util/libgnunetutil.la \ 172 $(top_builddir)/src/util/libgnunetutil.la \
@@ -185,14 +174,14 @@ gnunet_gns_proxy_LDADD = $(MHD_LIBS) $(LIB_GNURL) -lgnutls \
185if HAVE_GNUTLS_DANE 174if HAVE_GNUTLS_DANE
186gnunet_gns_proxy_LDADD += -lgnutls-dane 175gnunet_gns_proxy_LDADD += -lgnutls-dane
187endif 176endif
188gnunet_gns_proxy_CFLAGS = $(MHD_CFLAGS) $(CPP_GNURL) $(AM_CFLAGS) 177gnunet_gns_proxy_CFLAGS = $(MHD_CFLAGS) @LIBCURL_CPPFLAGS@ $(AM_CFLAGS)
189 178
190test_gns_proxy_SOURCES = \ 179test_gns_proxy_SOURCES = \
191 test_gns_proxy.c 180 test_gns_proxy.c
192test_gns_proxy_LDADD = $(MHD_LIBS) $(LIB_GNURL) -lgnutls \ 181test_gns_proxy_LDADD = $(MHD_LIBS) @LIBCURL@ -lgnutls \
193 $(top_builddir)/src/util/libgnunetutil.la \ 182 $(top_builddir)/src/util/libgnunetutil.la \
194 $(GN_LIBINTL) 183 $(GN_LIBINTL)
195test_gns_proxy_CFLAGS = $(MHD_CFLAGS) $(CPP_GNURL) $(AM_CFLAGS) 184test_gns_proxy_CFLAGS = $(MHD_CFLAGS) @LIBCURL_CPPFLAGS@ $(AM_CFLAGS)
196 185
197#gnunet_gns_import_SOURCES = \ 186#gnunet_gns_import_SOURCES = \
198# gnunet-gns-import.c 187# gnunet-gns-import.c
@@ -247,11 +236,9 @@ libgnunet_plugin_block_gns_la_LDFLAGS = \
247 $(GN_PLUGIN_LDFLAGS) 236 $(GN_PLUGIN_LDFLAGS)
248 237
249if HAVE_GNUTLS 238if HAVE_GNUTLS
250if HAVE_LIBGNURL
251check_PROGRAMS = \ 239check_PROGRAMS = \
252 test_gns_proxy 240 test_gns_proxy
253endif 241endif
254endif
255 242
256check_SCRIPTS = \ 243check_SCRIPTS = \
257 test_gns_lookup.sh \ 244 test_gns_lookup.sh \
@@ -273,11 +260,9 @@ check_SCRIPTS = \
273 test_gns_redirect_lookup.sh 260 test_gns_redirect_lookup.sh
274 261
275if HAVE_GNUTLS 262if HAVE_GNUTLS
276if HAVE_LIBGNURL
277check_SCRIPTS += \ 263check_SCRIPTS += \
278 test_proxy.sh 264 test_proxy.sh
279endif 265endif
280endif
281check_SCRIPTS += \ 266check_SCRIPTS += \
282 test_plugin_rest_gns.sh 267 test_plugin_rest_gns.sh
283 268