aboutsummaryrefslogtreecommitdiff
path: root/src/integration-tests/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2012-04-03 14:53:19 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2012-04-03 14:53:19 +0000
commit22cde9cd6e66462442647abf271559d9e3bcb41c (patch)
treeebc9964c2cbecb88db5349d07d3366a42ecf7e28 /src/integration-tests/Makefile.am
parent6fff2c158bad68c4623c6224c59e1bc67cdc17f1 (diff)
downloadgnunet-22cde9cd6e66462442647abf271559d9e3bcb41c.tar.gz
gnunet-22cde9cd6e66462442647abf271559d9e3bcb41c.zip
- more changes
Diffstat (limited to 'src/integration-tests/Makefile.am')
-rw-r--r--src/integration-tests/Makefile.am17
1 files changed, 15 insertions, 2 deletions
diff --git a/src/integration-tests/Makefile.am b/src/integration-tests/Makefile.am
index 9d5177b70..93608824d 100644
--- a/src/integration-tests/Makefile.am
+++ b/src/integration-tests/Makefile.am
@@ -16,7 +16,9 @@ check_PROGRAMS =
16noinst_SCRIPTS = \ 16noinst_SCRIPTS = \
17 gnunet_testing.py \ 17 gnunet_testing.py \
18 gnunet_pyexpect.py \ 18 gnunet_pyexpect.py \
19 test_integration_connection_values_tcp.py 19 test_integration_connection_values_tcp.py \
20 test_integration_connection_values_tcp_udp.py \
21 test_integration_connection_values_tcp_udp_http.py
20 22
21if HAVE_PYTHON_PEXPECT 23if HAVE_PYTHON_PEXPECT
22check_SCRIPTS = \ 24check_SCRIPTS = \
@@ -86,11 +88,20 @@ test_integration_connection_values_tcp.py: test_integration_connection_values_tc
86 $(do_subst) < $(srcdir)/test_integration_connection_values_tcp.py.in > test_integration_connection_values_tcp.py 88 $(do_subst) < $(srcdir)/test_integration_connection_values_tcp.py.in > test_integration_connection_values_tcp.py
87 chmod +x test_integration_connection_values_tcp.py 89 chmod +x test_integration_connection_values_tcp.py
88 90
91test_integration_connection_values_tcp_udp.py: test_integration_connection_values_tcp_udp.py.in Makefile
92 $(do_subst) < $(srcdir)/test_integration_connection_values_tcp_udp.py.in > test_integration_connection_values_tcp_udp.py
93 chmod +x test_integration_connection_values_tcp_udp.py
94
95test_integration_connection_values_tcp_udp_http.py: test_integration_connection_values_tcp_udp_http.py.in Makefile
96 $(do_subst) < $(srcdir)/test_integration_connection_values_tcp_udp_http.py.in > test_integration_connection_values_tcp_udp_http.py
97 chmod +x test_integration_connection_values_tcp_udp_http.py
98
89 99
90EXTRA_DIST = \ 100EXTRA_DIST = \
91 gnunet_testing.py.in \ 101 gnunet_testing.py.in \
92 gnunet_pyexpect.py.in \ 102 gnunet_pyexpect.py.in \
93 test_integration_connection_value.py.in \ 103 test_integration_connection_value_tcp.py.in \
104 test_integration_connection_value_tcp_udp.py.in \
94 test_integration_bootstrap_and_connect.py.in \ 105 test_integration_bootstrap_and_connect.py.in \
95 test_integration_bootstrap_and_connect_and_disconnect.py.in \ 106 test_integration_bootstrap_and_connect_and_disconnect.py.in \
96 test_integration_bootstrap_and_connect_and_disconnect_nat.py.in \ 107 test_integration_bootstrap_and_connect_and_disconnect_nat.py.in \
@@ -103,6 +114,8 @@ EXTRA_DIST = \
103 confs/c_no_nat_client_2.conf \ 114 confs/c_no_nat_client_2.conf \
104 confs/c_no_nat_client.conf \ 115 confs/c_no_nat_client.conf \
105 confs/c_normal_client_tcp.conf \ 116 confs/c_normal_client_tcp.conf \
117 confs/c_normal_client_tcp_udp.conf \
118 confs/c_normal_client_tcp_udp_http.conf \
106 hostkeys/0000-hostkey \ 119 hostkeys/0000-hostkey \
107 hostkeys/0001-hostkey \ 120 hostkeys/0001-hostkey \
108 hostkeys/0002-hostkey \ 121 hostkeys/0002-hostkey \