aboutsummaryrefslogtreecommitdiff
path: root/src/integration-tests/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2012-04-04 14:18:43 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2012-04-04 14:18:43 +0000
commit6e86ae790d66d9f6f5c93d16d1b2367b8364d554 (patch)
tree839623769e6767de75fa6efbabc66723c32d9f7d /src/integration-tests/Makefile.am
parentda438f75b99ca61be3dbc7a9b0726a229711024a (diff)
downloadgnunet-6e86ae790d66d9f6f5c93d16d1b2367b8364d554.tar.gz
gnunet-6e86ae790d66d9f6f5c93d16d1b2367b8364d554.zip
- connection_watchdog tool
Diffstat (limited to 'src/integration-tests/Makefile.am')
-rw-r--r--src/integration-tests/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/src/integration-tests/Makefile.am b/src/integration-tests/Makefile.am
index 8adbf2bcd..31f82170b 100644
--- a/src/integration-tests/Makefile.am
+++ b/src/integration-tests/Makefile.am
@@ -9,10 +9,13 @@ if USE_COVERAGE
9 XLIB = -lgcov 9 XLIB = -lgcov
10endif 10endif
11 11
12bin_PROGRAMS = 12#bin_PROGRAMS = \
13# connection_watchdog
13 14
14check_PROGRAMS = 15check_PROGRAMS =
15 16
17noinst_PROGRAMS = connection_watchdog
18
16noinst_SCRIPTS = \ 19noinst_SCRIPTS = \
17 gnunet_testing.py \ 20 gnunet_testing.py \
18 gnunet_pyexpect.py \ 21 gnunet_pyexpect.py \
@@ -38,6 +41,13 @@ TESTS = \
38 $(check_SCRIPTS) 41 $(check_SCRIPTS)
39endif 42endif
40 43
44connection_watchdog_SOURCE = \
45 connection_watchdog.c
46connection_watchdog_LDADD = \
47 $(top_builddir)/src/core/libgnunetcore.la \
48 $(top_builddir)/src/transport/libgnunettransport.la \
49 $(top_builddir)/src/util/libgnunetutil.la
50
41do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g' 51do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g'
42 52
43%.py: %.py.in Makefile 53%.py: %.py.in Makefile