aboutsummaryrefslogtreecommitdiff
path: root/src/integration-tests/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-12-05 15:55:15 +0000
committerChristian Grothoff <christian@grothoff.org>2013-12-05 15:55:15 +0000
commit78c3084c43eed918329cbf11aeb87b618bf5cdf6 (patch)
tree762963651e76359695822d27cf91e954e92ca4f9 /src/integration-tests/Makefile.am
parenta056cafb1f65d75de49e3832fe172695736315ae (diff)
downloadgnunet-78c3084c43eed918329cbf11aeb87b618bf5cdf6.tar.gz
gnunet-78c3084c43eed918329cbf11aeb87b618bf5cdf6.zip
-fix #3153
Diffstat (limited to 'src/integration-tests/Makefile.am')
-rw-r--r--src/integration-tests/Makefile.am34
1 files changed, 19 insertions, 15 deletions
diff --git a/src/integration-tests/Makefile.am b/src/integration-tests/Makefile.am
index e28e54469..8535a1b2e 100644
--- a/src/integration-tests/Makefile.am
+++ b/src/integration-tests/Makefile.am
@@ -1,7 +1,7 @@
1AM_CPPFLAGS = -I$(top_srcdir)/src/include 1AM_CPPFLAGS = -I$(top_srcdir)/src/include
2 2
3if MINGW 3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols 4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
5endif 5endif
6 6
7if USE_COVERAGE 7if USE_COVERAGE
@@ -31,17 +31,17 @@ check_SCRIPTS = \
31 test_integration_clique_nat.py \ 31 test_integration_clique_nat.py \
32 test_integration_connect_on_restart.py 32 test_integration_connect_on_restart.py
33endif 33endif
34# test_integration_disconnect.py 34# test_integration_disconnect.py
35 35
36if HAVE_MHD 36if HAVE_MHD
37if ENABLE_TEST_RUN 37if ENABLE_TEST_RUN
38TESTS = \ 38TESTS = \
39 $(check_SCRIPTS) 39 $(check_SCRIPTS)
40endif 40endif
41endif 41endif
42 42
43connection_watchdog_SOURCE = \ 43connection_watchdog_SOURCE = \
44 connection_watchdog.c 44 connection_watchdog.c
45connection_watchdog_LDADD = \ 45connection_watchdog_LDADD = \
46 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 46 $(top_builddir)/src/statistics/libgnunetstatistics.la \
47 $(top_builddir)/src/core/libgnunetcore.la \ 47 $(top_builddir)/src/core/libgnunetcore.la \
@@ -56,11 +56,11 @@ do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g'
56 56
57gnunet_testing.py: gnunet_testing.py.in Makefile 57gnunet_testing.py: gnunet_testing.py.in Makefile
58 $(do_subst) < $(srcdir)/gnunet_testing.py.in > gnunet_testing.py 58 $(do_subst) < $(srcdir)/gnunet_testing.py.in > gnunet_testing.py
59 chmod +x gnunet_testing.py 59 chmod +x gnunet_testing.py
60 60
61gnunet_pyexpect.py: gnunet_pyexpect.py.in Makefile 61gnunet_pyexpect.py: gnunet_pyexpect.py.in Makefile
62 $(do_subst) < $(srcdir)/gnunet_pyexpect.py.in > gnunet_pyexpect.py 62 $(do_subst) < $(srcdir)/gnunet_pyexpect.py.in > gnunet_pyexpect.py
63 chmod +x gnunet_pyexpect.py 63 chmod +x gnunet_pyexpect.py
64 64
65test_integration_bootstrap_and_connect.py: test_integration_bootstrap_and_connect.py.in Makefile 65test_integration_bootstrap_and_connect.py: test_integration_bootstrap_and_connect.py.in Makefile
66 $(do_subst) < $(srcdir)/test_integration_bootstrap_and_connect.py.in > test_integration_bootstrap_and_connect.py 66 $(do_subst) < $(srcdir)/test_integration_bootstrap_and_connect.py.in > test_integration_bootstrap_and_connect.py
@@ -85,31 +85,31 @@ test_integration_disconnect.py: test_integration_disconnect.py.in Makefile
85 85
86test_integration_restart.py: test_integration_restart.py.in Makefile 86test_integration_restart.py: test_integration_restart.py.in Makefile
87 $(do_subst) < $(srcdir)/test_integration_restart.py.in > test_integration_restart.py 87 $(do_subst) < $(srcdir)/test_integration_restart.py.in > test_integration_restart.py
88 chmod +x test_integration_restart.py 88 chmod +x test_integration_restart.py
89 89
90test_integration_clique.py: test_integration_clique.py.in Makefile 90test_integration_clique.py: test_integration_clique.py.in Makefile
91 $(do_subst) < $(srcdir)/test_integration_clique.py.in > test_integration_clique.py 91 $(do_subst) < $(srcdir)/test_integration_clique.py.in > test_integration_clique.py
92 chmod +x test_integration_clique.py 92 chmod +x test_integration_clique.py
93 93
94test_integration_clique_nat.py: test_integration_clique_nat.py.in Makefile 94test_integration_clique_nat.py: test_integration_clique_nat.py.in Makefile
95 $(do_subst) < $(srcdir)/test_integration_clique_nat.py.in > test_integration_clique_nat.py 95 $(do_subst) < $(srcdir)/test_integration_clique_nat.py.in > test_integration_clique_nat.py
96 chmod +x test_integration_clique_nat.py 96 chmod +x test_integration_clique_nat.py
97 97
98test_integration_connect_on_restart.py: test_integration_connect_on_restart.py.in Makefile 98test_integration_connect_on_restart.py: test_integration_connect_on_restart.py.in Makefile
99 $(do_subst) < $(srcdir)/test_integration_connect_on_restart.py.in > test_integration_connect_on_restart.py 99 $(do_subst) < $(srcdir)/test_integration_connect_on_restart.py.in > test_integration_connect_on_restart.py
100 chmod +x test_integration_connect_on_restart.py 100 chmod +x test_integration_connect_on_restart.py
101 101
102test_integration_connection_values_tcp.py: test_integration_connection_values_tcp.py.in Makefile 102test_integration_connection_values_tcp.py: test_integration_connection_values_tcp.py.in Makefile
103 $(do_subst) < $(srcdir)/test_integration_connection_values_tcp.py.in > test_integration_connection_values_tcp.py 103 $(do_subst) < $(srcdir)/test_integration_connection_values_tcp.py.in > test_integration_connection_values_tcp.py
104 chmod +x test_integration_connection_values_tcp.py 104 chmod +x test_integration_connection_values_tcp.py
105 105
106test_integration_connection_values_tcp_udp.py: test_integration_connection_values_tcp_udp.py.in Makefile 106test_integration_connection_values_tcp_udp.py: test_integration_connection_values_tcp_udp.py.in Makefile
107 $(do_subst) < $(srcdir)/test_integration_connection_values_tcp_udp.py.in > test_integration_connection_values_tcp_udp.py 107 $(do_subst) < $(srcdir)/test_integration_connection_values_tcp_udp.py.in > test_integration_connection_values_tcp_udp.py
108 chmod +x test_integration_connection_values_tcp_udp.py 108 chmod +x test_integration_connection_values_tcp_udp.py
109 109
110test_integration_connection_values_tcp_udp_http.py: test_integration_connection_values_tcp_udp_http.py.in Makefile 110test_integration_connection_values_tcp_udp_http.py: test_integration_connection_values_tcp_udp_http.py.in Makefile
111 $(do_subst) < $(srcdir)/test_integration_connection_values_tcp_udp_http.py.in > test_integration_connection_values_tcp_udp_http.py 111 $(do_subst) < $(srcdir)/test_integration_connection_values_tcp_udp_http.py.in > test_integration_connection_values_tcp_udp_http.py
112 chmod +x test_integration_connection_values_tcp_udp_http.py 112 chmod +x test_integration_connection_values_tcp_udp_http.py
113 113
114 114
115EXTRA_DIST = \ 115EXTRA_DIST = \
@@ -149,9 +149,13 @@ EXTRA_DIST = \
149 hostkeys/0006-hostkey \ 149 hostkeys/0006-hostkey \
150 hostkeys/0007-hostkey \ 150 hostkeys/0007-hostkey \
151 hostkeys/0008-hostkey \ 151 hostkeys/0008-hostkey \
152 hostkeys/0009-hostkey 152 hostkeys/0009-hostkey
153# test_integration_disconnect_nat.py 153# test_integration_disconnect_nat.py
154 154
155CLEANFILES = \ 155CLEANFILES = \
156 $(check_SCRIPTS) \ 156 $(check_SCRIPTS) \
157 gnunet_pyexpect.py \
158 test_integration_connection_values_tcp.py \
159 test_integration_connection_values_tcp_udp.py \
160 test_integration_connection_values_tcp_udp_http.py \
157 gnunet_testing.py 161 gnunet_testing.py