aboutsummaryrefslogtreecommitdiff
path: root/src/integration-tests/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2016-05-15 22:37:09 +0000
committerChristian Grothoff <christian@grothoff.org>2016-05-15 22:37:09 +0000
commitd6d45150cab02055da7bd6ce612f2db53a07e3e8 (patch)
tree041af3037c37e3677f5e4ed268c9fd20ee458e60 /src/integration-tests/Makefile.am
parent6a4a7af5301434a5083f9904a4fe12766fef5fcf (diff)
downloadgnunet-d6d45150cab02055da7bd6ce612f2db53a07e3e8.tar.gz
gnunet-d6d45150cab02055da7bd6ce612f2db53a07e3e8.zip
only run integration tests if libgnurl/libcurl was available
Diffstat (limited to 'src/integration-tests/Makefile.am')
-rw-r--r--src/integration-tests/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/integration-tests/Makefile.am b/src/integration-tests/Makefile.am
index 8f818ddee..4e96ee173 100644
--- a/src/integration-tests/Makefile.am
+++ b/src/integration-tests/Makefile.am
@@ -28,8 +28,15 @@ endif
28if HAVE_MHD 28if HAVE_MHD
29if ENABLE_TEST_RUN 29if ENABLE_TEST_RUN
30AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH; 30AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;
31if HAVE_LIBGNURL
31TESTS = \ 32TESTS = \
32 $(check_SCRIPTS) 33 $(check_SCRIPTS)
34else
35if HAVE_LIBCURL
36TESTS = \
37 $(check_SCRIPTS)
38endif
39endif
33endif 40endif
34endif 41endif
35 42
@@ -54,7 +61,7 @@ test_integration_bootstrap_and_connect.py: test_integration_bootstrap_and_connec
54test_integration_disconnect.py: test_integration_disconnect.py.in Makefile 61test_integration_disconnect.py: test_integration_disconnect.py.in Makefile
55 $(do_subst) < $(srcdir)/test_integration_disconnect.py.in > test_integration_disconnect.py 62 $(do_subst) < $(srcdir)/test_integration_disconnect.py.in > test_integration_disconnect.py
56 chmod +x test_integration_disconnect.py 63 chmod +x test_integration_disconnect.py
57 64
58test_integration_disconnect_nat.py: test_integration_disconnect_nat.py.in Makefile 65test_integration_disconnect_nat.py: test_integration_disconnect_nat.py.in Makefile
59 $(do_subst) < $(srcdir)/test_integration_disconnect_nat.py.in > test_integration_disconnect_nat.py 66 $(do_subst) < $(srcdir)/test_integration_disconnect_nat.py.in > test_integration_disconnect_nat.py
60 chmod +x test_integration_disconnect_nat.py 67 chmod +x test_integration_disconnect_nat.py