aboutsummaryrefslogtreecommitdiff
path: root/src/integration-tests/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2012-05-31 11:58:18 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2012-05-31 11:58:18 +0000
commitf7c9e5c48036f08ea45357283cc844fd5ead7731 (patch)
tree9a76ee813cc05c14ad4b5b906b2167f37b26e5e6 /src/integration-tests/Makefile.am
parent87df203c4b021746b5a4ff626243f71af7874e6c (diff)
downloadgnunet-f7c9e5c48036f08ea45357283cc844fd5ead7731.tar.gz
gnunet-f7c9e5c48036f08ea45357283cc844fd5ead7731.zip
- base for a testing based connection stability test
Diffstat (limited to 'src/integration-tests/Makefile.am')
-rw-r--r--src/integration-tests/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/integration-tests/Makefile.am b/src/integration-tests/Makefile.am
index e4fcceb60..7c1991b91 100644
--- a/src/integration-tests/Makefile.am
+++ b/src/integration-tests/Makefile.am
@@ -35,6 +35,9 @@ check_SCRIPTS = \
35endif 35endif
36# test_integration_disconnect.py 36# test_integration_disconnect.py
37 37
38check_PROGRAMS = \
39 test_connection_stability
40
38 41
39if ENABLE_TEST_RUN 42if ENABLE_TEST_RUN
40TESTS = \ 43TESTS = \
@@ -112,6 +115,12 @@ test_integration_connection_values_tcp_udp_http.py: test_integration_connection_
112 $(do_subst) < $(srcdir)/test_integration_connection_values_tcp_udp_http.py.in > test_integration_connection_values_tcp_udp_http.py 115 $(do_subst) < $(srcdir)/test_integration_connection_values_tcp_udp_http.py.in > test_integration_connection_values_tcp_udp_http.py
113 chmod +x test_integration_connection_values_tcp_udp_http.py 116 chmod +x test_integration_connection_values_tcp_udp_http.py
114 117
118test_connection_stability_SOURCES = \
119 test_connection_stability.c
120test_connection_stability_LDADD = \
121 $(top_builddir)/src/testing/libgnunettesting.la \
122 $(top_builddir)/src/util/libgnunetutil.la
123
115 124
116EXTRA_DIST = \ 125EXTRA_DIST = \
117 gnunet_testing.py.in \ 126 gnunet_testing.py.in \
@@ -137,6 +146,7 @@ EXTRA_DIST = \
137 confs/c_no_nat_client_http_2.conf\ 146 confs/c_no_nat_client_http_2.conf\
138 confs/c_no_nat_client_http.conf \ 147 confs/c_no_nat_client_http.conf \
139 confs/c_no_nat_client_http_2.conf \ 148 confs/c_no_nat_client_http_2.conf \
149 test_connection_stability.conf \
140 hostkeys/0000-hostkey \ 150 hostkeys/0000-hostkey \
141 hostkeys/0001-hostkey \ 151 hostkeys/0001-hostkey \
142 hostkeys/0002-hostkey \ 152 hostkeys/0002-hostkey \