aboutsummaryrefslogtreecommitdiff
path: root/src/mesh/Makefile.am
diff options
context:
space:
mode:
authorBart Polot <bart@net.in.tum.de>2014-02-04 12:36:31 +0000
committerBart Polot <bart@net.in.tum.de>2014-02-04 12:36:31 +0000
commit0066f847206caa73b90b01a49d88e408934530dd (patch)
treec9a228498b9000dae84821427d3c47a1058ea669 /src/mesh/Makefile.am
parentd8ec84381eb2a365ef40af64d8c88f039ddd1095 (diff)
downloadgnunet-0066f847206caa73b90b01a49d88e408934530dd.tar.gz
gnunet-0066f847206caa73b90b01a49d88e408934530dd.zip
- add hello subsystem to get hellos for known peers
Diffstat (limited to 'src/mesh/Makefile.am')
-rw-r--r--src/mesh/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/mesh/Makefile.am b/src/mesh/Makefile.am
index 1ca4c5a49..5c2dc84dc 100644
--- a/src/mesh/Makefile.am
+++ b/src/mesh/Makefile.am
@@ -69,6 +69,7 @@ gnunet_service_mesh_SOURCES = \
69 gnunet-service-mesh_local.c gnunet-service-mesh_local.h \ 69 gnunet-service-mesh_local.c gnunet-service-mesh_local.h \
70 gnunet-service-mesh_peer.c gnunet-service-mesh_peer.h \ 70 gnunet-service-mesh_peer.c gnunet-service-mesh_peer.h \
71 gnunet-service-mesh_dht.c gnunet-service-mesh_dht.h \ 71 gnunet-service-mesh_dht.c gnunet-service-mesh_dht.h \
72 gnunet-service-mesh_hello.c gnunet-service-mesh_hello.h \
72 mesh_path.c mesh_path.h \ 73 mesh_path.c mesh_path.h \
73 mesh_common.c \ 74 mesh_common.c \
74 gnunet-service-mesh.c 75 gnunet-service-mesh.c
@@ -78,12 +79,14 @@ gnunet_service_mesh_LDADD = \
78 $(top_builddir)/src/core/libgnunetcore.la \ 79 $(top_builddir)/src/core/libgnunetcore.la \
79 $(top_builddir)/src/dht/libgnunetdht.la \ 80 $(top_builddir)/src/dht/libgnunetdht.la \
80 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 81 $(top_builddir)/src/statistics/libgnunetstatistics.la \
82 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
81 $(top_builddir)/src/block/libgnunetblock.la 83 $(top_builddir)/src/block/libgnunetblock.la
82gnunet_service_mesh_DEPENDENCIES = \ 84gnunet_service_mesh_DEPENDENCIES = \
83 $(top_builddir)/src/util/libgnunetutil.la \ 85 $(top_builddir)/src/util/libgnunetutil.la \
84 $(top_builddir)/src/core/libgnunetcore.la \ 86 $(top_builddir)/src/core/libgnunetcore.la \
85 $(top_builddir)/src/dht/libgnunetdht.la \ 87 $(top_builddir)/src/dht/libgnunetdht.la \
86 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 88 $(top_builddir)/src/statistics/libgnunetstatistics.la \
89 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
87 $(top_builddir)/src/block/libgnunetblock.la 90 $(top_builddir)/src/block/libgnunetblock.la
88if LINUX 91if LINUX
89 gnunet_service_mesh_LDFLAGS = -lrt 92 gnunet_service_mesh_LDFLAGS = -lrt