aboutsummaryrefslogtreecommitdiff
path: root/src/mesh/Makefile.am
diff options
context:
space:
mode:
authorBart Polot <bart@net.in.tum.de>2014-05-07 12:07:16 +0000
committerBart Polot <bart@net.in.tum.de>2014-05-07 12:07:16 +0000
commit41716952f1d0508fb621cb5fec31406d3bd96192 (patch)
tree0ea8e1a1397babe96db05d17cb7618fc69bb88c7 /src/mesh/Makefile.am
parent74794f20cec6fbbd007e0921e7a347655050c024 (diff)
downloadgnunet-41716952f1d0508fb621cb5fec31406d3bd96192.tar.gz
gnunet-41716952f1d0508fb621cb5fec31406d3bd96192.zip
Renamed directory
Diffstat (limited to 'src/mesh/Makefile.am')
-rw-r--r--src/mesh/Makefile.am194
1 files changed, 0 insertions, 194 deletions
diff --git a/src/mesh/Makefile.am b/src/mesh/Makefile.am
deleted file mode 100644
index e9aaec402..000000000
--- a/src/mesh/Makefile.am
+++ /dev/null
@@ -1,194 +0,0 @@
1AM_CPPFLAGS = -I$(top_srcdir)/src/include
2
3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
5endif
6
7if USE_COVERAGE
8 AM_CFLAGS = --coverage -O0
9 XLIB = -lgcov
10endif
11
12pkgcfgdir= $(pkgdatadir)/config.d/
13
14libexecdir= $(pkglibdir)/libexec/
15
16pkgcfg_DATA = \
17 cadet.conf
18
19plugindir = $(libdir)/gnunet
20
21AM_CLFAGS = -g
22
23libexec_PROGRAMS = \
24 gnunet-service-cadet $(EXP_LIBEXEC)
25
26bin_PROGRAMS = \
27 gnunet-cadet
28
29lib_LTLIBRARIES = \
30 libgnunetcadet.la $(EXP_LIB)
31
32libgnunetcadet_la_SOURCES = \
33 cadet_api.c cadet_common.c
34libgnunetcadet_la_LIBADD = \
35 $(top_builddir)/src/util/libgnunetutil.la \
36 $(XLIB) \
37 $(LTLIBINTL)
38libgnunetcadet_la_LDFLAGS = \
39 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
40 -version-info 5:0:0
41
42gnunet_cadet_SOURCES = \
43 gnunet-cadet.c
44gnunet_cadet_LDADD = \
45 $(top_builddir)/src/cadet/libgnunetcadet.la \
46 $(top_builddir)/src/util/libgnunetutil.la
47gnunet_cadet_DEPENDENCIES = \
48 libgnunetcadet.la
49
50gnunet_service_cadet_SOURCES = \
51 gnunet-service-cadet_tunnel.c gnunet-service-cadet_tunnel.h \
52 gnunet-service-cadet_connection.c gnunet-service-cadet_connection.h \
53 gnunet-service-cadet_channel.c gnunet-service-cadet_channel.h \
54 gnunet-service-cadet_local.c gnunet-service-cadet_local.h \
55 gnunet-service-cadet_peer.c gnunet-service-cadet_peer.h \
56 gnunet-service-cadet_dht.c gnunet-service-cadet_dht.h \
57 gnunet-service-cadet_hello.c gnunet-service-cadet_hello.h \
58 cadet_path.c cadet_path.h \
59 cadet_common.c \
60 gnunet-service-cadet.c
61gnunet_service_cadet_CFLAGS = $(AM_CFLAGS)
62gnunet_service_cadet_LDADD = \
63 $(top_builddir)/src/util/libgnunetutil.la \
64 $(top_builddir)/src/transport/libgnunettransport.la \
65 $(top_builddir)/src/core/libgnunetcore.la \
66 $(top_builddir)/src/dht/libgnunetdht.la \
67 $(top_builddir)/src/statistics/libgnunetstatistics.la \
68 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
69 $(top_builddir)/src/hello/libgnunethello.la \
70 $(top_builddir)/src/block/libgnunetblock.la
71gnunet_service_cadet_DEPENDENCIES = \
72 $(top_builddir)/src/util/libgnunetutil.la \
73 $(top_builddir)/src/transport/libgnunettransport.la \
74 $(top_builddir)/src/core/libgnunetcore.la \
75 $(top_builddir)/src/dht/libgnunetdht.la \
76 $(top_builddir)/src/statistics/libgnunetstatistics.la \
77 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
78 $(top_builddir)/src/hello/libgnunethello.la \
79 $(top_builddir)/src/block/libgnunetblock.la
80if LINUX
81 gnunet_service_cadet_LDFLAGS = -lrt
82endif
83
84
85if HAVE_TESTING
86 noinst_LIBRARIES = libgnunetcadettest.a $(noinst_LIB_EXP)
87 noinst_PROGRAMS = gnunet-cadet-profiler
88endif
89
90libgnunetcadettest_a_SOURCES = \
91 cadet_test_lib.c cadet_test_lib.h
92libgnunetcadettest_a_LIBADD = \
93 $(top_builddir)/src/util/libgnunetutil.la \
94 $(top_builddir)/src/testbed/libgnunettestbed.la \
95 $(top_builddir)/src/cadet/libgnunetcadet.la
96libgnunetcadettest_a_DEPENDENCIES = \
97 libgnunetcadet.la
98
99if HAVE_TESTING
100check_PROGRAMS = \
101 test_cadet_single \
102 test_cadet_local \
103 test_cadet_forward \
104 test_cadet_signal \
105 test_cadet_keepalive \
106 test_cadet_speed \
107 test_cadet_speed_ack \
108 test_cadet_speed_backwards \
109 test_cadet_speed_reliable \
110 test_cadet_speed_reliable_backwards
111endif
112
113ld_cadet_test_lib = \
114 $(top_builddir)/src/util/libgnunetutil.la \
115 $(top_builddir)/src/testing/libgnunettesting.la \
116 $(top_builddir)/src/cadet/libgnunetcadettest.a \
117 $(top_builddir)/src/cadet/libgnunetcadet.la \
118 $(top_builddir)/src/testbed/libgnunettestbed.la \
119 $(top_builddir)/src/statistics/libgnunetstatistics.la
120
121dep_cadet_test_lib = \
122 libgnunetcadet.la \
123 libgnunetcadettest.a \
124 $(top_builddir)/src/statistics/libgnunetstatistics.la
125
126
127gnunet_cadet_profiler_SOURCES = \
128 gnunet-cadet-profiler.c
129gnunet_cadet_profiler_LDADD = $(ld_cadet_test_lib)
130gnunet_cadet_profiler_DEPENDENCIES = $(dep_cadet_test_lib)
131
132
133test_cadet_single_SOURCES = \
134 test_cadet_single.c
135test_cadet_single_LDADD = $(ld_cadet_test_lib)
136test_cadet_single_DEPENDENCIES = $(dep_cadet_test_lib)
137
138test_cadet_local_SOURCES = \
139 test_cadet_local.c
140test_cadet_local_LDADD = $(ld_cadet_test_lib)
141test_cadet_local_DEPENDENCIES = $(dep_cadet_test_lib)
142
143test_cadet_forward_SOURCES = \
144 test_cadet.c
145test_cadet_forward_LDADD = $(ld_cadet_test_lib)
146test_cadet_forward_DEPENDENCIES = $(dep_cadet_test_lib)
147
148test_cadet_signal_SOURCES = \
149 test_cadet.c
150test_cadet_signal_LDADD = $(ld_cadet_test_lib)
151test_cadet_signal_DEPENDENCIES = $(dep_cadet_test_lib)
152
153test_cadet_keepalive_SOURCES = \
154 test_cadet.c
155test_cadet_keepalive_LDADD = $(ld_cadet_test_lib)
156test_cadet_keepalive_DEPENDENCIES = $(dep_cadet_test_lib)
157
158test_cadet_speed_SOURCES = \
159 test_cadet.c
160test_cadet_speed_LDADD = $(ld_cadet_test_lib)
161test_cadet_speed_DEPENDENCIES = $(dep_cadet_test_lib)
162
163test_cadet_speed_ack_SOURCES = \
164 test_cadet.c
165test_cadet_speed_ack_LDADD = $(ld_cadet_test_lib)
166test_cadet_speed_ack_DEPENDENCIES = $(dep_cadet_test_lib)
167
168test_cadet_speed_backwards_SOURCES = \
169 test_cadet.c
170test_cadet_speed_backwards_LDADD = $(ld_cadet_test_lib)
171test_cadet_speed_backwards_DEPENDENCIES = $(dep_cadet_test_lib)
172
173test_cadet_speed_reliable_SOURCES = \
174 test_cadet.c
175test_cadet_speed_reliable_LDADD = $(ld_cadet_test_lib)
176test_cadet_speed_reliable_DEPENDENCIES = $(dep_cadet_test_lib)
177
178test_cadet_speed_reliable_backwards_SOURCES = \
179 test_cadet.c
180test_cadet_speed_reliable_backwards_LDADD = $(ld_cadet_test_lib)
181test_cadet_speed_reliable_backwards_DEPENDENCIES = $(dep_cadet_test_lib)
182
183
184if ENABLE_TEST_RUN
185AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;
186TESTS = \
187 $(check_PROGRAMS)
188endif
189
190EXTRA_DIST = \
191 cadet.h cadet_protocol.h \
192 test_cadet.conf \
193 test_cadet_drop.conf
194