aboutsummaryrefslogtreecommitdiff
path: root/src/mesh/Makefile.am
diff options
context:
space:
mode:
authorLRN <lrn1986@gmail.com>2013-05-22 22:52:48 +0000
committerLRN <lrn1986@gmail.com>2013-05-22 22:52:48 +0000
commit5fbb91ae6390397376076be6f6d938f5ce01d9e4 (patch)
tree0722e4490f081134ff21f0d779bd1f5f5ae2abde /src/mesh/Makefile.am
parent2dc1ea3556597729487f1370731f85eb1af821dd (diff)
downloadgnunet-5fbb91ae6390397376076be6f6d938f5ce01d9e4.tar.gz
gnunet-5fbb91ae6390397376076be6f6d938f5ce01d9e4.zip
Try to fix mesh dependencies
Diffstat (limited to 'src/mesh/Makefile.am')
-rw-r--r--src/mesh/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/mesh/Makefile.am b/src/mesh/Makefile.am
index 3531d0647..135f2bce3 100644
--- a/src/mesh/Makefile.am
+++ b/src/mesh/Makefile.am
@@ -25,6 +25,9 @@ if HAVE_EXPERIMENTAL
25 EXP_LIBEXEC = gnunet-service-mesh-new 25 EXP_LIBEXEC = gnunet-service-mesh-new
26 EXP_TESTS = \ 26 EXP_TESTS = \
27 test_mesh2_local 27 test_mesh2_local
28 MESH_DEP = $(top_builddir)/src/mesh/libgnunetmesh2.la
29else
30 MESH_DEP = $(top_builddir)/src/mesh/libgnunetmesh.la
28endif 31endif
29 32
30libexec_PROGRAMS = \ 33libexec_PROGRAMS = \
@@ -159,7 +162,7 @@ test_mesh_api_SOURCES = \
159test_mesh_api_LDADD = \ 162test_mesh_api_LDADD = \
160 $(top_builddir)/src/util/libgnunetutil.la \ 163 $(top_builddir)/src/util/libgnunetutil.la \
161 $(top_builddir)/src/testing/libgnunettesting.la \ 164 $(top_builddir)/src/testing/libgnunettesting.la \
162 $(top_builddir)/src/mesh/libgnunetmesh2.la 165 $(MESH_DEP)
163test_mesh_api_DEPENDENCIES = \ 166test_mesh_api_DEPENDENCIES = \
164 libgnunetmesh.la \ 167 libgnunetmesh.la \
165 $(top_builddir)/src/util/libgnunetutil.la 168 $(top_builddir)/src/util/libgnunetutil.la
@@ -275,7 +278,7 @@ test_mesh2_local_SOURCES = \
275test_mesh2_local_LDADD = \ 278test_mesh2_local_LDADD = \
276 $(top_builddir)/src/util/libgnunetutil.la \ 279 $(top_builddir)/src/util/libgnunetutil.la \
277 $(top_builddir)/src/testing/libgnunettesting.la \ 280 $(top_builddir)/src/testing/libgnunettesting.la \
278 $(top_builddir)/src/mesh/libgnunetmesh2.la 281 $(MESH_DEP)
279test_mesh2_local_DEPENDENCIES = \ 282test_mesh2_local_DEPENDENCIES = \
280 libgnunetmesh2.la 283 libgnunetmesh2.la
281 284