aboutsummaryrefslogtreecommitdiff
path: root/src/mesh/Makefile.am
diff options
context:
space:
mode:
authorBart Polot <bart@net.in.tum.de>2013-05-16 14:45:29 +0000
committerBart Polot <bart@net.in.tum.de>2013-05-16 14:45:29 +0000
commit60dc97e5f97fe81014495f0cb28f7c7815b667d7 (patch)
treedc8c0ce076923d81749dcaf5720fa6269e16f20d /src/mesh/Makefile.am
parentf5a00303d231d09028cd15296a2382bf48074a1e (diff)
downloadgnunet-60dc97e5f97fe81014495f0cb28f7c7815b667d7.tar.gz
gnunet-60dc97e5f97fe81014495f0cb28f7c7815b667d7.zip
- add mesh2 local testcase
Diffstat (limited to 'src/mesh/Makefile.am')
-rw-r--r--src/mesh/Makefile.am20
1 files changed, 17 insertions, 3 deletions
diff --git a/src/mesh/Makefile.am b/src/mesh/Makefile.am
index d7dada67c..3531d0647 100644
--- a/src/mesh/Makefile.am
+++ b/src/mesh/Makefile.am
@@ -23,6 +23,8 @@ AM_CLFAGS = -g
23if HAVE_EXPERIMENTAL 23if HAVE_EXPERIMENTAL
24 EXP_LIB = libgnunetmesh2.la 24 EXP_LIB = libgnunetmesh2.la
25 EXP_LIBEXEC = gnunet-service-mesh-new 25 EXP_LIBEXEC = gnunet-service-mesh-new
26 EXP_TESTS = \
27 test_mesh2_local
26endif 28endif
27 29
28libexec_PROGRAMS = \ 30libexec_PROGRAMS = \
@@ -93,7 +95,7 @@ gnunet_service_mesh_LDFLAGS = -lrt
93endif 95endif
94 96
95gnunet_mesh_SOURCES = \ 97gnunet_mesh_SOURCES = \
96 gnunet-mesh.c 98 gnunet-mesh.c
97gnunet_mesh_LDADD = \ 99gnunet_mesh_LDADD = \
98 $(top_builddir)/src/mesh/libgnunetmesh.la \ 100 $(top_builddir)/src/mesh/libgnunetmesh.la \
99 $(top_builddir)/src/util/libgnunetutil.la 101 $(top_builddir)/src/util/libgnunetutil.la
@@ -149,7 +151,8 @@ check_PROGRAMS = \
149 test_mesh_small_speed_nobuf \ 151 test_mesh_small_speed_nobuf \
150 test_mesh_small_speed_backwards \ 152 test_mesh_small_speed_backwards \
151 test_mesh_small_speed_nobuf_backwards \ 153 test_mesh_small_speed_nobuf_backwards \
152 test_mesh_small_speed_ack 154 test_mesh_small_speed_ack \
155 $(EXP_TESTS)
153 156
154test_mesh_api_SOURCES = \ 157test_mesh_api_SOURCES = \
155 test_mesh_api.c 158 test_mesh_api.c
@@ -267,8 +270,19 @@ test_mesh_small_speed_nobuf_backwards_LDADD = $(ld_mesh_test_lib)
267test_mesh_small_speed_nobuf_backwards_DEPENDENCIES = $(dep_mesh_test_lib) 270test_mesh_small_speed_nobuf_backwards_DEPENDENCIES = $(dep_mesh_test_lib)
268 271
269 272
273test_mesh2_local_SOURCES = \
274 test_mesh2_local.c
275test_mesh2_local_LDADD = \
276 $(top_builddir)/src/util/libgnunetutil.la \
277 $(top_builddir)/src/testing/libgnunettesting.la \
278 $(top_builddir)/src/mesh/libgnunetmesh2.la
279test_mesh2_local_DEPENDENCIES = \
280 libgnunetmesh2.la
281
270if ENABLE_TEST_RUN 282if ENABLE_TEST_RUN
271TESTS = test_mesh_api \ 283TESTS = \
284 $(EXP_TESTS) \
285 test_mesh_api \
272 test_mesh_tree_api \ 286 test_mesh_tree_api \
273 test_mesh_local_1 test_mesh_local_2 \ 287 test_mesh_local_1 test_mesh_local_2 \
274 test_mesh_local_traffic_fwd \ 288 test_mesh_local_traffic_fwd \