aboutsummaryrefslogtreecommitdiff
path: root/src/mesh/Makefile.am
diff options
context:
space:
mode:
authorBart Polot <bart@net.in.tum.de>2013-06-10 14:38:05 +0000
committerBart Polot <bart@net.in.tum.de>2013-06-10 14:38:05 +0000
commit7f61d08dcf2e6e895bf01a8c647372c4ef6d04fc (patch)
tree96f2a3cce839611567e03c19a2857082cd6a51d7 /src/mesh/Makefile.am
parent2426176ae7761fc909d85377a7f39b67c9d776c9 (diff)
downloadgnunet-7f61d08dcf2e6e895bf01a8c647372c4ef6d04fc.tar.gz
gnunet-7f61d08dcf2e6e895bf01a8c647372c4ef6d04fc.zip
- add framework for mesh2 mutipeer tests
Diffstat (limited to 'src/mesh/Makefile.am')
-rw-r--r--src/mesh/Makefile.am46
1 files changed, 33 insertions, 13 deletions
diff --git a/src/mesh/Makefile.am b/src/mesh/Makefile.am
index 135f2bce3..5b59a4652 100644
--- a/src/mesh/Makefile.am
+++ b/src/mesh/Makefile.am
@@ -21,13 +21,12 @@ plugindir = $(libdir)/gnunet
21AM_CLFAGS = -g 21AM_CLFAGS = -g
22 22
23if HAVE_EXPERIMENTAL 23if HAVE_EXPERIMENTAL
24 noinst_LIB_EXP = libgnunetmesh2test.a
24 EXP_LIB = libgnunetmesh2.la 25 EXP_LIB = libgnunetmesh2.la
25 EXP_LIBEXEC = gnunet-service-mesh-new 26 EXP_LIBEXEC = gnunet-service-mesh-new
26 EXP_TESTS = \ 27 EXP_TESTS = \
27 test_mesh2_local 28 test_mesh2_local \
28 MESH_DEP = $(top_builddir)/src/mesh/libgnunetmesh2.la 29 test_mesh2_small_forward
29else
30 MESH_DEP = $(top_builddir)/src/mesh/libgnunetmesh.la
31endif 30endif
32 31
33libexec_PROGRAMS = \ 32libexec_PROGRAMS = \
@@ -127,7 +126,7 @@ gnunet_service_mesh_new_LDFLAGS = -lrt
127endif 126endif
128 127
129 128
130noinst_LIBRARIES = libgnunetmeshtest.a 129noinst_LIBRARIES = libgnunetmeshtest.a $(noinst_LIB_EXP)
131 130
132libgnunetmeshtest_a_SOURCES = \ 131libgnunetmeshtest_a_SOURCES = \
133 mesh_test_lib.c mesh_test_lib.h 132 mesh_test_lib.c mesh_test_lib.h
@@ -138,6 +137,15 @@ libgnunetmeshtest_a_LIBADD = \
138libgnunetmeshtest_a_DEPENDENCIES = \ 137libgnunetmeshtest_a_DEPENDENCIES = \
139 libgnunetmesh.la 138 libgnunetmesh.la
140 139
140libgnunetmesh2test_a_SOURCES = \
141 mesh2_test_lib.c mesh2_test_lib.h
142libgnunetmesh2test_a_LIBADD = \
143 $(top_builddir)/src/util/libgnunetutil.la \
144 $(top_builddir)/src/testbed/libgnunettestbed.la \
145 $(top_builddir)/src/mesh/libgnunetmesh2.la
146libgnunetmesh2test_a_DEPENDENCIES = \
147 libgnunetmesh2.la
148
141 149
142check_PROGRAMS = \ 150check_PROGRAMS = \
143 test_mesh_api \ 151 test_mesh_api \
@@ -162,7 +170,7 @@ test_mesh_api_SOURCES = \
162test_mesh_api_LDADD = \ 170test_mesh_api_LDADD = \
163 $(top_builddir)/src/util/libgnunetutil.la \ 171 $(top_builddir)/src/util/libgnunetutil.la \
164 $(top_builddir)/src/testing/libgnunettesting.la \ 172 $(top_builddir)/src/testing/libgnunettesting.la \
165 $(MESH_DEP) 173 $(top_builddir)/src/mesh/libgnunetmesh.la
166test_mesh_api_DEPENDENCIES = \ 174test_mesh_api_DEPENDENCIES = \
167 libgnunetmesh.la \ 175 libgnunetmesh.la \
168 $(top_builddir)/src/util/libgnunetutil.la 176 $(top_builddir)/src/util/libgnunetutil.la
@@ -273,15 +281,27 @@ test_mesh_small_speed_nobuf_backwards_LDADD = $(ld_mesh_test_lib)
273test_mesh_small_speed_nobuf_backwards_DEPENDENCIES = $(dep_mesh_test_lib) 281test_mesh_small_speed_nobuf_backwards_DEPENDENCIES = $(dep_mesh_test_lib)
274 282
275 283
276test_mesh2_local_SOURCES = \ 284ld_mesh2_test_lib = \
277 test_mesh2_local.c 285 $(top_builddir)/src/mesh/libgnunetmesh2test.a \
278test_mesh2_local_LDADD = \ 286 $(top_builddir)/src/mesh/libgnunetmesh2.la \
279 $(top_builddir)/src/util/libgnunetutil.la \ 287 $(top_builddir)/src/testbed/libgnunettestbed.la \
280 $(top_builddir)/src/testing/libgnunettesting.la \ 288 $(top_builddir)/src/util/libgnunetutil.la
281 $(MESH_DEP) 289
282test_mesh2_local_DEPENDENCIES = \ 290dep_mesh2_test_lib = \
291 libgnunetmesh2test.a \
283 libgnunetmesh2.la 292 libgnunetmesh2.la
284 293
294test_mesh2_local_SOURCES = \
295 test_mesh2_local.c
296test_mesh2_local_LDADD = $(ld_mesh2_test_lib)
297test_mesh2_local_DEPENDENCIES = $(dep_mesh2_test_lib)
298
299test_mesh2_small_forward_SOURCES = \
300 test_mesh2_small.c
301test_mesh2_small_forward_LDADD = $(ld_mesh2_test_lib)
302test_mesh2_small_forward_DEPENDENCIES = $(dep_mesh2_test_lib)
303
304
285if ENABLE_TEST_RUN 305if ENABLE_TEST_RUN
286TESTS = \ 306TESTS = \
287 $(EXP_TESTS) \ 307 $(EXP_TESTS) \