aboutsummaryrefslogtreecommitdiff
path: root/src/mesh/Makefile.am
diff options
context:
space:
mode:
authorBart Polot <bart@net.in.tum.de>2013-08-12 11:53:23 +0000
committerBart Polot <bart@net.in.tum.de>2013-08-12 11:53:23 +0000
commita1597ce8dcfa7be6fdb323ecdf21c351a818a16f (patch)
tree2f6ec6ee98a8c8c4ed29be7abdbd90e1c2eb2c04 /src/mesh/Makefile.am
parent91e06fa0095e2e2cd813bc692a8ae224836325bf (diff)
downloadgnunet-a1597ce8dcfa7be6fdb323ecdf21c351a818a16f.tar.gz
gnunet-a1597ce8dcfa7be6fdb323ecdf21c351a818a16f.zip
- add exerimental compilation of -enc
Diffstat (limited to 'src/mesh/Makefile.am')
-rw-r--r--src/mesh/Makefile.am19
1 files changed, 17 insertions, 2 deletions
diff --git a/src/mesh/Makefile.am b/src/mesh/Makefile.am
index 8e6ea38d4..c3d478138 100644
--- a/src/mesh/Makefile.am
+++ b/src/mesh/Makefile.am
@@ -20,8 +20,11 @@ plugindir = $(libdir)/gnunet
20 20
21AM_CLFAGS = -g 21AM_CLFAGS = -g
22 22
23EXP_LIBEXEC = 23EXP_LIB = \
24# gnunet-service-mesh-enc 24 libgnunetmeshenc.la
25
26EXP_LIBEXEC = \
27 gnunet-service-mesh-enc
25 28
26libexec_PROGRAMS = \ 29libexec_PROGRAMS = \
27 gnunet-service-mesh $(EXP_LIBEXEC) 30 gnunet-service-mesh $(EXP_LIBEXEC)
@@ -57,6 +60,18 @@ libgnunetmesh_la_LDFLAGS = \
57 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 60 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
58 -version-info 3:0:0 61 -version-info 3:0:0
59 62
63
64libgnunetmeshenc_la_SOURCES = \
65 mesh_api_enc.c mesh_common.c
66libgnunetmeshenc_la_LIBADD = \
67 $(top_builddir)/src/util/libgnunetutil.la \
68 $(XLIB) \
69 $(LTLIBINTL)
70libgnunetmeshenc_la_LDFLAGS = \
71 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
72 -version-info 1:0:0
73
74
60gnunet_mesh_SOURCES = \ 75gnunet_mesh_SOURCES = \
61 gnunet-mesh.c 76 gnunet-mesh.c
62gnunet_mesh_LDADD = \ 77gnunet_mesh_LDADD = \