aboutsummaryrefslogtreecommitdiff
path: root/src/mesh/Makefile.am
diff options
context:
space:
mode:
authorBart Polot <bart@net.in.tum.de>2014-05-07 12:06:53 +0000
committerBart Polot <bart@net.in.tum.de>2014-05-07 12:06:53 +0000
commitaa52254dd92fe8d0658b83807b3141a765cc86a5 (patch)
tree5af477d470436b1490912d2748daa8fe9241ce07 /src/mesh/Makefile.am
parentbe4c79e4cd4a8f118c5577874f0c95e253359595 (diff)
downloadgnunet-aa52254dd92fe8d0658b83807b3141a765cc86a5.tar.gz
gnunet-aa52254dd92fe8d0658b83807b3141a765cc86a5.zip
- fix makefile
Diffstat (limited to 'src/mesh/Makefile.am')
-rw-r--r--src/mesh/Makefile.am202
1 files changed, 101 insertions, 101 deletions
diff --git a/src/mesh/Makefile.am b/src/mesh/Makefile.am
index 8323d367e..e9aaec402 100644
--- a/src/mesh/Makefile.am
+++ b/src/mesh/Makefile.am
@@ -14,52 +14,52 @@ pkgcfgdir= $(pkgdatadir)/config.d/
14libexecdir= $(pkglibdir)/libexec/ 14libexecdir= $(pkglibdir)/libexec/
15 15
16pkgcfg_DATA = \ 16pkgcfg_DATA = \
17 mesh.conf 17 cadet.conf
18 18
19plugindir = $(libdir)/gnunet 19plugindir = $(libdir)/gnunet
20 20
21AM_CLFAGS = -g 21AM_CLFAGS = -g
22 22
23libexec_PROGRAMS = \ 23libexec_PROGRAMS = \
24 gnunet-service-mesh $(EXP_LIBEXEC) 24 gnunet-service-cadet $(EXP_LIBEXEC)
25 25
26bin_PROGRAMS = \ 26bin_PROGRAMS = \
27 gnunet-mesh 27 gnunet-cadet
28 28
29lib_LTLIBRARIES = \ 29lib_LTLIBRARIES = \
30 libgnunetmesh.la $(EXP_LIB) 30 libgnunetcadet.la $(EXP_LIB)
31 31
32libgnunetmesh_la_SOURCES = \ 32libgnunetcadet_la_SOURCES = \
33 mesh_api.c mesh_common.c 33 cadet_api.c cadet_common.c
34libgnunetmesh_la_LIBADD = \ 34libgnunetcadet_la_LIBADD = \
35 $(top_builddir)/src/util/libgnunetutil.la \ 35 $(top_builddir)/src/util/libgnunetutil.la \
36 $(XLIB) \ 36 $(XLIB) \
37 $(LTLIBINTL) 37 $(LTLIBINTL)
38libgnunetmesh_la_LDFLAGS = \ 38libgnunetcadet_la_LDFLAGS = \
39 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 39 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
40 -version-info 5:0:0 40 -version-info 5:0:0
41 41
42gnunet_mesh_SOURCES = \ 42gnunet_cadet_SOURCES = \
43 gnunet-mesh.c 43 gnunet-cadet.c
44gnunet_mesh_LDADD = \ 44gnunet_cadet_LDADD = \
45 $(top_builddir)/src/mesh/libgnunetmesh.la \ 45 $(top_builddir)/src/cadet/libgnunetcadet.la \
46 $(top_builddir)/src/util/libgnunetutil.la 46 $(top_builddir)/src/util/libgnunetutil.la
47gnunet_mesh_DEPENDENCIES = \ 47gnunet_cadet_DEPENDENCIES = \
48 libgnunetmesh.la 48 libgnunetcadet.la
49 49
50gnunet_service_mesh_SOURCES = \ 50gnunet_service_cadet_SOURCES = \
51 gnunet-service-mesh_tunnel.c gnunet-service-mesh_tunnel.h \ 51 gnunet-service-cadet_tunnel.c gnunet-service-cadet_tunnel.h \
52 gnunet-service-mesh_connection.c gnunet-service-mesh_connection.h \ 52 gnunet-service-cadet_connection.c gnunet-service-cadet_connection.h \
53 gnunet-service-mesh_channel.c gnunet-service-mesh_channel.h \ 53 gnunet-service-cadet_channel.c gnunet-service-cadet_channel.h \
54 gnunet-service-mesh_local.c gnunet-service-mesh_local.h \ 54 gnunet-service-cadet_local.c gnunet-service-cadet_local.h \
55 gnunet-service-mesh_peer.c gnunet-service-mesh_peer.h \ 55 gnunet-service-cadet_peer.c gnunet-service-cadet_peer.h \
56 gnunet-service-mesh_dht.c gnunet-service-mesh_dht.h \ 56 gnunet-service-cadet_dht.c gnunet-service-cadet_dht.h \
57 gnunet-service-mesh_hello.c gnunet-service-mesh_hello.h \ 57 gnunet-service-cadet_hello.c gnunet-service-cadet_hello.h \
58 mesh_path.c mesh_path.h \ 58 cadet_path.c cadet_path.h \
59 mesh_common.c \ 59 cadet_common.c \
60 gnunet-service-mesh.c 60 gnunet-service-cadet.c
61gnunet_service_mesh_CFLAGS = $(AM_CFLAGS) 61gnunet_service_cadet_CFLAGS = $(AM_CFLAGS)
62gnunet_service_mesh_LDADD = \ 62gnunet_service_cadet_LDADD = \
63 $(top_builddir)/src/util/libgnunetutil.la \ 63 $(top_builddir)/src/util/libgnunetutil.la \
64 $(top_builddir)/src/transport/libgnunettransport.la \ 64 $(top_builddir)/src/transport/libgnunettransport.la \
65 $(top_builddir)/src/core/libgnunetcore.la \ 65 $(top_builddir)/src/core/libgnunetcore.la \
@@ -68,7 +68,7 @@ gnunet_service_mesh_LDADD = \
68 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \ 68 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
69 $(top_builddir)/src/hello/libgnunethello.la \ 69 $(top_builddir)/src/hello/libgnunethello.la \
70 $(top_builddir)/src/block/libgnunetblock.la 70 $(top_builddir)/src/block/libgnunetblock.la
71gnunet_service_mesh_DEPENDENCIES = \ 71gnunet_service_cadet_DEPENDENCIES = \
72 $(top_builddir)/src/util/libgnunetutil.la \ 72 $(top_builddir)/src/util/libgnunetutil.la \
73 $(top_builddir)/src/transport/libgnunettransport.la \ 73 $(top_builddir)/src/transport/libgnunettransport.la \
74 $(top_builddir)/src/core/libgnunetcore.la \ 74 $(top_builddir)/src/core/libgnunetcore.la \
@@ -78,107 +78,107 @@ gnunet_service_mesh_DEPENDENCIES = \
78 $(top_builddir)/src/hello/libgnunethello.la \ 78 $(top_builddir)/src/hello/libgnunethello.la \
79 $(top_builddir)/src/block/libgnunetblock.la 79 $(top_builddir)/src/block/libgnunetblock.la
80if LINUX 80if LINUX
81 gnunet_service_mesh_LDFLAGS = -lrt 81 gnunet_service_cadet_LDFLAGS = -lrt
82endif 82endif
83 83
84 84
85if HAVE_TESTING 85if HAVE_TESTING
86 noinst_LIBRARIES = libgnunetmeshtest.a $(noinst_LIB_EXP) 86 noinst_LIBRARIES = libgnunetcadettest.a $(noinst_LIB_EXP)
87 noinst_PROGRAMS = gnunet-mesh-profiler 87 noinst_PROGRAMS = gnunet-cadet-profiler
88endif 88endif
89 89
90libgnunetmeshtest_a_SOURCES = \ 90libgnunetcadettest_a_SOURCES = \
91 mesh_test_lib.c mesh_test_lib.h 91 cadet_test_lib.c cadet_test_lib.h
92libgnunetmeshtest_a_LIBADD = \ 92libgnunetcadettest_a_LIBADD = \
93 $(top_builddir)/src/util/libgnunetutil.la \ 93 $(top_builddir)/src/util/libgnunetutil.la \
94 $(top_builddir)/src/testbed/libgnunettestbed.la \ 94 $(top_builddir)/src/testbed/libgnunettestbed.la \
95 $(top_builddir)/src/mesh/libgnunetmesh.la 95 $(top_builddir)/src/cadet/libgnunetcadet.la
96libgnunetmeshtest_a_DEPENDENCIES = \ 96libgnunetcadettest_a_DEPENDENCIES = \
97 libgnunetmesh.la 97 libgnunetcadet.la
98 98
99if HAVE_TESTING 99if HAVE_TESTING
100check_PROGRAMS = \ 100check_PROGRAMS = \
101 test_mesh_single \ 101 test_cadet_single \
102 test_mesh_local \ 102 test_cadet_local \
103 test_mesh_forward \ 103 test_cadet_forward \
104 test_mesh_signal \ 104 test_cadet_signal \
105 test_mesh_keepalive \ 105 test_cadet_keepalive \
106 test_mesh_speed \ 106 test_cadet_speed \
107 test_mesh_speed_ack \ 107 test_cadet_speed_ack \
108 test_mesh_speed_backwards \ 108 test_cadet_speed_backwards \
109 test_mesh_speed_reliable \ 109 test_cadet_speed_reliable \
110 test_mesh_speed_reliable_backwards 110 test_cadet_speed_reliable_backwards
111endif 111endif
112 112
113ld_mesh_test_lib = \ 113ld_cadet_test_lib = \
114 $(top_builddir)/src/util/libgnunetutil.la \ 114 $(top_builddir)/src/util/libgnunetutil.la \
115 $(top_builddir)/src/testing/libgnunettesting.la \ 115 $(top_builddir)/src/testing/libgnunettesting.la \
116 $(top_builddir)/src/mesh/libgnunetmeshtest.a \ 116 $(top_builddir)/src/cadet/libgnunetcadettest.a \
117 $(top_builddir)/src/mesh/libgnunetmesh.la \ 117 $(top_builddir)/src/cadet/libgnunetcadet.la \
118 $(top_builddir)/src/testbed/libgnunettestbed.la \ 118 $(top_builddir)/src/testbed/libgnunettestbed.la \
119 $(top_builddir)/src/statistics/libgnunetstatistics.la 119 $(top_builddir)/src/statistics/libgnunetstatistics.la
120 120
121dep_mesh_test_lib = \ 121dep_cadet_test_lib = \
122 libgnunetmesh.la \ 122 libgnunetcadet.la \
123 libgnunetmeshtest.a \ 123 libgnunetcadettest.a \
124 $(top_builddir)/src/statistics/libgnunetstatistics.la 124 $(top_builddir)/src/statistics/libgnunetstatistics.la
125 125
126 126
127gnunet_mesh_profiler_SOURCES = \ 127gnunet_cadet_profiler_SOURCES = \
128 gnunet-mesh-profiler.c 128 gnunet-cadet-profiler.c
129gnunet_mesh_profiler_LDADD = $(ld_mesh_test_lib) 129gnunet_cadet_profiler_LDADD = $(ld_cadet_test_lib)
130gnunet_mesh_profiler_DEPENDENCIES = $(dep_mesh_test_lib) 130gnunet_cadet_profiler_DEPENDENCIES = $(dep_cadet_test_lib)
131 131
132 132
133test_mesh_single_SOURCES = \ 133test_cadet_single_SOURCES = \
134 test_mesh_single.c 134 test_cadet_single.c
135test_mesh_single_LDADD = $(ld_mesh_test_lib) 135test_cadet_single_LDADD = $(ld_cadet_test_lib)
136test_mesh_single_DEPENDENCIES = $(dep_mesh_test_lib) 136test_cadet_single_DEPENDENCIES = $(dep_cadet_test_lib)
137 137
138test_mesh_local_SOURCES = \ 138test_cadet_local_SOURCES = \
139 test_mesh_local.c 139 test_cadet_local.c
140test_mesh_local_LDADD = $(ld_mesh_test_lib) 140test_cadet_local_LDADD = $(ld_cadet_test_lib)
141test_mesh_local_DEPENDENCIES = $(dep_mesh_test_lib) 141test_cadet_local_DEPENDENCIES = $(dep_cadet_test_lib)
142 142
143test_mesh_forward_SOURCES = \ 143test_cadet_forward_SOURCES = \
144 test_mesh.c 144 test_cadet.c
145test_mesh_forward_LDADD = $(ld_mesh_test_lib) 145test_cadet_forward_LDADD = $(ld_cadet_test_lib)
146test_mesh_forward_DEPENDENCIES = $(dep_mesh_test_lib) 146test_cadet_forward_DEPENDENCIES = $(dep_cadet_test_lib)
147 147
148test_mesh_signal_SOURCES = \ 148test_cadet_signal_SOURCES = \
149 test_mesh.c 149 test_cadet.c
150test_mesh_signal_LDADD = $(ld_mesh_test_lib) 150test_cadet_signal_LDADD = $(ld_cadet_test_lib)
151test_mesh_signal_DEPENDENCIES = $(dep_mesh_test_lib) 151test_cadet_signal_DEPENDENCIES = $(dep_cadet_test_lib)
152 152
153test_mesh_keepalive_SOURCES = \ 153test_cadet_keepalive_SOURCES = \
154 test_mesh.c 154 test_cadet.c
155test_mesh_keepalive_LDADD = $(ld_mesh_test_lib) 155test_cadet_keepalive_LDADD = $(ld_cadet_test_lib)
156test_mesh_keepalive_DEPENDENCIES = $(dep_mesh_test_lib) 156test_cadet_keepalive_DEPENDENCIES = $(dep_cadet_test_lib)
157 157
158test_mesh_speed_SOURCES = \ 158test_cadet_speed_SOURCES = \
159 test_mesh.c 159 test_cadet.c
160test_mesh_speed_LDADD = $(ld_mesh_test_lib) 160test_cadet_speed_LDADD = $(ld_cadet_test_lib)
161test_mesh_speed_DEPENDENCIES = $(dep_mesh_test_lib) 161test_cadet_speed_DEPENDENCIES = $(dep_cadet_test_lib)
162 162
163test_mesh_speed_ack_SOURCES = \ 163test_cadet_speed_ack_SOURCES = \
164 test_mesh.c 164 test_cadet.c
165test_mesh_speed_ack_LDADD = $(ld_mesh_test_lib) 165test_cadet_speed_ack_LDADD = $(ld_cadet_test_lib)
166test_mesh_speed_ack_DEPENDENCIES = $(dep_mesh_test_lib) 166test_cadet_speed_ack_DEPENDENCIES = $(dep_cadet_test_lib)
167 167
168test_mesh_speed_backwards_SOURCES = \ 168test_cadet_speed_backwards_SOURCES = \
169 test_mesh.c 169 test_cadet.c
170test_mesh_speed_backwards_LDADD = $(ld_mesh_test_lib) 170test_cadet_speed_backwards_LDADD = $(ld_cadet_test_lib)
171test_mesh_speed_backwards_DEPENDENCIES = $(dep_mesh_test_lib) 171test_cadet_speed_backwards_DEPENDENCIES = $(dep_cadet_test_lib)
172 172
173test_mesh_speed_reliable_SOURCES = \ 173test_cadet_speed_reliable_SOURCES = \
174 test_mesh.c 174 test_cadet.c
175test_mesh_speed_reliable_LDADD = $(ld_mesh_test_lib) 175test_cadet_speed_reliable_LDADD = $(ld_cadet_test_lib)
176test_mesh_speed_reliable_DEPENDENCIES = $(dep_mesh_test_lib) 176test_cadet_speed_reliable_DEPENDENCIES = $(dep_cadet_test_lib)
177 177
178test_mesh_speed_reliable_backwards_SOURCES = \ 178test_cadet_speed_reliable_backwards_SOURCES = \
179 test_mesh.c 179 test_cadet.c
180test_mesh_speed_reliable_backwards_LDADD = $(ld_mesh_test_lib) 180test_cadet_speed_reliable_backwards_LDADD = $(ld_cadet_test_lib)
181test_mesh_speed_reliable_backwards_DEPENDENCIES = $(dep_mesh_test_lib) 181test_cadet_speed_reliable_backwards_DEPENDENCIES = $(dep_cadet_test_lib)
182 182
183 183
184if ENABLE_TEST_RUN 184if ENABLE_TEST_RUN
@@ -188,7 +188,7 @@ TESTS = \
188endif 188endif
189 189
190EXTRA_DIST = \ 190EXTRA_DIST = \
191 mesh.h mesh_protocol.h \ 191 cadet.h cadet_protocol.h \
192 test_mesh.conf \ 192 test_cadet.conf \
193 test_mesh_drop.conf 193 test_cadet_drop.conf
194 194