aboutsummaryrefslogtreecommitdiff
path: root/src/mesh/Makefile.am
diff options
context:
space:
mode:
authorBart Polot <bart@net.in.tum.de>2014-03-13 15:01:40 +0000
committerBart Polot <bart@net.in.tum.de>2014-03-13 15:01:40 +0000
commitb06de9fad684e2e657329d2d395b9c639e74acac (patch)
tree06052917ef0d20ec59795025fcdc53812b3007db /src/mesh/Makefile.am
parent6c814b8eb899ebbe3d0ea269aafa46b01aaeedbc (diff)
downloadgnunet-b06de9fad684e2e657329d2d395b9c639e74acac.tar.gz
gnunet-b06de9fad684e2e657329d2d395b9c639e74acac.zip
- fix compilation issues, add to Makefile
Diffstat (limited to 'src/mesh/Makefile.am')
-rw-r--r--src/mesh/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/mesh/Makefile.am b/src/mesh/Makefile.am
index a2bb0135b..75bb03a87 100644
--- a/src/mesh/Makefile.am
+++ b/src/mesh/Makefile.am
@@ -84,6 +84,7 @@ endif
84 84
85if HAVE_TESTING 85if HAVE_TESTING
86 noinst_LIBRARIES = libgnunetmeshtest.a $(noinst_LIB_EXP) 86 noinst_LIBRARIES = libgnunetmeshtest.a $(noinst_LIB_EXP)
87 noinst_PROGRAMS = gnunet-mesh-profiler
87endif 88endif
88 89
89libgnunetmeshtest_a_SOURCES = \ 90libgnunetmeshtest_a_SOURCES = \
@@ -117,12 +118,18 @@ ld_mesh_test_lib = \
117 $(top_builddir)/src/testbed/libgnunettestbed.la \ 118 $(top_builddir)/src/testbed/libgnunettestbed.la \
118 $(top_builddir)/src/statistics/libgnunetstatistics.la 119 $(top_builddir)/src/statistics/libgnunetstatistics.la
119 120
120
121dep_mesh_test_lib = \ 121dep_mesh_test_lib = \
122 libgnunetmesh.la \ 122 libgnunetmesh.la \
123 libgnunetmeshtest.a \ 123 libgnunetmeshtest.a \
124 $(top_builddir)/src/statistics/libgnunetstatistics.la 124 $(top_builddir)/src/statistics/libgnunetstatistics.la
125 125
126
127gnunet_mesh_profiler_SOURCES = \
128 mesh_profiler.c
129gnunet_mesh_profiler_LDADD = $(ld_mesh_test_lib)
130gnunet_mesh_profiler_DEPENDENCIES = $(dep_mesh_test_lib)
131
132
126test_mesh_single_SOURCES = \ 133test_mesh_single_SOURCES = \
127 test_mesh_single.c 134 test_mesh_single.c
128test_mesh_single_LDADD = $(ld_mesh_test_lib) 135test_mesh_single_LDADD = $(ld_mesh_test_lib)