aboutsummaryrefslogtreecommitdiff
path: root/src/mesh/Makefile.am
diff options
context:
space:
mode:
authorBart Polot <bart@net.in.tum.de>2013-11-14 13:55:12 +0000
committerBart Polot <bart@net.in.tum.de>2013-11-14 13:55:12 +0000
commitb7366f3d6a56d38d0269a33039f88de967e8c130 (patch)
treee299448a28e358c6549670a094b82f247925f7e2 /src/mesh/Makefile.am
parent6bde5e0c83d1fd344a26de64172ddce37920bb40 (diff)
downloadgnunet-b7366f3d6a56d38d0269a33039f88de967e8c130.tar.gz
gnunet-b7366f3d6a56d38d0269a33039f88de967e8c130.zip
Use encrypted MESH by default
Diffstat (limited to 'src/mesh/Makefile.am')
-rw-r--r--src/mesh/Makefile.am59
1 files changed, 10 insertions, 49 deletions
diff --git a/src/mesh/Makefile.am b/src/mesh/Makefile.am
index 3c71f4792..bc6d6e692 100644
--- a/src/mesh/Makefile.am
+++ b/src/mesh/Makefile.am
@@ -20,12 +20,6 @@ plugindir = $(libdir)/gnunet
20 20
21AM_CLFAGS = -g 21AM_CLFAGS = -g
22 22
23EXP_LIB = \
24 libgnunetmeshenc.la
25
26EXP_LIBEXEC = \
27 gnunet-service-mesh-enc
28
29libexec_PROGRAMS = \ 23libexec_PROGRAMS = \
30 gnunet-service-mesh $(EXP_LIBEXEC) 24 gnunet-service-mesh $(EXP_LIBEXEC)
31 25
@@ -58,19 +52,7 @@ libgnunetmesh_la_LIBADD = \
58 $(LTLIBINTL) 52 $(LTLIBINTL)
59libgnunetmesh_la_LDFLAGS = \ 53libgnunetmesh_la_LDFLAGS = \
60 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 54 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
61 -version-info 3:0:0 55 -version-info 4:0:0
62
63
64libgnunetmeshenc_la_SOURCES = \
65 mesh_api_enc.c mesh_common.c
66libgnunetmeshenc_la_LIBADD = \
67 $(top_builddir)/src/util/libgnunetutil.la \
68 $(XLIB) \
69 $(LTLIBINTL)
70libgnunetmeshenc_la_LDFLAGS = \
71 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
72 -version-info 1:0:0
73
74 56
75gnunet_mesh_SOURCES = \ 57gnunet_mesh_SOURCES = \
76 gnunet-mesh.c 58 gnunet-mesh.c
@@ -81,27 +63,6 @@ gnunet_mesh_DEPENDENCIES = \
81 libgnunetmesh.la 63 libgnunetmesh.la
82 64
83gnunet_service_mesh_SOURCES = \ 65gnunet_service_mesh_SOURCES = \
84 gnunet-service-mesh.c \
85 mesh_path.c \
86 mesh_common.c
87gnunet_service_mesh_CFLAGS = $(AM_CFLAGS)
88gnunet_service_mesh_LDADD = \
89 $(top_builddir)/src/util/libgnunetutil.la \
90 $(top_builddir)/src/core/libgnunetcore.la \
91 $(top_builddir)/src/dht/libgnunetdht.la \
92 $(top_builddir)/src/statistics/libgnunetstatistics.la \
93 $(top_builddir)/src/block/libgnunetblock.la
94gnunet_service_mesh_DEPENDENCIES = \
95 $(top_builddir)/src/util/libgnunetutil.la \
96 $(top_builddir)/src/core/libgnunetcore.la \
97 $(top_builddir)/src/dht/libgnunetdht.la \
98 $(top_builddir)/src/statistics/libgnunetstatistics.la \
99 $(top_builddir)/src/block/libgnunetblock.la
100if LINUX
101 gnunet_service_mesh_LDFLAGS = -lrt
102endif
103
104gnunet_service_mesh_enc_SOURCES = \
105 gnunet-service-mesh_tunnel.c \ 66 gnunet-service-mesh_tunnel.c \
106 gnunet-service-mesh_connection.c \ 67 gnunet-service-mesh_connection.c \
107 gnunet-service-mesh_channel.c \ 68 gnunet-service-mesh_channel.c \
@@ -110,22 +71,22 @@ gnunet_service_mesh_enc_SOURCES = \
110 gnunet-service-mesh_dht.c \ 71 gnunet-service-mesh_dht.c \
111 mesh_path.c \ 72 mesh_path.c \
112 mesh_common.c \ 73 mesh_common.c \
113 gnunet-service-mesh-enc.c 74 gnunet-service-mesh.c
114gnunet_service_mesh_enc_CFLAGS = $(AM_CFLAGS) 75gnunet_service_mesh_CFLAGS = $(AM_CFLAGS)
115gnunet_service_mesh_enc_LDADD = \ 76gnunet_service_mesh_LDADD = \
116 $(top_builddir)/src/util/libgnunetutil.la \ 77 $(top_builddir)/src/util/libgnunetutil.la \
117 $(top_builddir)/src/core/libgnunetcore.la \ 78 $(top_builddir)/src/core/libgnunetcore.la \
118 $(top_builddir)/src/dht/libgnunetdht.la \ 79 $(top_builddir)/src/dht/libgnunetdht.la \
119 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 80 $(top_builddir)/src/statistics/libgnunetstatistics.la \
120 $(top_builddir)/src/block/libgnunetblock.la 81 $(top_builddir)/src/block/libgnunetblock.la
121gnunet_service_mesh_enc_DEPENDENCIES = \ 82gnunet_service_mesh_DEPENDENCIES = \
122 $(top_builddir)/src/util/libgnunetutil.la \ 83 $(top_builddir)/src/util/libgnunetutil.la \
123 $(top_builddir)/src/core/libgnunetcore.la \ 84 $(top_builddir)/src/core/libgnunetcore.la \
124 $(top_builddir)/src/dht/libgnunetdht.la \ 85 $(top_builddir)/src/dht/libgnunetdht.la \
125 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 86 $(top_builddir)/src/statistics/libgnunetstatistics.la \
126 $(top_builddir)/src/block/libgnunetblock.la 87 $(top_builddir)/src/block/libgnunetblock.la
127if LINUX 88if LINUX
128 gnunet_service_mesh_enc_LDFLAGS = -lrt 89 gnunet_service_mesh_LDFLAGS = -lrt
129endif 90endif
130 91
131 92
@@ -138,9 +99,9 @@ libgnunetmeshtest_a_SOURCES = \
138libgnunetmeshtest_a_LIBADD = \ 99libgnunetmeshtest_a_LIBADD = \
139 $(top_builddir)/src/util/libgnunetutil.la \ 100 $(top_builddir)/src/util/libgnunetutil.la \
140 $(top_builddir)/src/testbed/libgnunettestbed.la \ 101 $(top_builddir)/src/testbed/libgnunettestbed.la \
141 $(top_builddir)/src/mesh/libgnunetmeshenc.la 102 $(top_builddir)/src/mesh/libgnunetmesh.la
142libgnunetmeshtest_a_DEPENDENCIES = \ 103libgnunetmeshtest_a_DEPENDENCIES = \
143 libgnunetmeshenc.la 104 libgnunetmesh.la
144 105
145if HAVE_TESTING 106if HAVE_TESTING
146check_PROGRAMS = \ 107check_PROGRAMS = \
@@ -161,11 +122,11 @@ ld_mesh_test_lib = \
161 $(top_builddir)/src/util/libgnunetutil.la \ 122 $(top_builddir)/src/util/libgnunetutil.la \
162 $(top_builddir)/src/testing/libgnunettesting.la \ 123 $(top_builddir)/src/testing/libgnunettesting.la \
163 $(top_builddir)/src/mesh/libgnunetmeshtest.a \ 124 $(top_builddir)/src/mesh/libgnunetmeshtest.a \
164 $(top_builddir)/src/mesh/libgnunetmeshenc.la \ 125 $(top_builddir)/src/mesh/libgnunetmesh.la \
165 $(top_builddir)/src/testbed/libgnunettestbed.la 126 $(top_builddir)/src/testbed/libgnunettestbed.la
166 127
167dep_mesh_test_lib = \ 128dep_mesh_test_lib = \
168 libgnunetmeshenc.la \ 129 libgnunetmesh.la \
169 libgnunetmeshtest.a 130 libgnunetmeshtest.a
170 131
171test_mesh_single_SOURCES = \ 132test_mesh_single_SOURCES = \