aboutsummaryrefslogtreecommitdiff
path: root/src/mesh/Makefile.am
diff options
context:
space:
mode:
authorBart Polot <bart@net.in.tum.de>2013-06-28 14:34:55 +0000
committerBart Polot <bart@net.in.tum.de>2013-06-28 14:34:55 +0000
commitcf19b5082fe8de33e38957f54d28647635b46b60 (patch)
treee6e41da7d5cb14d9a342ef6533633ecb2f34b18d /src/mesh/Makefile.am
parent166d8f9122bf7ebbaa2a662d09a3fa4d34f6d092 (diff)
downloadgnunet-cf19b5082fe8de33e38957f54d28647635b46b60.tar.gz
gnunet-cf19b5082fe8de33e38957f54d28647635b46b60.zip
Replace mesh with new version
Diffstat (limited to 'src/mesh/Makefile.am')
-rw-r--r--src/mesh/Makefile.am279
1 files changed, 42 insertions, 237 deletions
diff --git a/src/mesh/Makefile.am b/src/mesh/Makefile.am
index c0d66ace3..e1c607d7f 100644
--- a/src/mesh/Makefile.am
+++ b/src/mesh/Makefile.am
@@ -20,21 +20,6 @@ plugindir = $(libdir)/gnunet
20 20
21AM_CLFAGS = -g 21AM_CLFAGS = -g
22 22
23if HAVE_EXPERIMENTAL
24 noinst_LIB_EXP = libgnunetmesh2test.a
25 EXP_LIB = libgnunetmesh2.la
26 EXP_LIBEXEC = gnunet-service-mesh-new
27 EXP_TESTS = \
28 test_mesh2_local \
29 test_mesh2_small_forward \
30 test_mesh2_small_signal \
31 test_mesh2_small_speed \
32 test_mesh2_small_speed_ack \
33 test_mesh2_small_speed_nobuf \
34 test_mesh2_small_speed_backwards \
35 test_mesh2_small_speed_nobuf_backwards
36endif
37
38libexec_PROGRAMS = \ 23libexec_PROGRAMS = \
39 gnunet-service-mesh $(EXP_LIBEXEC) 24 gnunet-service-mesh $(EXP_LIBEXEC)
40 25
@@ -58,6 +43,7 @@ libgnunet_plugin_block_mesh_la_DEPENDENCIES = \
58 $(top_builddir)/src/block/libgnunetblock.la \ 43 $(top_builddir)/src/block/libgnunetblock.la \
59 $(top_builddir)/src/util/libgnunetutil.la 44 $(top_builddir)/src/util/libgnunetutil.la
60 45
46
61libgnunetmesh_la_SOURCES = \ 47libgnunetmesh_la_SOURCES = \
62 mesh_api.c mesh_common.c 48 mesh_api.c mesh_common.c
63libgnunetmesh_la_LIBADD = \ 49libgnunetmesh_la_LIBADD = \
@@ -66,41 +52,7 @@ libgnunetmesh_la_LIBADD = \
66 $(LTLIBINTL) 52 $(LTLIBINTL)
67libgnunetmesh_la_LDFLAGS = \ 53libgnunetmesh_la_LDFLAGS = \
68 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 54 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
69 -version-info 2:1:1 55 -version-info 3:0:0
70
71libgnunetmesh2_la_SOURCES = \
72 mesh2_api.c mesh_common.c
73libgnunetmesh2_la_LIBADD = \
74 $(top_builddir)/src/util/libgnunetutil.la \
75 $(XLIB) \
76 $(LTLIBINTL)
77libgnunetmesh2_la_LDFLAGS = \
78 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
79 -version-info 2:2:1
80
81
82gnunet_service_mesh_SOURCES = \
83 gnunet-service-mesh.c \
84 mesh_tunnel_tree.c mesh_tunnel_tree.h \
85 mesh_common.c
86gnunet_service_mesh_CFLAGS = $(AM_CFLAGS)
87gnunet_service_mesh_LDADD = \
88 $(top_builddir)/src/statistics/libgnunetstatistics.la \
89 $(top_builddir)/src/regex/libgnunetregex.la \
90 $(top_builddir)/src/util/libgnunetutil.la \
91 $(top_builddir)/src/core/libgnunetcore.la \
92 $(top_builddir)/src/dht/libgnunetdht.la \
93 $(top_builddir)/src/block/libgnunetblock.la
94gnunet_service_mesh_DEPENDENCIES = \
95 $(top_builddir)/src/util/libgnunetutil.la \
96 $(top_builddir)/src/core/libgnunetcore.la \
97 $(top_builddir)/src/dht/libgnunetdht.la \
98 $(top_builddir)/src/statistics/libgnunetstatistics.la \
99 $(top_builddir)/src/block/libgnunetblock.la \
100 $(top_builddir)/src/regex/libgnunetregex.la
101if LINUX
102gnunet_service_mesh_LDFLAGS = -lrt
103endif
104 56
105gnunet_mesh_SOURCES = \ 57gnunet_mesh_SOURCES = \
106 gnunet-mesh.c 58 gnunet-mesh.c
@@ -110,25 +62,25 @@ gnunet_mesh_LDADD = \
110gnunet_mesh_DEPENDENCIES = \ 62gnunet_mesh_DEPENDENCIES = \
111 libgnunetmesh.la 63 libgnunetmesh.la
112 64
113gnunet_service_mesh_new_SOURCES = \ 65gnunet_service_mesh_SOURCES = \
114 gnunet-service-mesh-new.c \ 66 gnunet-service-mesh.c \
115 mesh_path.c \ 67 mesh_path.c \
116 mesh_common.c 68 mesh_common.c
117gnunet_service_mesh_new_CFLAGS = $(AM_CFLAGS) 69gnunet_service_mesh_CFLAGS = $(AM_CFLAGS)
118gnunet_service_mesh_new_LDADD = \ 70gnunet_service_mesh_LDADD = \
119 $(top_builddir)/src/util/libgnunetutil.la \ 71 $(top_builddir)/src/util/libgnunetutil.la \
120 $(top_builddir)/src/core/libgnunetcore.la \ 72 $(top_builddir)/src/core/libgnunetcore.la \
121 $(top_builddir)/src/dht/libgnunetdht.la \ 73 $(top_builddir)/src/dht/libgnunetdht.la \
122 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 74 $(top_builddir)/src/statistics/libgnunetstatistics.la \
123 $(top_builddir)/src/block/libgnunetblock.la 75 $(top_builddir)/src/block/libgnunetblock.la
124gnunet_service_mesh_new_DEPENDENCIES = \ 76gnunet_service_mesh_DEPENDENCIES = \
125 $(top_builddir)/src/util/libgnunetutil.la \ 77 $(top_builddir)/src/util/libgnunetutil.la \
126 $(top_builddir)/src/core/libgnunetcore.la \ 78 $(top_builddir)/src/core/libgnunetcore.la \
127 $(top_builddir)/src/dht/libgnunetdht.la \ 79 $(top_builddir)/src/dht/libgnunetdht.la \
128 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 80 $(top_builddir)/src/statistics/libgnunetstatistics.la \
129 $(top_builddir)/src/block/libgnunetblock.la 81 $(top_builddir)/src/block/libgnunetblock.la
130if LINUX 82if LINUX
131gnunet_service_mesh_new_LDFLAGS = -lrt 83 gnunet_service_mesh_LDFLAGS = -lrt
132endif 84endif
133 85
134if HAVE_TESTING 86if HAVE_TESTING
@@ -144,222 +96,75 @@ libgnunetmeshtest_a_LIBADD = \
144libgnunetmeshtest_a_DEPENDENCIES = \ 96libgnunetmeshtest_a_DEPENDENCIES = \
145 libgnunetmesh.la 97 libgnunetmesh.la
146 98
147libgnunetmesh2test_a_SOURCES = \
148 mesh2_test_lib.c mesh2_test_lib.h
149libgnunetmesh2test_a_LIBADD = \
150 $(top_builddir)/src/util/libgnunetutil.la \
151 $(top_builddir)/src/testbed/libgnunettestbed.la \
152 $(top_builddir)/src/mesh/libgnunetmesh2.la
153libgnunetmesh2test_a_DEPENDENCIES = \
154 libgnunetmesh2.la
155
156if HAVE_TESTING 99if HAVE_TESTING
157check_PROGRAMS = \ 100check_PROGRAMS = \
158 test_mesh_api \ 101 test_mesh_local \
159 test_mesh_tree_api \ 102 test_mesh_small_forward \
160 test_mesh_local_1 \ 103 test_mesh_small_signal \
161 test_mesh_local_2 \ 104 test_mesh_small_speed \
162 test_mesh_local_traffic_fwd \ 105 test_mesh_small_speed_ack \
163 test_mesh_local_traffic_bck \ 106 test_mesh_small_speed_nobuf \
164 test_mesh_local_traffic_both \ 107 test_mesh_small_speed_backwards \
165 test_mesh_2dtorus \ 108 test_mesh_small_speed_nobuf_backwards
166 test_mesh_small_unicast \
167 test_mesh_small_signal \
168 test_mesh_small_speed \
169 test_mesh_small_speed_nobuf \
170 test_mesh_small_speed_backwards \
171 test_mesh_small_speed_nobuf_backwards \
172 test_mesh_small_speed_ack \
173 $(EXP_TESTS)
174endif 109endif
175 110
176test_mesh_api_SOURCES = \
177 test_mesh_api.c
178test_mesh_api_LDADD = \
179 $(top_builddir)/src/util/libgnunetutil.la \
180 $(top_builddir)/src/testing/libgnunettesting.la \
181 $(top_builddir)/src/mesh/libgnunetmesh.la
182test_mesh_api_DEPENDENCIES = \
183 libgnunetmesh.la \
184 $(top_builddir)/src/util/libgnunetutil.la
185
186test_mesh_tree_api_SOURCES = \
187 test_mesh_tree_api.c
188test_mesh_tree_api_LDADD = \
189 $(top_builddir)/src/util/libgnunetutil.la \
190 $(top_builddir)/src/dht/libgnunetdht.la
191test_mesh_tree_api_DEPENDENCIES = \
192 libgnunetmesh.la \
193 $(top_builddir)/src/dht/libgnunetdht.la
194
195test_mesh_local_1_SOURCES = \
196 test_mesh_local_1.c
197test_mesh_local_1_LDADD = \
198 $(top_builddir)/src/util/libgnunetutil.la \
199 $(top_builddir)/src/testing/libgnunettesting.la \
200 $(top_builddir)/src/mesh/libgnunetmesh.la
201test_mesh_local_1_DEPENDENCIES = \
202 libgnunetmesh.la
203
204test_mesh_local_2_SOURCES = \
205 test_mesh_local_2.c
206test_mesh_local_2_LDADD = \
207 $(top_builddir)/src/util/libgnunetutil.la \
208 $(top_builddir)/src/testing/libgnunettesting.la \
209 $(top_builddir)/src/mesh/libgnunetmesh.la
210test_mesh_local_2_DEPENDENCIES = \
211 libgnunetmesh.la
212
213test_mesh_local_traffic_fwd_SOURCES = \
214 test_mesh_local_traffic.c
215test_mesh_local_traffic_fwd_LDADD = \
216 $(top_builddir)/src/util/libgnunetutil.la \
217 $(top_builddir)/src/testing/libgnunettesting.la \
218 $(top_builddir)/src/mesh/libgnunetmesh.la
219test_mesh_local_traffic_fwd_DEPENDENCIES = \
220 libgnunetmesh.la
221
222test_mesh_local_traffic_bck_SOURCES = \
223 test_mesh_local_traffic.c
224test_mesh_local_traffic_bck_LDADD = \
225 $(top_builddir)/src/util/libgnunetutil.la \
226 $(top_builddir)/src/testing/libgnunettesting.la \
227 $(top_builddir)/src/mesh/libgnunetmesh.la
228test_mesh_local_traffic_bck_DEPENDENCIES = \
229 libgnunetmesh.la
230
231test_mesh_local_traffic_both_SOURCES = \
232 test_mesh_local_traffic.c
233test_mesh_local_traffic_both_LDADD = \
234 $(top_builddir)/src/util/libgnunetutil.la \
235 $(top_builddir)/src/testing/libgnunettesting.la \
236 $(top_builddir)/src/mesh/libgnunetmesh.la
237test_mesh_local_traffic_both_DEPENDENCIES = \
238 libgnunetmesh.la
239
240
241ld_mesh_test_lib = \ 111ld_mesh_test_lib = \
242 $(top_builddir)/src/mesh/libgnunetmeshtest.a \ 112 $(top_builddir)/src/util/libgnunetutil.la \
243 $(top_builddir)/src/mesh/libgnunetmesh.la \ 113 $(top_builddir)/src/testing/libgnunettesting.la \
244 $(top_builddir)/src/testbed/libgnunettestbed.la \ 114 $(top_builddir)/src/testbed/libgnunettestbed.la \
245 $(top_builddir)/src/util/libgnunetutil.la 115 $(top_builddir)/src/mesh/libgnunetmesh.la \
116 $(top_builddir)/src/mesh/libgnunetmeshtest.a
246 117
247dep_mesh_test_lib = \ 118dep_mesh_test_lib = \
248 libgnunetmeshtest.a \ 119 libgnunetmesh.la \
249 libgnunetmesh.la 120 libgnunetmeshtest.a
250 121
251test_mesh_2dtorus_SOURCES = \ 122test_mesh_local_SOURCES = \
252 test_mesh_2dtorus.c 123 test_mesh_local.c
253test_mesh_2dtorus_LDADD = $(ld_mesh_test_lib) 124test_mesh_local_LDADD = $(ld_mesh_test_lib)
254test_mesh_2dtorus_DEPENDENCIES = $(dep_mesh_test_lib) 125test_mesh_local_DEPENDENCIES = $(dep_mesh_test_lib)
255 126
256test_mesh_small_unicast_SOURCES = \ 127test_mesh_small_forward_SOURCES = \
257 test_mesh_small.c 128 test_mesh_small.c
258test_mesh_small_unicast_LDADD = $(ld_mesh_test_lib) 129test_mesh_small_forward_LDADD = $(ld_mesh_test_lib)
259test_mesh_small_unicast_DEPENDENCIES = $(dep_mesh_test_lib) 130test_mesh_small_forward_DEPENDENCIES = $(dep_mesh_test_lib)
260 131
261test_mesh_small_signal_SOURCES = \ 132test_mesh_small_signal_SOURCES = \
262 test_mesh_small.c 133 test_mesh_small.c
263test_mesh_small_signal_LDADD = $(ld_mesh_test_lib) 134test_mesh_small_signal_LDADD = $(ld_mesh_test_lib)
264test_mesh_small_signal_DEPENDENCIES = $(dep_mesh_test_lib) 135test_mesh_small_signal_DEPENDENCIES = $(dep_mesh_test_lib)
265 136
266test_mesh_small_speed_ack_SOURCES = \
267 test_mesh_small.c
268test_mesh_small_speed_ack_LDADD = $(ld_mesh_test_lib)
269test_mesh_small_speed_ack_DEPENDENCIES = $(dep_mesh_test_lib)
270
271test_mesh_small_speed_SOURCES = \ 137test_mesh_small_speed_SOURCES = \
272 test_mesh_small.c 138 test_mesh_small.c
273test_mesh_small_speed_LDADD = $(ld_mesh_test_lib) 139test_mesh_small_speed_LDADD = $(ld_mesh_test_lib)
274test_mesh_small_speed_DEPENDENCIES = $(dep_mesh_test_lib) 140test_mesh_small_speed_DEPENDENCIES = $(dep_mesh_test_lib)
275 141
142test_mesh_small_speed_ack_SOURCES = \
143 test_mesh_small.c
144test_mesh_small_speed_ack_LDADD = $(ld_mesh_test_lib)
145test_mesh_small_speed_ack_DEPENDENCIES = $(dep_mesh_test_lib)
146
276test_mesh_small_speed_nobuf_SOURCES = \ 147test_mesh_small_speed_nobuf_SOURCES = \
277 test_mesh_small.c 148 test_mesh_small.c
278test_mesh_small_speed_nobuf_LDADD = $(ld_mesh_test_lib) 149test_mesh_small_speed_nobuf_LDADD = $(ld_mesh_test_lib)
279test_mesh_small_speed_nobuf_DEPENDENCIES = $(dep_mesh_test_lib) 150test_mesh_small_speed_nobuf_DEPENDENCIES = $(dep_mesh_test_lib)
280 151
281test_mesh_small_speed_backwards_SOURCES = \ 152test_mesh_small_speed_backwards_SOURCES = \
282 test_mesh_small.c 153 test_mesh_small.c
283test_mesh_small_speed_backwards_LDADD = $(ld_mesh_test_lib) 154test_mesh_small_speed_backwards_LDADD = $(ld_mesh_test_lib)
284test_mesh_small_speed_backwards_DEPENDENCIES = $(dep_mesh_test_lib) 155test_mesh_small_speed_backwards_DEPENDENCIES = $(dep_mesh_test_lib)
285 156
286test_mesh_small_speed_nobuf_backwards_SOURCES = \ 157test_mesh_small_speed_nobuf_backwards_SOURCES = \
287 test_mesh_small.c 158 test_mesh_small.c
288test_mesh_small_speed_nobuf_backwards_LDADD = $(ld_mesh_test_lib) 159test_mesh_small_speed_nobuf_backwards_LDADD = $(ld_mesh_test_lib)
289test_mesh_small_speed_nobuf_backwards_DEPENDENCIES = $(dep_mesh_test_lib) 160test_mesh_small_speed_nobuf_backwards_DEPENDENCIES = $(dep_mesh_test_lib)
290 161
291 162
292ld_mesh2_test_lib = \
293 $(top_builddir)/src/mesh/libgnunetmesh2test.a \
294 $(top_builddir)/src/mesh/libgnunetmesh2.la \
295 $(top_builddir)/src/testing/libgnunettesting.la \
296 $(top_builddir)/src/testbed/libgnunettestbed.la \
297 $(top_builddir)/src/util/libgnunetutil.la
298
299dep_mesh2_test_lib = \
300 libgnunetmesh2test.a \
301 libgnunetmesh2.la
302
303test_mesh2_local_SOURCES = \
304 test_mesh2_local.c
305test_mesh2_local_LDADD = $(ld_mesh2_test_lib)
306test_mesh2_local_DEPENDENCIES = $(dep_mesh2_test_lib)
307
308test_mesh2_small_forward_SOURCES = \
309 test_mesh2_small.c
310test_mesh2_small_forward_LDADD = $(ld_mesh2_test_lib)
311test_mesh2_small_forward_DEPENDENCIES = $(dep_mesh2_test_lib)
312
313test_mesh2_small_signal_SOURCES = \
314 test_mesh2_small.c
315test_mesh2_small_signal_LDADD = $(ld_mesh2_test_lib)
316test_mesh2_small_signal_DEPENDENCIES = $(dep_mesh2_test_lib)
317
318test_mesh2_small_speed_SOURCES = \
319 test_mesh2_small.c
320test_mesh2_small_speed_LDADD = $(ld_mesh2_test_lib)
321test_mesh2_small_speed_DEPENDENCIES = $(dep_mesh2_test_lib)
322
323test_mesh2_small_speed_ack_SOURCES = \
324 test_mesh2_small.c
325test_mesh2_small_speed_ack_LDADD = $(ld_mesh2_test_lib)
326test_mesh2_small_speed_ack_DEPENDENCIES = $(dep_mesh2_test_lib)
327
328test_mesh2_small_speed_nobuf_SOURCES = \
329 test_mesh2_small.c
330test_mesh2_small_speed_nobuf_LDADD = $(ld_mesh2_test_lib)
331test_mesh2_small_speed_nobuf_DEPENDENCIES = $(dep_mesh2_test_lib)
332
333test_mesh2_small_speed_backwards_SOURCES = \
334 test_mesh2_small.c
335test_mesh2_small_speed_backwards_LDADD = $(ld_mesh2_test_lib)
336test_mesh2_small_speed_backwards_DEPENDENCIES = $(dep_mesh2_test_lib)
337
338test_mesh2_small_speed_nobuf_backwards_SOURCES = \
339 test_mesh2_small.c
340test_mesh2_small_speed_nobuf_backwards_LDADD = $(ld_mesh2_test_lib)
341test_mesh2_small_speed_nobuf_backwards_DEPENDENCIES = $(dep_mesh2_test_lib)
342
343
344if ENABLE_TEST_RUN 163if ENABLE_TEST_RUN
345TESTS = \ 164TESTS = \
346 $(EXP_TESTS) \ 165 $(check_PROGRAMS)
347 test_mesh_api \
348 test_mesh_tree_api \
349 test_mesh_local_1 test_mesh_local_2 \
350 test_mesh_local_traffic_fwd \
351 test_mesh_local_traffic_bck \
352 test_mesh_local_traffic_both \
353 test_mesh_2dtorus \
354 test_mesh_small_unicast \
355 test_mesh_small_signal \
356 test_mesh_small_speed \
357 test_mesh_small_speed_nobuf \
358 test_mesh_small_speed_backwards
359endif 166endif
360 167
361EXTRA_DIST = \ 168EXTRA_DIST = \
362 mesh.h mesh_protocol.h \ 169 mesh.h mesh_protocol.h \
363 test_mesh.conf \ 170 test_mesh.conf
364 test_mesh_2dtorus.conf \
365 test_mesh_small.conf