aboutsummaryrefslogtreecommitdiff
path: root/src/monkey/Makefile.am
diff options
context:
space:
mode:
authorSafey A.Halim <safey.allah@gmail.com>2010-06-29 19:14:37 +0000
committerSafey A.Halim <safey.allah@gmail.com>2010-06-29 19:14:37 +0000
commit1e2ec555753751d032dbe1f19d5206a2da4de65a (patch)
treeba5f6d9487ab2f7aea7fa98d1de3d6abef268b33 /src/monkey/Makefile.am
parentc75af8bb6df74bfcba1e7b1a3123babf066a1939 (diff)
downloadgnunet-1e2ec555753751d032dbe1f19d5206a2da4de65a.tar.gz
gnunet-1e2ec555753751d032dbe1f19d5206a2da4de65a.zip
Adding "Monkey", GNUnet module for automatic debugging. Experimental code so far.
Diffstat (limited to 'src/monkey/Makefile.am')
-rw-r--r--src/monkey/Makefile.am100
1 files changed, 100 insertions, 0 deletions
diff --git a/src/monkey/Makefile.am b/src/monkey/Makefile.am
new file mode 100644
index 000000000..516f8c08e
--- /dev/null
+++ b/src/monkey/Makefile.am
@@ -0,0 +1,100 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
5endif
6
7if USE_COVERAGE
8 AM_CFLAGS = --coverage -O0
9 XLIB = -lgcov
10endif
11
12
13lib_LTLIBRARIES = libgnunetmonkey.la
14
15libgnunetmonkey_la_SOURCES = \
16 monkey_api.c monkey.h
17libgnunetmonkey_la_LIBADD = \
18 $(top_builddir)/src/util/libgnunetutil.la \
19 -lesmtp
20libgnunetmonkey_la_LDFLAGS = \
21 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
22 -version-info 0:0:0
23
24
25bin_PROGRAMS = \
26 gnunet-monkey \
27 gnunet-service-monkey \
28 bug_null_pointer_exception \
29 mail_sender
30
31gnunet_monkey_SOURCES = \
32 mi_gdb.h \
33 alloc.c \
34 breakpoint.c \
35 connect.c \
36 cpp_int.cc \
37 data_man.c \
38 error.c \
39 get_free_pty.c \
40 get_free_vt.c \
41 gnunet-monkey.c \
42 misc.c \
43 parse.c \
44 prg_control.c \
45 stack_man.c \
46 symbol_query.c \
47 target_man.c \
48 thread.c \
49 var_obj.c
50
51gnunet_monkey_LDADD = \
52 $(top_builddir)/src/monkey/libgnunetmonkey.la \
53 $(top_builddir)/src/util/libgnunetutil.la \
54 $(GN_LIBINTL)
55
56
57
58gnunet_service_monkey_SOURCES = \
59 gnunet-service-monkey.c
60gnunet_service_monkey_LDADD = \
61 $(top_builddir)/src/monkey/libgnunetmonkey.la \
62 $(top_builddir)/src/util/libgnunetutil.la \
63 $(GN_LIBINTL)
64
65
66mail_sender_SOURCES = \
67 mail_sender.c
68mail_sender_LDADD = \
69 $(top_builddir)/src/monkey/libgnunetmonkey.la \
70 $(top_builddir)/src/util/libgnunetutil.la \
71 $(GN_LIBINTL)
72
73bug_null_pointer_exception_SOURCES = \
74 bug_null_pointer_exception.c
75bug_null_pointer_exception_LDADD = \
76 $(top_builddir)/src/monkey/libgnunetmonkey.la \
77 $(top_builddir)/src/util/libgnunetutil.la \
78 $(GN_LIBINTL)
79
80
81
82check_PROGRAMS = \
83 test_monkey_api
84
85TESTS = $(check_PROGRAMS) $(check_SCRIPTS)
86
87test_monkey_api_SOURCES = \
88 test_monkey_api.c
89test_monkey_api_LDADD = \
90 $(top_builddir)/src/monkey/libgnunetmonkey.la \
91 $(top_builddir)/src/util/libgnunetutil.la
92
93check_SCRIPTS = \
94 test_gnunet_monkey.sh
95
96EXTRA_DIST = \
97 test_monkey_api_data.conf \
98 $(check_SCRIPTS)
99
100