aboutsummaryrefslogtreecommitdiff
path: root/src/namecache/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <mschanzenbach@posteo.de>2021-10-11 23:43:04 +0200
committerMartin Schanzenbach <mschanzenbach@posteo.de>2021-10-11 23:43:04 +0200
commit4e7e81f4d1305df169d3f7623948a142aa47936b (patch)
treebd74087a75d29375fdf457d3c4fc6662106cf92f /src/namecache/Makefile.am
parent65554324abf7e83e3f0f51c3b059e621934afb9d (diff)
downloadgnunet-4e7e81f4d1305df169d3f7623948a142aa47936b.tar.gz
gnunet-4e7e81f4d1305df169d3f7623948a142aa47936b.zip
BUILD: Remove --disable-testing. Issue #7033
Diffstat (limited to 'src/namecache/Makefile.am')
-rw-r--r--src/namecache/Makefile.am8
1 files changed, 0 insertions, 8 deletions
diff --git a/src/namecache/Makefile.am b/src/namecache/Makefile.am
index 8ffa85ddb..272f16b77 100644
--- a/src/namecache/Makefile.am
+++ b/src/namecache/Makefile.am
@@ -17,30 +17,22 @@ endif
17 17
18if HAVE_EXPERIMENTAL 18if HAVE_EXPERIMENTAL
19FLAT_PLUGIN = libgnunet_plugin_namecache_flat.la 19FLAT_PLUGIN = libgnunet_plugin_namecache_flat.la
20if HAVE_TESTING
21FLAT_TESTS = test_plugin_namecache_flat 20FLAT_TESTS = test_plugin_namecache_flat
22endif 21endif
23endif
24 22
25if HAVE_SQLITE 23if HAVE_SQLITE
26SQLITE_PLUGIN = libgnunet_plugin_namecache_sqlite.la 24SQLITE_PLUGIN = libgnunet_plugin_namecache_sqlite.la
27if HAVE_TESTING
28SQLITE_TESTS = test_plugin_namecache_sqlite 25SQLITE_TESTS = test_plugin_namecache_sqlite
29endif 26endif
30endif
31 27
32if HAVE_POSTGRESQL 28if HAVE_POSTGRESQL
33POSTGRES_PLUGIN = libgnunet_plugin_namecache_postgres.la 29POSTGRES_PLUGIN = libgnunet_plugin_namecache_postgres.la
34if HAVE_TESTING
35POSTGRES_TESTS = test_plugin_namecache_postgres 30POSTGRES_TESTS = test_plugin_namecache_postgres
36endif 31endif
37endif
38 32
39# testcases do not even build yet; thus: experimental! 33# testcases do not even build yet; thus: experimental!
40if HAVE_TESTING
41TESTING_TESTS = \ 34TESTING_TESTS = \
42 test_namecache_api_cache_block 35 test_namecache_api_cache_block
43endif
44 36
45if HAVE_SQLITE 37if HAVE_SQLITE
46check_PROGRAMS = \ 38check_PROGRAMS = \