aboutsummaryrefslogtreecommitdiff
path: root/src/nat/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2011-06-25 06:24:01 +0000
committerChristian Grothoff <christian@grothoff.org>2011-06-25 06:24:01 +0000
commit8a3016481ba6aeb36de3950a56e641dda53ca544 (patch)
tree0c5468ec6e5d2165ad5931940e0b8439d09398de /src/nat/Makefile.am
parentb6d4eeb39fd0cd41df164bd0959f58b08aa45e83 (diff)
downloadgnunet-8a3016481ba6aeb36de3950a56e641dda53ca544.tar.gz
gnunet-8a3016481ba6aeb36de3950a56e641dda53ca544.zip
the big NAT change
Diffstat (limited to 'src/nat/Makefile.am')
-rw-r--r--src/nat/Makefile.am20
1 files changed, 3 insertions, 17 deletions
diff --git a/src/nat/Makefile.am b/src/nat/Makefile.am
index 8542af8fa..2f30d3185 100644
--- a/src/nat/Makefile.am
+++ b/src/nat/Makefile.am
@@ -11,26 +11,12 @@ endif
11lib_LTLIBRARIES = libgnunetnat.la 11lib_LTLIBRARIES = libgnunetnat.la
12 12
13libgnunetnat_la_SOURCES = \ 13libgnunetnat_la_SOURCES = \
14 upnp.c upnp.h \ 14 nat.c
15 upnp-commands.c upnp-commands.h \
16 upnp-discover.c upnp-discover.h \
17 upnp-igd-parse.c upnp-igd-parse.h \
18 upnp-minixml.c upnp-minixml.h \
19 upnp-reply-parse.c upnp-reply-parse.h bsdqueue.h \
20 nat.c nat.h \
21 natpmp.h
22
23libgnunetnat_la_CFLAGS = \
24 -DDEBUG_UPNP -g -O0
25 15
26libgnunetnat_la_LIBADD = \ 16libgnunetnat_la_LIBADD = \
27 $(top_builddir)/src/util/libgnunetutil.la \ 17 $(top_builddir)/src/util/libgnunetutil.la \
28 @LIBCURL@ \
29 $(GN_LIBINTL) @EXT_LIBS@ 18 $(GN_LIBINTL) @EXT_LIBS@
30 19
31libgnunetnat_la_CPPFLAGS = \
32 @LIBCURL_CPPFLAGS@
33
34libgnunetnat_la_LDFLAGS = \ 20libgnunetnat_la_LDFLAGS = \
35 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 21 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
36 -version-info 0:0:0 22 -version-info 0:0:0
@@ -39,7 +25,7 @@ check_PROGRAMS = \
39 test-nat 25 test-nat
40 26
41if ENABLE_TEST_RUN 27if ENABLE_TEST_RUN
42TESTS = $(check_PROGRAMS) 28 TESTS = $(check_PROGRAMS)
43endif 29endif
44 30
45test_nat_SOURCES = \ 31test_nat_SOURCES = \
@@ -51,4 +37,4 @@ test_nat_LDADD = \
51 @LIBCURL@ 37 @LIBCURL@
52 38
53EXTRA_DIST = \ 39EXTRA_DIST = \
54 test-nat.conf 40 test_nat_data.conf