aboutsummaryrefslogtreecommitdiff
path: root/src/nat/Makefile.am
diff options
context:
space:
mode:
authorMoon <moon@140774ce-b5e7-0310-ab8b-a85725594a96>2009-10-25 09:44:36 +0000
committerMoon <moon@140774ce-b5e7-0310-ab8b-a85725594a96>2009-10-25 09:44:36 +0000
commitb94248cf8b37caaea9436d9973a6641eaeca90cb (patch)
treed612aa43f7a899630e4a237422a6db9123078143 /src/nat/Makefile.am
parent38fea0d2e4fe5410fcba7b115080a464f9af1930 (diff)
downloadgnunet-b94248cf8b37caaea9436d9973a6641eaeca90cb.tar.gz
gnunet-b94248cf8b37caaea9436d9973a6641eaeca90cb.zip
initial NAT lib commit (UPnP and NAT-PMP support)
Diffstat (limited to 'src/nat/Makefile.am')
-rw-r--r--src/nat/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/src/nat/Makefile.am b/src/nat/Makefile.am
new file mode 100644
index 000000000..dc881a302
--- /dev/null
+++ b/src/nat/Makefile.am
@@ -0,0 +1,44 @@
1SUBDIRS = miniupnp libnatpmp
2
3INCLUDES = -I$(top_srcdir)/src/include
4
5if MINGW
6 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
7endif
8
9if USE_COVERAGE
10 AM_CFLAGS = -fprofile-arcs -ftest-coverage
11endif
12
13lib_LTLIBRARIES = libgnunetnat.la
14
15libgnunetnat_la_SOURCES = \
16 upnp.c upnp.h \
17 natpmp.c natpmp.h \
18 nat.c nat.h
19
20libgnunetnat_la_CFLAGS = \
21 -I$(top_scrdir)/include
22
23libgnunetnat_la_LIBADD = \
24 $(top_builddir)/src/util/libgnunetutil.la \
25 $(GN_LIBINTL) @EXT_LIBS@
26
27libgnunetnat_la_LDFLAGS = \
28 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
29 -version-info 0:0:0
30
31check_PROGRAMS = \
32 test-nat
33
34TESTS = $(check_PROGRAMS)
35
36test_nat_SOURCES = \
37 test_nat.c
38
39test_nat_LDADD = \
40 $(top_builddir)/src/nat/libgnunetnat.la \
41 $(top_builddir)/src/util/libgnunetutil.la \
42 $(top_builddir)/src/nat/miniupnp/libminiupnp.a \
43 $(top_builddir)/src/nat/libnatpmp/libnatpmp.a
44