aboutsummaryrefslogtreecommitdiff
path: root/src/peerstore/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <mschanzenbach@posteo.de>2016-05-24 20:40:15 +0000
committerMartin Schanzenbach <mschanzenbach@posteo.de>2016-05-24 20:40:15 +0000
commitc651b45f01ccd44defd30f82fd21beb4426fea65 (patch)
tree9378928b64f21430bea5100c79f8c8ab6c824e8e /src/peerstore/Makefile.am
parent425065e903d0eb1a4a1faeaf183401fa49e9560b (diff)
downloadgnunet-c651b45f01ccd44defd30f82fd21beb4426fea65.tar.gz
gnunet-c651b45f01ccd44defd30f82fd21beb4426fea65.zip
- jsonapi build fix, add peerstore flat (EXP)
Diffstat (limited to 'src/peerstore/Makefile.am')
-rw-r--r--src/peerstore/Makefile.am21
1 files changed, 19 insertions, 2 deletions
diff --git a/src/peerstore/Makefile.am b/src/peerstore/Makefile.am
index 766055baf..dbb86553d 100644
--- a/src/peerstore/Makefile.am
+++ b/src/peerstore/Makefile.am
@@ -51,9 +51,21 @@ libgnunetpeerstore_la_LIBADD = \
51libgnunetpeerstore_la_LDFLAGS = \ 51libgnunetpeerstore_la_LDFLAGS = \
52 $(GN_LIB_LDFLAGS) 52 $(GN_LIB_LDFLAGS)
53 53
54if HAVE_EXPERIMENTAL
55 FLAT_PLUGIN = libgnunet_plugin_peerstore_flat.la
56
57libgnunet_plugin_peerstore_flat_la_SOURCES = \
58 plugin_peerstore_flat.c
59libgnunet_plugin_peerstore_flat_la_LIBADD = \
60 libgnunetpeerstore.la \
61 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
62 $(LTLIBINTL)
63libgnunet_plugin_peerstore_flat_la_LDFLAGS = \
64 $(GN_PLUGIN_LDFLAGS)
65endif
66
54if HAVE_SQLITE 67if HAVE_SQLITE
55plugin_LTLIBRARIES = \ 68SQLITE_PLUGIN = libgnunet_plugin_peerstore_sqlite.la
56 libgnunet_plugin_peerstore_sqlite.la
57 69
58libgnunet_plugin_peerstore_sqlite_la_SOURCES = \ 70libgnunet_plugin_peerstore_sqlite_la_SOURCES = \
59 plugin_peerstore_sqlite.c 71 plugin_peerstore_sqlite.c
@@ -65,6 +77,11 @@ libgnunet_plugin_peerstore_sqlite_la_LDFLAGS = \
65 $(GN_PLUGIN_LDFLAGS) 77 $(GN_PLUGIN_LDFLAGS)
66endif 78endif
67 79
80plugin_LTLIBRARIES = \
81 $(SQLITE_PLUGIN) \
82 $(FLAT_PLUGIN)
83
84
68check_PROGRAMS = \ 85check_PROGRAMS = \
69 test_peerstore_api_store \ 86 test_peerstore_api_store \
70 test_peerstore_api_iterate \ 87 test_peerstore_api_iterate \