aboutsummaryrefslogtreecommitdiff
path: root/src/peerstore/Makefile.am
diff options
context:
space:
mode:
authorOmar Tarabai <tarabai@devegypt.com>2014-06-05 12:05:13 +0000
committerOmar Tarabai <tarabai@devegypt.com>2014-06-05 12:05:13 +0000
commitd33c98924608b9aa01fe5e77330a7d7f11849acb (patch)
tree4dea172fdc5fcec35db6d71d4457d4f811313d11 /src/peerstore/Makefile.am
parented152ee424088c09368b865afaa1117f0a207963 (diff)
downloadgnunet-d33c98924608b9aa01fe5e77330a7d7f11849acb.tar.gz
gnunet-d33c98924608b9aa01fe5e77330a7d7f11849acb.zip
peerstore: stress test + minor fix
Diffstat (limited to 'src/peerstore/Makefile.am')
-rw-r--r--src/peerstore/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/peerstore/Makefile.am b/src/peerstore/Makefile.am
index 5b3c918db..1defd0c72 100644
--- a/src/peerstore/Makefile.am
+++ b/src/peerstore/Makefile.am
@@ -67,7 +67,8 @@ libgnunet_plugin_peerstore_sqlite_la_DEPENDENCIES = \
67check_PROGRAMS = \ 67check_PROGRAMS = \
68 test_peerstore_api_store \ 68 test_peerstore_api_store \
69 test_peerstore_api_iterate \ 69 test_peerstore_api_iterate \
70 test_peerstore_api_watch 70 test_peerstore_api_watch \
71 test_peerstore_stress_store
71 72
72if ENABLE_TEST_RUN 73if ENABLE_TEST_RUN
73AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH; 74AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;
@@ -94,3 +95,10 @@ test_peerstore_api_watch_LDADD = \
94 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \ 95 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \
95 $(top_builddir)/src/testing/libgnunettesting.la \ 96 $(top_builddir)/src/testing/libgnunettesting.la \
96 $(top_builddir)/src/util/libgnunetutil.la 97 $(top_builddir)/src/util/libgnunetutil.la
98
99test_peerstore_stress_store_SOURCES = \
100 test_peerstore_stress_store.c
101test_peerstore_stress_store_LDADD = \
102 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \
103 $(top_builddir)/src/testing/libgnunettesting.la \
104 $(top_builddir)/src/util/libgnunetutil.la