aboutsummaryrefslogtreecommitdiff
path: root/src/peerstore/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2014-09-13 13:54:57 +0000
committerChristian Grothoff <christian@grothoff.org>2014-09-13 13:54:57 +0000
commitd94c5185fcdf47c6a57d3233b946fa7e621f7ad9 (patch)
tree1ded577285183d6457bde8787b9bccaa01f12143 /src/peerstore/Makefile.am
parente184df6030ab5c5374fe3b8a94482ff5a30c1580 (diff)
downloadgnunet-d94c5185fcdf47c6a57d3233b946fa7e621f7ad9.tar.gz
gnunet-d94c5185fcdf47c6a57d3233b946fa7e621f7ad9.zip
fixing parallel build, getting rid of useless _DEPENDENCIES declarations
Diffstat (limited to 'src/peerstore/Makefile.am')
-rw-r--r--src/peerstore/Makefile.am19
1 files changed, 8 insertions, 11 deletions
diff --git a/src/peerstore/Makefile.am b/src/peerstore/Makefile.am
index 46f126063..2c96d7268 100644
--- a/src/peerstore/Makefile.am
+++ b/src/peerstore/Makefile.am
@@ -51,18 +51,15 @@ libgnunetpeerstore_la_LDFLAGS = \
51 51
52plugin_LTLIBRARIES = \ 52plugin_LTLIBRARIES = \
53 libgnunet_plugin_peerstore_sqlite.la 53 libgnunet_plugin_peerstore_sqlite.la
54 54
55libgnunet_plugin_peerstore_sqlite_la_SOURCES = \ 55libgnunet_plugin_peerstore_sqlite_la_SOURCES = \
56 plugin_peerstore_sqlite.c 56 plugin_peerstore_sqlite.c
57libgnunet_plugin_peerstore_sqlite_la_LIBADD = \ 57libgnunet_plugin_peerstore_sqlite_la_LIBADD = \
58 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \ 58 libgnunetpeerstore.la \
59 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lsqlite3 \ 59 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) -lsqlite3 \
60 $(LTLIBINTL) 60 $(LTLIBINTL)
61libgnunet_plugin_peerstore_sqlite_la_LDFLAGS = \ 61libgnunet_plugin_peerstore_sqlite_la_LDFLAGS = \
62 $(GN_PLUGIN_LDFLAGS) 62 $(GN_PLUGIN_LDFLAGS)
63libgnunet_plugin_peerstore_sqlite_la_DEPENDENCIES = \
64 $(top_builddir)/src/util/libgnunetutil.la \
65 libgnunetpeerstore.la
66 63
67check_PROGRAMS = \ 64check_PROGRAMS = \
68 test_peerstore_api_store \ 65 test_peerstore_api_store \
@@ -70,7 +67,7 @@ check_PROGRAMS = \
70 test_peerstore_api_watch \ 67 test_peerstore_api_watch \
71 test_peerstore_api_sync \ 68 test_peerstore_api_sync \
72 perf_peerstore_store 69 perf_peerstore_store
73 70
74if ENABLE_TEST_RUN 71if ENABLE_TEST_RUN
75AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH; 72AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;
76TESTS = $(check_PROGRAMS) 73TESTS = $(check_PROGRAMS)
@@ -79,34 +76,34 @@ endif
79test_peerstore_api_store_SOURCES = \ 76test_peerstore_api_store_SOURCES = \
80 test_peerstore_api_store.c 77 test_peerstore_api_store.c
81test_peerstore_api_store_LDADD = \ 78test_peerstore_api_store_LDADD = \
82 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \ 79 libgnunetpeerstore.la \
83 $(top_builddir)/src/testing/libgnunettesting.la \ 80 $(top_builddir)/src/testing/libgnunettesting.la \
84 $(top_builddir)/src/util/libgnunetutil.la 81 $(top_builddir)/src/util/libgnunetutil.la
85 82
86test_peerstore_api_iterate_SOURCES = \ 83test_peerstore_api_iterate_SOURCES = \
87 test_peerstore_api_iterate.c 84 test_peerstore_api_iterate.c
88test_peerstore_api_iterate_LDADD = \ 85test_peerstore_api_iterate_LDADD = \
89 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \ 86 libgnunetpeerstore.la \
90 $(top_builddir)/src/testing/libgnunettesting.la \ 87 $(top_builddir)/src/testing/libgnunettesting.la \
91 $(top_builddir)/src/util/libgnunetutil.la 88 $(top_builddir)/src/util/libgnunetutil.la
92 89
93test_peerstore_api_watch_SOURCES = \ 90test_peerstore_api_watch_SOURCES = \
94 test_peerstore_api_watch.c 91 test_peerstore_api_watch.c
95test_peerstore_api_watch_LDADD = \ 92test_peerstore_api_watch_LDADD = \
96 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \ 93 libgnunetpeerstore.la \
97 $(top_builddir)/src/testing/libgnunettesting.la \ 94 $(top_builddir)/src/testing/libgnunettesting.la \
98 $(top_builddir)/src/util/libgnunetutil.la 95 $(top_builddir)/src/util/libgnunetutil.la
99 96
100test_peerstore_api_sync_SOURCES = \ 97test_peerstore_api_sync_SOURCES = \
101 test_peerstore_api_sync.c 98 test_peerstore_api_sync.c
102test_peerstore_api_sync_LDADD = \ 99test_peerstore_api_sync_LDADD = \
103 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \ 100 libgnunetpeerstore.la \
104 $(top_builddir)/src/testing/libgnunettesting.la \ 101 $(top_builddir)/src/testing/libgnunettesting.la \
105 $(top_builddir)/src/util/libgnunetutil.la 102 $(top_builddir)/src/util/libgnunetutil.la
106 103
107perf_peerstore_store_SOURCES = \ 104perf_peerstore_store_SOURCES = \
108 perf_peerstore_store.c 105 perf_peerstore_store.c
109perf_peerstore_store_LDADD = \ 106perf_peerstore_store_LDADD = \
110 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \ 107 libgnunetpeerstore.la \
111 $(top_builddir)/src/testing/libgnunettesting.la \ 108 $(top_builddir)/src/testing/libgnunettesting.la \
112 $(top_builddir)/src/util/libgnunetutil.la 109 $(top_builddir)/src/util/libgnunetutil.la