aboutsummaryrefslogtreecommitdiff
path: root/src/peerstore/Makefile.am
diff options
context:
space:
mode:
authorOmar Tarabai <tarabai@devegypt.com>2014-07-09 14:46:56 +0000
committerOmar Tarabai <tarabai@devegypt.com>2014-07-09 14:46:56 +0000
commite5d7c67c647e9620c5c1ae77e133a74698443ee1 (patch)
tree1f49323d5963cc4a77e2648b29744ad5cf6291bf /src/peerstore/Makefile.am
parent696df0a02abec9683b34c3097cff4448ad154367 (diff)
downloadgnunet-e5d7c67c647e9620c5c1ae77e133a74698443ee1.tar.gz
gnunet-e5d7c67c647e9620c5c1ae77e133a74698443ee1.zip
Added flag to API disconnect method to send pending store requests before disconnecting.
Added a test case for it.
Diffstat (limited to 'src/peerstore/Makefile.am')
-rw-r--r--src/peerstore/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/peerstore/Makefile.am b/src/peerstore/Makefile.am
index 4c5e4af8c..71898bdea 100644
--- a/src/peerstore/Makefile.am
+++ b/src/peerstore/Makefile.am
@@ -68,6 +68,7 @@ check_PROGRAMS = \
68 test_peerstore_api_store \ 68 test_peerstore_api_store \
69 test_peerstore_api_iterate \ 69 test_peerstore_api_iterate \
70 test_peerstore_api_watch \ 70 test_peerstore_api_watch \
71 test_peerstore_api_sync \
71 perf_peerstore_store 72 perf_peerstore_store
72 73
73if ENABLE_TEST_RUN 74if ENABLE_TEST_RUN
@@ -96,6 +97,13 @@ test_peerstore_api_watch_LDADD = \
96 $(top_builddir)/src/testing/libgnunettesting.la \ 97 $(top_builddir)/src/testing/libgnunettesting.la \
97 $(top_builddir)/src/util/libgnunetutil.la 98 $(top_builddir)/src/util/libgnunetutil.la
98 99
100test_peerstore_api_sync_SOURCES = \
101 test_peerstore_api_sync.c
102test_peerstore_api_sync_LDADD = \
103 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \
104 $(top_builddir)/src/testing/libgnunettesting.la \
105 $(top_builddir)/src/util/libgnunetutil.la
106
99perf_peerstore_store_SOURCES = \ 107perf_peerstore_store_SOURCES = \
100 perf_peerstore_store.c 108 perf_peerstore_store.c
101perf_peerstore_store_LDADD = \ 109perf_peerstore_store_LDADD = \