aboutsummaryrefslogtreecommitdiff
path: root/src/pq/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2016-02-05 22:24:10 +0000
committerChristian Grothoff <christian@grothoff.org>2016-02-05 22:24:10 +0000
commitd75a2de4e9a450269291a47593f2e50c37eca733 (patch)
tree915d9cf6f76d8cfb2e7fb80f948aa362e72a944f /src/pq/Makefile.am
parent522bd40f4cee9e5546d15128f76d18799017220c (diff)
downloadgnunet-d75a2de4e9a450269291a47593f2e50c37eca733.tar.gz
gnunet-d75a2de4e9a450269291a47593f2e50c37eca733.zip
creating libgnunetpq library
Diffstat (limited to 'src/pq/Makefile.am')
-rw-r--r--src/pq/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/src/pq/Makefile.am b/src/pq/Makefile.am
new file mode 100644
index 000000000..66f57838e
--- /dev/null
+++ b/src/pq/Makefile.am
@@ -0,0 +1,39 @@
1# This Makefile.am is in the public domain
2AM_CPPFLAGS = -I$(top_srcdir)/src/include $(POSTGRESQL_CPPFLAGS)
3
4if MINGW
5 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
6endif
7
8if USE_COVERAGE
9 AM_CFLAGS = --coverage
10endif
11
12if HAVE_POSTGRESQL
13lib_LTLIBRARIES = libgnunetpq.la
14endif
15
16libgnunetpq_la_SOURCES = \
17 pq.c \
18 pq_query_helper.c \
19 pq_result_helper.c
20libgnunetpq_la_LIBADD = -lpq \
21 $(top_builddir)/src/util/libgnunetutil.la
22libgnunetpq_la_LDFLAGS = \
23 $(POSTGRESQL_LDFLAGS) \
24 $(GN_LIB_LDFLAGS) \
25 -version-info 0:0:0
26
27
28TESTS = \
29 test_pq
30
31check_PROGRAMS= \
32 test_pq
33
34test_pq_SOURCES = \
35 test_pq.c
36test_pq_LDADD = \
37 libgnunetpq.la \
38 $(top_builddir)/src/util/libgnunetutil.la \
39 -lpq $(XLIB)