aboutsummaryrefslogtreecommitdiff
path: root/src/pt/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-06-04 12:46:35 +0000
committerChristian Grothoff <christian@grothoff.org>2013-06-04 12:46:35 +0000
commita4de07fd32aa846b48da80980da97e292bdae691 (patch)
tree6e0f717a78899b586917dac4ef6978611a4f0153 /src/pt/Makefile.am
parenteb9f75cf04f449f04713af6584ccae9e42b49eb2 (diff)
downloadgnunet-a4de07fd32aa846b48da80980da97e292bdae691.tar.gz
gnunet-a4de07fd32aa846b48da80980da97e292bdae691.zip
-duplication
Diffstat (limited to 'src/pt/Makefile.am')
-rw-r--r--src/pt/Makefile.am221
1 files changed, 110 insertions, 111 deletions
diff --git a/src/pt/Makefile.am b/src/pt/Makefile.am
index 396fa0d16..a9ae4fa5e 100644
--- a/src/pt/Makefile.am
+++ b/src/pt/Makefile.am
@@ -1,111 +1,110 @@
1INCLUDES = -I$(top_srcdir)/src/include 1INCLUDES = -I$(top_srcdir)/src/include
2 2
3if MINGW 3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols 4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
5endif 5endif
6 6
7if USE_COVERAGE 7if USE_COVERAGE
8 AM_CFLAGS = --coverage -O0 8 AM_CFLAGS = --coverage -O0
9endif 9endif
10 10
11pkgcfgdir= $(pkgdatadir)/config.d/ 11pkgcfgdir= $(pkgdatadir)/config.d/
12 12
13libexecdir= $(pkglibdir)/libexec/ 13libexecdir= $(pkglibdir)/libexec/
14 14
15plugindir = $(libdir)/gnunet 15plugindir = $(libdir)/gnunet
16 16
17dist_pkgcfg_DATA = \ 17dist_pkgcfg_DATA = \
18 pt.conf 18 pt.conf
19 19
20libexec_PROGRAMS = \ 20libexec_PROGRAMS = \
21 gnunet-daemon-pt 21 gnunet-daemon-pt
22 22
23gnunet_daemon_pt_SOURCES = \ 23gnunet_daemon_pt_SOURCES = \
24 gnunet-daemon-pt.c 24 gnunet-daemon-pt.c
25gnunet_daemon_pt_LDADD = \ 25gnunet_daemon_pt_LDADD = \
26 $(top_builddir)/src/vpn/libgnunetvpn.la \ 26 $(top_builddir)/src/vpn/libgnunetvpn.la \
27 $(top_builddir)/src/mesh/libgnunetmesh.la \ 27 $(top_builddir)/src/mesh/libgnunetmesh.la \
28 $(top_builddir)/src/dns/libgnunetdns.la \ 28 $(top_builddir)/src/dns/libgnunetdns.la \
29 $(top_builddir)/src/dns/libgnunetdnsparser.la \ 29 $(top_builddir)/src/dns/libgnunetdnsparser.la \
30 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 30 $(top_builddir)/src/statistics/libgnunetstatistics.la \
31 $(top_builddir)/src/util/libgnunetutil.la \ 31 $(top_builddir)/src/util/libgnunetutil.la \
32 $(top_builddir)/src/mesh/libgnunetmesh.la \ 32 $(GN_LIBINTL)
33 $(GN_LIBINTL) 33
34 34if HAVE_MHD
35if HAVE_MHD 35if HAVE_LIBCURL
36if HAVE_LIBCURL 36if LINUX
37if LINUX 37 VPN_TEST = \
38 VPN_TEST = \ 38 test_gnunet_vpn-4_to_6 \
39 test_gnunet_vpn-4_to_6 \ 39 test_gnunet_vpn-6_to_4 \
40 test_gnunet_vpn-6_to_4 \ 40 test_gnunet_vpn-6_over \
41 test_gnunet_vpn-6_over \ 41 test_gnunet_vpn-4_over \
42 test_gnunet_vpn-4_over \ 42 test_gns_vpn
43 test_gns_vpn 43endif
44endif 44if MINGW
45if MINGW 45 VPN_TEST = \
46 VPN_TEST = \ 46 test_gnunet_vpn-4_to_6 \
47 test_gnunet_vpn-4_to_6 \ 47 test_gnunet_vpn-6_to_4 \
48 test_gnunet_vpn-6_to_4 \ 48 test_gnunet_vpn-6_over \
49 test_gnunet_vpn-6_over \ 49 test_gnunet_vpn-4_over
50 test_gnunet_vpn-4_over 50endif
51endif 51endif
52endif 52endif
53endif 53
54 54check_PROGRAMS = $(VPN_TEST)
55check_PROGRAMS = $(VPN_TEST) 55
56 56if ENABLE_TEST_RUN
57if ENABLE_TEST_RUN 57TESTS = $(check_PROGRAMS)
58TESTS = $(check_PROGRAMS) 58endif
59endif 59
60 60EXTRA_DIST = \
61EXTRA_DIST = \ 61 test_gnunet_vpn.conf \
62 test_gnunet_vpn.conf \ 62 test_gns_vpn.conf
63 test_gns_vpn.conf 63
64 64
65 65
66 66test_gns_vpn_SOURCES = \
67test_gns_vpn_SOURCES = \ 67 test_gns_vpn.c
68 test_gns_vpn.c 68test_gns_vpn_LDADD = -lmicrohttpd @LIBCURL@ \
69test_gns_vpn_LDADD = -lmicrohttpd @LIBCURL@ \ 69 $(top_builddir)/src/namestore/libgnunetnamestore.la \
70 $(top_builddir)/src/namestore/libgnunetnamestore.la \ 70 $(top_builddir)/src/testing/libgnunettesting.la \
71 $(top_builddir)/src/testing/libgnunettesting.la \ 71 $(top_builddir)/src/util/libgnunetutil.la
72 $(top_builddir)/src/util/libgnunetutil.la 72test_gns_vpn_CPPFLAGS = \
73test_gns_vpn_CPPFLAGS = \ 73 @LIBCURL_CPPFLAGS@
74 @LIBCURL_CPPFLAGS@ 74
75 75test_gnunet_vpn_4_over_SOURCES = \
76test_gnunet_vpn_4_over_SOURCES = \ 76 test_gnunet_vpn.c
77 test_gnunet_vpn.c 77test_gnunet_vpn_4_over_LDADD = -lmicrohttpd @LIBCURL@ \
78test_gnunet_vpn_4_over_LDADD = -lmicrohttpd @LIBCURL@ \ 78 $(top_builddir)/src/vpn/libgnunetvpn.la \
79 $(top_builddir)/src/vpn/libgnunetvpn.la \ 79 $(top_builddir)/src/testing/libgnunettesting.la \
80 $(top_builddir)/src/testing/libgnunettesting.la \ 80 $(top_builddir)/src/util/libgnunetutil.la
81 $(top_builddir)/src/util/libgnunetutil.la 81test_gnunet_vpn_4_over_CPPFLAGS = \
82test_gnunet_vpn_4_over_CPPFLAGS = \ 82 @LIBCURL_CPPFLAGS@
83 @LIBCURL_CPPFLAGS@ 83
84 84test_gnunet_vpn_6_over_SOURCES = \
85test_gnunet_vpn_6_over_SOURCES = \ 85 test_gnunet_vpn.c
86 test_gnunet_vpn.c 86test_gnunet_vpn_6_over_LDADD = -lmicrohttpd @LIBCURL@ \
87test_gnunet_vpn_6_over_LDADD = -lmicrohttpd @LIBCURL@ \ 87 $(top_builddir)/src/vpn/libgnunetvpn.la \
88 $(top_builddir)/src/vpn/libgnunetvpn.la \ 88 $(top_builddir)/src/testing/libgnunettesting.la \
89 $(top_builddir)/src/testing/libgnunettesting.la \ 89 $(top_builddir)/src/util/libgnunetutil.la
90 $(top_builddir)/src/util/libgnunetutil.la 90test_gnunet_vpn_6_over_CPPFLAGS = \
91test_gnunet_vpn_6_over_CPPFLAGS = \ 91 @LIBCURL_CPPFLAGS@
92 @LIBCURL_CPPFLAGS@ 92
93 93test_gnunet_vpn_4_to_6_SOURCES = \
94test_gnunet_vpn_4_to_6_SOURCES = \ 94 test_gnunet_vpn.c
95 test_gnunet_vpn.c 95test_gnunet_vpn_4_to_6_LDADD = -lmicrohttpd @LIBCURL@ \
96test_gnunet_vpn_4_to_6_LDADD = -lmicrohttpd @LIBCURL@ \ 96 $(top_builddir)/src/vpn/libgnunetvpn.la \
97 $(top_builddir)/src/vpn/libgnunetvpn.la \ 97 $(top_builddir)/src/testing/libgnunettesting.la \
98 $(top_builddir)/src/testing/libgnunettesting.la \ 98 $(top_builddir)/src/util/libgnunetutil.la
99 $(top_builddir)/src/util/libgnunetutil.la 99test_gnunet_vpn_4_to_6_CPPFLAGS = \
100test_gnunet_vpn_4_to_6_CPPFLAGS = \ 100 @LIBCURL_CPPFLAGS@
101 @LIBCURL_CPPFLAGS@ 101
102 102test_gnunet_vpn_6_to_4_SOURCES = \
103test_gnunet_vpn_6_to_4_SOURCES = \ 103 test_gnunet_vpn.c
104 test_gnunet_vpn.c 104test_gnunet_vpn_6_to_4_LDADD = -lmicrohttpd @LIBCURL@ \
105test_gnunet_vpn_6_to_4_LDADD = -lmicrohttpd @LIBCURL@ \ 105 $(top_builddir)/src/vpn/libgnunetvpn.la \
106 $(top_builddir)/src/vpn/libgnunetvpn.la \ 106 $(top_builddir)/src/testing/libgnunettesting.la \
107 $(top_builddir)/src/testing/libgnunettesting.la \ 107 $(top_builddir)/src/util/libgnunetutil.la
108 $(top_builddir)/src/util/libgnunetutil.la 108test_gnunet_vpn_6_to_4_CPPFLAGS = \
109test_gnunet_vpn_6_to_4_CPPFLAGS = \ 109 @LIBCURL_CPPFLAGS@
110 @LIBCURL_CPPFLAGS@ 110
111