aboutsummaryrefslogtreecommitdiff
path: root/src/pt/Makefile.am
diff options
context:
space:
mode:
authorChristian Fuchs <christian.fuchs@cfuchs.net>2013-04-15 12:36:37 +0000
committerChristian Fuchs <christian.fuchs@cfuchs.net>2013-04-15 12:36:37 +0000
commitad68ae150f17cf6e0b2c605c9331cf0aedfce1d0 (patch)
tree9079e9ce1b942683e45f2f5212fe2f9ce1bd5d56 /src/pt/Makefile.am
parentfbda84a3f00a667f4b149f00f9a7d330e5db54a8 (diff)
downloadgnunet-ad68ae150f17cf6e0b2c605c9331cf0aedfce1d0.tar.gz
gnunet-ad68ae150f17cf6e0b2c605c9331cf0aedfce1d0.zip
extended the GNUNET_OS_check_helper_binary parameters to do previlege
checking in windows. To do so, tested binaries must still be supplied with valid commandline arguments, but on windows gnunet will utilize the -d flag to run the programs initialization phase or privileged operations only. In these modes, a program will not enter its mainloop or communicate with the outside. updated relevant function calls gnunet-wide to meet the extended function parameters.
Diffstat (limited to 'src/pt/Makefile.am')
-rw-r--r--src/pt/Makefile.am211
1 files changed, 109 insertions, 102 deletions
diff --git a/src/pt/Makefile.am b/src/pt/Makefile.am
index b9a8e497c..ed7892fe0 100644
--- a/src/pt/Makefile.am
+++ b/src/pt/Makefile.am
@@ -1,102 +1,109 @@
1INCLUDES = -I$(top_srcdir)/src/include 1INCLUDES = -I$(top_srcdir)/src/include
2 2
3if MINGW 3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols 4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
5endif 5endif
6 6
7if USE_COVERAGE 7if USE_COVERAGE
8 AM_CFLAGS = --coverage -O0 8 AM_CFLAGS = --coverage -O0
9endif 9endif
10 10
11pkgcfgdir= $(pkgdatadir)/config.d/ 11pkgcfgdir= $(pkgdatadir)/config.d/
12 12
13libexecdir= $(pkglibdir)/libexec/ 13libexecdir= $(pkglibdir)/libexec/
14 14
15plugindir = $(libdir)/gnunet 15plugindir = $(libdir)/gnunet
16 16
17dist_pkgcfg_DATA = \ 17dist_pkgcfg_DATA = \
18 pt.conf 18 pt.conf
19 19
20libexec_PROGRAMS = \ 20libexec_PROGRAMS = \
21 gnunet-daemon-pt 21 gnunet-daemon-pt
22 22
23gnunet_daemon_pt_SOURCES = \ 23gnunet_daemon_pt_SOURCES = \
24 gnunet-daemon-pt.c 24 gnunet-daemon-pt.c
25gnunet_daemon_pt_LDADD = \ 25gnunet_daemon_pt_LDADD = \
26 $(top_builddir)/src/vpn/libgnunetvpn.la \ 26 $(top_builddir)/src/vpn/libgnunetvpn.la \
27 $(top_builddir)/src/mesh/libgnunetmesh.la \ 27 $(top_builddir)/src/mesh/libgnunetmesh.la \
28 $(top_builddir)/src/dns/libgnunetdns.la \ 28 $(top_builddir)/src/dns/libgnunetdns.la \
29 $(top_builddir)/src/dns/libgnunetdnsparser.la \ 29 $(top_builddir)/src/dns/libgnunetdnsparser.la \
30 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 30 $(top_builddir)/src/statistics/libgnunetstatistics.la \
31 $(top_builddir)/src/util/libgnunetutil.la \ 31 $(top_builddir)/src/util/libgnunetutil.la \
32 $(top_builddir)/src/mesh/libgnunetmesh.la \ 32 $(top_builddir)/src/mesh/libgnunetmesh.la \
33 $(GN_LIBINTL) 33 $(GN_LIBINTL)
34 34
35if HAVE_MHD 35if HAVE_MHD
36if LINUX 36if LINUX
37 VPN_TEST = \ 37 VPN_TEST = \
38 test_gnunet_vpn-4_to_6 \ 38 test_gnunet_vpn-4_to_6 \
39 test_gnunet_vpn-6_to_4 \ 39 test_gnunet_vpn-6_to_4 \
40 test_gnunet_vpn-6_over \ 40 test_gnunet_vpn-6_over \
41 test_gnunet_vpn-4_over \ 41 test_gnunet_vpn-4_over \
42 test_gns_vpn 42 test_gns_vpn
43endif 43endif
44endif 44if MINGW
45 45 VPN_TEST = \
46check_PROGRAMS = $(VPN_TEST) 46 test_gnunet_vpn-4_to_6 \
47 47 test_gnunet_vpn-6_to_4 \
48if ENABLE_TEST_RUN 48 test_gnunet_vpn-6_over \
49TESTS = $(check_PROGRAMS) 49 test_gnunet_vpn-4_over
50endif 50endif
51 51endif
52EXTRA_DIST = \ 52
53 test_gnunet_vpn.conf \ 53check_PROGRAMS = $(VPN_TEST)
54 test_gns_vpn.conf 54
55 55if ENABLE_TEST_RUN
56 56TESTS = $(check_PROGRAMS)
57 57endif
58test_gns_vpn_SOURCES = \ 58
59 test_gns_vpn.c 59EXTRA_DIST = \
60test_gns_vpn_LDADD = -lmicrohttpd @LIBCURL@ \ 60 test_gnunet_vpn.conf \
61 $(top_builddir)/src/namestore/libgnunetnamestore.la \ 61 test_gns_vpn.conf
62 $(top_builddir)/src/testing/libgnunettesting.la \ 62
63 $(top_builddir)/src/util/libgnunetutil.la 63
64test_gns_vpn_CPPFLAGS = \ 64
65 @LIBCURL_CPPFLAGS@ 65test_gns_vpn_SOURCES = \
66 66 test_gns_vpn.c
67test_gnunet_vpn_4_over_SOURCES = \ 67test_gns_vpn_LDADD = -lmicrohttpd @LIBCURL@ \
68 test_gnunet_vpn.c 68 $(top_builddir)/src/namestore/libgnunetnamestore.la \
69test_gnunet_vpn_4_over_LDADD = -lmicrohttpd @LIBCURL@ \ 69 $(top_builddir)/src/testing/libgnunettesting.la \
70 $(top_builddir)/src/vpn/libgnunetvpn.la \ 70 $(top_builddir)/src/util/libgnunetutil.la
71 $(top_builddir)/src/testing/libgnunettesting.la \ 71test_gns_vpn_CPPFLAGS = \
72 $(top_builddir)/src/util/libgnunetutil.la 72 @LIBCURL_CPPFLAGS@
73test_gnunet_vpn_4_over_CPPFLAGS = \ 73
74 @LIBCURL_CPPFLAGS@ 74test_gnunet_vpn_4_over_SOURCES = \
75 75 test_gnunet_vpn.c
76test_gnunet_vpn_6_over_SOURCES = \ 76test_gnunet_vpn_4_over_LDADD = -lmicrohttpd @LIBCURL@ \
77 test_gnunet_vpn.c 77 $(top_builddir)/src/vpn/libgnunetvpn.la \
78test_gnunet_vpn_6_over_LDADD = -lmicrohttpd @LIBCURL@ \ 78 $(top_builddir)/src/testing/libgnunettesting.la \
79 $(top_builddir)/src/vpn/libgnunetvpn.la \ 79 $(top_builddir)/src/util/libgnunetutil.la
80 $(top_builddir)/src/testing/libgnunettesting.la \ 80test_gnunet_vpn_4_over_CPPFLAGS = \
81 $(top_builddir)/src/util/libgnunetutil.la 81 @LIBCURL_CPPFLAGS@
82test_gnunet_vpn_6_over_CPPFLAGS = \ 82
83 @LIBCURL_CPPFLAGS@ 83test_gnunet_vpn_6_over_SOURCES = \
84 84 test_gnunet_vpn.c
85test_gnunet_vpn_4_to_6_SOURCES = \ 85test_gnunet_vpn_6_over_LDADD = -lmicrohttpd @LIBCURL@ \
86 test_gnunet_vpn.c 86 $(top_builddir)/src/vpn/libgnunetvpn.la \
87test_gnunet_vpn_4_to_6_LDADD = -lmicrohttpd @LIBCURL@ \ 87 $(top_builddir)/src/testing/libgnunettesting.la \
88 $(top_builddir)/src/vpn/libgnunetvpn.la \ 88 $(top_builddir)/src/util/libgnunetutil.la
89 $(top_builddir)/src/testing/libgnunettesting.la \ 89test_gnunet_vpn_6_over_CPPFLAGS = \
90 $(top_builddir)/src/util/libgnunetutil.la 90 @LIBCURL_CPPFLAGS@
91test_gnunet_vpn_4_to_6_CPPFLAGS = \ 91
92 @LIBCURL_CPPFLAGS@ 92test_gnunet_vpn_4_to_6_SOURCES = \
93 93 test_gnunet_vpn.c
94test_gnunet_vpn_6_to_4_SOURCES = \ 94test_gnunet_vpn_4_to_6_LDADD = -lmicrohttpd @LIBCURL@ \
95 test_gnunet_vpn.c 95 $(top_builddir)/src/vpn/libgnunetvpn.la \
96test_gnunet_vpn_6_to_4_LDADD = -lmicrohttpd @LIBCURL@ \ 96 $(top_builddir)/src/testing/libgnunettesting.la \
97 $(top_builddir)/src/vpn/libgnunetvpn.la \ 97 $(top_builddir)/src/util/libgnunetutil.la
98 $(top_builddir)/src/testing/libgnunettesting.la \ 98test_gnunet_vpn_4_to_6_CPPFLAGS = \
99 $(top_builddir)/src/util/libgnunetutil.la 99 @LIBCURL_CPPFLAGS@
100test_gnunet_vpn_6_to_4_CPPFLAGS = \ 100
101 @LIBCURL_CPPFLAGS@ 101test_gnunet_vpn_6_to_4_SOURCES = \
102 102 test_gnunet_vpn.c
103test_gnunet_vpn_6_to_4_LDADD = -lmicrohttpd @LIBCURL@ \
104 $(top_builddir)/src/vpn/libgnunetvpn.la \
105 $(top_builddir)/src/testing/libgnunettesting.la \
106 $(top_builddir)/src/util/libgnunetutil.la
107test_gnunet_vpn_6_to_4_CPPFLAGS = \
108 @LIBCURL_CPPFLAGS@
109