aboutsummaryrefslogtreecommitdiff
path: root/src/reclaim/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2022-01-14 18:24:13 +0100
committerMartin Schanzenbach <schanzen@gnunet.org>2022-01-14 18:24:13 +0100
commitdf8660ffec05d108d59de191ddc5114c4678a362 (patch)
treeb99c80f689bf07f2a999c6abbfb1f042c1bdedf6 /src/reclaim/Makefile.am
parent7064aca619f59b7c19ff7e8c645d48995728a66c (diff)
downloadgnunet-df8660ffec05d108d59de191ddc5114c4678a362.tar.gz
gnunet-df8660ffec05d108d59de191ddc5114c4678a362.zip
-move to reclaim
Diffstat (limited to 'src/reclaim/Makefile.am')
-rw-r--r--src/reclaim/Makefile.am22
1 files changed, 20 insertions, 2 deletions
diff --git a/src/reclaim/Makefile.am b/src/reclaim/Makefile.am
index 350d77d4b..6b5934a2f 100644
--- a/src/reclaim/Makefile.am
+++ b/src/reclaim/Makefile.am
@@ -43,7 +43,8 @@ plugin_LTLIBRARIES = \
43 $(REST_PLUGIN) 43 $(REST_PLUGIN)
44 44
45bin_PROGRAMS = \ 45bin_PROGRAMS = \
46 gnunet-reclaim 46 gnunet-reclaim \
47 gnunet-did
47 48
48libexec_PROGRAMS = \ 49libexec_PROGRAMS = \
49 gnunet-service-reclaim 50 gnunet-service-reclaim
@@ -187,13 +188,30 @@ test_reclaim_attribute_LDADD = \
187 libgnunetreclaim.la \ 188 libgnunetreclaim.la \
188 $(GN_LIBINTL) 189 $(GN_LIBINTL)
189 190
191gnunet_did_SOURCES = \
192 gnunet-did.c
193gnunet_did_LDADD = \
194 $(top_builddir)/src/util/libgnunetutil.la \
195 $(top_builddir)/src/gns/libgnunetgns.la \
196 $(top_builddir)/src/gnsrecord/libgnunetgnsrecord.la \
197 $(top_builddir)/src/identity/libgnunetidentity.la \
198 $(top_builddir)/src/namestore/libgnunetnamestore.la \
199 -ljansson
200
201
202test_w3c_ed25519_2020_SOURCES = \
203 test_w3c_ed25519_2020.c
204test_w3c_ed25519_2020_LDADD = \
205 $(top_builddir)/src/util/libgnunetutil.la
206
190check_SCRIPTS = \ 207check_SCRIPTS = \
191 test_reclaim_attribute.sh \ 208 test_reclaim_attribute.sh \
192 test_reclaim_issue.sh \ 209 test_reclaim_issue.sh \
193 test_reclaim_consume.sh 210 test_reclaim_consume.sh
194 211
195check_PROGRAMS = \ 212check_PROGRAMS = \
196 test_reclaim_attribute 213 test_reclaim_attribute \
214 test_w3c_ed25519_2020
197 215
198if ENABLE_TEST_RUN 216if ENABLE_TEST_RUN
199 AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; 217 AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;