aboutsummaryrefslogtreecommitdiff
path: root/src/rps/Makefile.am
diff options
context:
space:
mode:
authorBart Polot <bart@net.in.tum.de>2014-12-05 14:07:11 +0000
committerBart Polot <bart@net.in.tum.de>2014-12-05 14:07:11 +0000
commit6cd1fc3aa29926ce0326d07ba684e1b65a1a0db7 (patch)
treeb201a08dda53a39a1572a18d8e08d0359896ea74 /src/rps/Makefile.am
parentf78293457b6e5d922d199a0c1f28a544ba943e7a (diff)
downloadgnunet-6cd1fc3aa29926ce0326d07ba684e1b65a1a0db7.tar.gz
gnunet-6cd1fc3aa29926ce0326d07ba684e1b65a1a0db7.zip
Import RPS
Diffstat (limited to 'src/rps/Makefile.am')
-rw-r--r--src/rps/Makefile.am76
1 files changed, 76 insertions, 0 deletions
diff --git a/src/rps/Makefile.am b/src/rps/Makefile.am
new file mode 100644
index 000000000..f6c31b107
--- /dev/null
+++ b/src/rps/Makefile.am
@@ -0,0 +1,76 @@
1AM_CPPFLAGS = -I$(top_srcdir)/src/include
2
3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
5endif
6
7if USE_COVERAGE
8 AM_CFLAGS = --coverage -O0
9 XLIB = -lgcov
10endif
11
12pkgcfgdir= $(pkgdatadir)/config.d/
13
14libexecdir= $(pkglibdir)/libexec/
15
16pkgcfg_DATA = \
17 rps.conf
18
19bin_PROGRAMS = gnunet-rps
20
21gnunet_rps_SOURCES = gnunet-rps.c
22gnunet_rps_LDADD = \
23 libgnunetrps.la \
24 $(top_builddir)/src/util/libgnunetutil.la \
25 $(XLIB) $(GN_LIBINTL)
26
27lib_LTLIBRARIES = libgnunetrps.la
28
29libgnunetrps_la_SOURCES = \
30 rps_api.c rps.h
31libgnunetrps_la_LIBADD = \
32 $(top_builddir)/src/util/libgnunetutil.la \
33 $(GN_LIBINTL) $(XLIB)
34libgnunetrps_la_LDFLAGS = \
35 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
36 -version-info 0:0:0
37
38
39libexec_PROGRAMS = \
40 gnunet-service-rps
41
42
43gnunet_service_rps_SOURCES = \
44 gnunet-service-rps.c
45gnunet_service_rps_LDADD = \
46 libgnunetrps.la \
47 $(top_builddir)/src/util/libgnunetutil.la \
48 $(top_builddir)/src/cadet/libgnunetcadet.la \
49 $(top_builddir)/src/nse/libgnunetnse.la \
50 $(top_builddir)/src/statistics/libgnunetstatistics.la \
51 $(LIBGCRYPT_LIBS) \
52 -lm -lgcrypt \
53 $(GN_LIBINTL)
54
55if HAVE_TESTING
56check_PROGRAMS = \
57 test_rps_multipeer
58endif
59
60if ENABLE_TEST_RUN
61AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;
62TESTS = $(check_PROGRAMS)
63endif
64
65test_rps_multipeer_SOURCES = \
66 test_rps_multipeer.c
67test_rps_multipeer_LDADD = \
68 libgnunetrps.la \
69 $(top_builddir)/src/util/libgnunetutil.la \
70 $(top_builddir)/src/testbed/libgnunettestbed.la \
71 -lm
72
73
74EXTRA_DIST = \
75 test_rps.conf
76