aboutsummaryrefslogtreecommitdiff
path: root/src/rps/Makefile.am
diff options
context:
space:
mode:
authorJulius Bünger <buenger@mytum.de>2015-02-23 14:35:02 +0000
committerJulius Bünger <buenger@mytum.de>2015-02-23 14:35:02 +0000
commit7f424af3f7d3d3271feafecc6330185e76f95ee2 (patch)
tree548341830a1648620a0697533136423ef5ca95a9 /src/rps/Makefile.am
parentf63e66fdbf2b8f066b2cf447e5291cbaa898cb87 (diff)
downloadgnunet-7f424af3f7d3d3271feafecc6330185e76f95ee2.tar.gz
gnunet-7f424af3f7d3d3271feafecc6330185e76f95ee2.zip
- sending act malicious message
Diffstat (limited to 'src/rps/Makefile.am')
-rw-r--r--src/rps/Makefile.am19
1 files changed, 13 insertions, 6 deletions
diff --git a/src/rps/Makefile.am b/src/rps/Makefile.am
index 488cea152..fe086e59c 100644
--- a/src/rps/Makefile.am
+++ b/src/rps/Makefile.am
@@ -58,9 +58,17 @@ gnunet_service_rps_LDADD = \
58 58
59if HAVE_TESTING 59if HAVE_TESTING
60check_PROGRAMS = \ 60check_PROGRAMS = \
61 test_rps_multipeer 61 test_rps_multipeer \
62 test_rps_malicious_1
62endif 63endif
63 64
65ld_rps_test_lib = \
66 libgnunetrps.la \
67 $(top_builddir)/src/util/libgnunetutil.la \
68 $(top_builddir)/src/testbed/libgnunettestbed.la \
69 -lm
70
71
64if ENABLE_TEST_RUN 72if ENABLE_TEST_RUN
65AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH; 73AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;
66TESTS = $(check_PROGRAMS) 74TESTS = $(check_PROGRAMS)
@@ -68,12 +76,11 @@ endif
68 76
69test_rps_multipeer_SOURCES = \ 77test_rps_multipeer_SOURCES = \
70 test_rps_multipeer.c 78 test_rps_multipeer.c
71test_rps_multipeer_LDADD = \ 79test_rps_multipeer_LDADD = $(ld_rps_test_lib)
72 libgnunetrps.la \
73 $(top_builddir)/src/util/libgnunetutil.la \
74 $(top_builddir)/src/testbed/libgnunettestbed.la \
75 -lm
76 80
81test_rps_malicious_1_SOURCES = \
82 test_rps_malicious_1.c
83test_rps_malicious_1_LDADD = $(ld_rps_test_lib)
77 84
78EXTRA_DIST = \ 85EXTRA_DIST = \
79 test_rps.conf 86 test_rps.conf