aboutsummaryrefslogtreecommitdiff
path: root/src/rps/Makefile.am
diff options
context:
space:
mode:
authorJulius Bünger <buenger@mytum.de>2018-06-06 00:33:56 +0200
committerJulius Bünger <buenger@mytum.de>2018-06-06 00:34:36 +0200
commitd15b9286cbaa6f56299f9064d269d3a1aa1ddee4 (patch)
treed9798b5d8495cdd4b92c58a1015a8f83bbe827d1 /src/rps/Makefile.am
parent6ab858be606ee40db66e349c165a6862a79c65a4 (diff)
downloadgnunet-d15b9286cbaa6f56299f9064d269d3a1aa1ddee4.tar.gz
gnunet-d15b9286cbaa6f56299f9064d269d3a1aa1ddee4.zip
rps: split tests and profiler, proper shutdown
Diffstat (limited to 'src/rps/Makefile.am')
-rw-r--r--src/rps/Makefile.am16
1 files changed, 10 insertions, 6 deletions
diff --git a/src/rps/Makefile.am b/src/rps/Makefile.am
index b5f712268..aa354dff7 100644
--- a/src/rps/Makefile.am
+++ b/src/rps/Makefile.am
@@ -83,17 +83,17 @@ check_PROGRAMS = \
83 test_rps_churn 83 test_rps_churn
84endif 84endif
85 85
86rps_test_src = \
87 test_rps.c \
88 rps-test_util.h rps-test_util.c \
89 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c
90
86ld_rps_test_lib = \ 91ld_rps_test_lib = \
87 libgnunetrps.la \ 92 libgnunetrps.la \
88 $(top_builddir)/src/util/libgnunetutil.la \ 93 $(top_builddir)/src/util/libgnunetutil.la \
89 $(top_builddir)/src/testbed/libgnunettestbed.la \ 94 $(top_builddir)/src/testbed/libgnunettestbed.la \
90 -lm 95 -lm
91 96
92rps_test_src = \
93 test_rps.c \
94 rps-test_util.h rps-test_util.c \
95 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c
96
97if ENABLE_TEST_RUN 97if ENABLE_TEST_RUN
98AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; 98AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
99TESTS = $(check_PROGRAMS) 99TESTS = $(check_PROGRAMS)
@@ -143,7 +143,11 @@ test_rps_churn_LDADD = $(ld_rps_test_lib)
143gnunet_rps_profiler_SOURCES = $(rps_test_src) 143gnunet_rps_profiler_SOURCES = $(rps_test_src)
144gnunet_rps_profiler_LDADD = \ 144gnunet_rps_profiler_LDADD = \
145 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 145 $(top_builddir)/src/statistics/libgnunetstatistics.la \
146 $(ld_rps_test_lib) 146 libgnunetrps.la \
147 $(top_builddir)/src/util/libgnunetutil.la \
148 $(top_builddir)/src/testbed/libgnunettestbed.la \
149 -lm
150
147 151
148EXTRA_DIST = \ 152EXTRA_DIST = \
149 test_rps.conf 153 test_rps.conf