aboutsummaryrefslogtreecommitdiff
path: root/src/rps/Makefile.am
diff options
context:
space:
mode:
authorJulius Bünger <buenger@mytum.de>2015-07-23 18:21:49 +0000
committerJulius Bünger <buenger@mytum.de>2015-07-23 18:21:49 +0000
commitff073fe2f2c6a0fe0532061533c570acfba60e7d (patch)
tree43bd8220c5414f04ba20ec8362e1cc2cd15057a4 /src/rps/Makefile.am
parent66fa52570d0d9f29d8b6bf8bd4667c18931b3806 (diff)
downloadgnunet-ff073fe2f2c6a0fe0532061533c570acfba60e7d.tar.gz
gnunet-ff073fe2f2c6a0fe0532061533c570acfba60e7d.zip
get perfect sample of each sampler element
Diffstat (limited to 'src/rps/Makefile.am')
-rw-r--r--src/rps/Makefile.am22
1 files changed, 10 insertions, 12 deletions
diff --git a/src/rps/Makefile.am b/src/rps/Makefile.am
index fc0b9848d..b1ebffee4 100644
--- a/src/rps/Makefile.am
+++ b/src/rps/Makefile.am
@@ -81,34 +81,32 @@ ld_rps_test_lib = \
81 $(top_builddir)/src/testbed/libgnunettestbed.la \ 81 $(top_builddir)/src/testbed/libgnunettestbed.la \
82 -lm 82 -lm
83 83
84rps_test_src = \
85 test_rps.c \
86 rps-test_util.h rps-test_util.c \
87 gnunet-service-rps_sampler_elem.h gnunet-service-rps_sampler_elem.c
84 88
85if ENABLE_TEST_RUN 89if ENABLE_TEST_RUN
86AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH; 90AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;
87TESTS = $(check_PROGRAMS) 91TESTS = $(check_PROGRAMS)
88endif 92endif
89 93
90test_rps_malicious_1_SOURCES = \ 94test_rps_malicious_1_SOURCES = $(rps_test_src)
91 test_rps.c
92test_rps_malicious_1_LDADD = $(ld_rps_test_lib) 95test_rps_malicious_1_LDADD = $(ld_rps_test_lib)
93 96
94test_rps_malicious_2_SOURCES = \ 97test_rps_malicious_2_SOURCES = $(rps_test_src)
95 test_rps.c
96test_rps_malicious_2_LDADD = $(ld_rps_test_lib) 98test_rps_malicious_2_LDADD = $(ld_rps_test_lib)
97 99
98test_rps_malicious_3_SOURCES = \ 100test_rps_malicious_3_SOURCES = $(rps_test_src)
99 test_rps.c
100test_rps_malicious_3_LDADD = $(ld_rps_test_lib) 101test_rps_malicious_3_LDADD = $(ld_rps_test_lib)
101 102
102test_rps_single_req_SOURCES = \ 103test_rps_single_req_SOURCES = $(rps_test_src)
103 test_rps.c
104test_rps_single_req_LDADD = $(ld_rps_test_lib) 104test_rps_single_req_LDADD = $(ld_rps_test_lib)
105 105
106test_rps_seed_request_SOURCES = \ 106test_rps_seed_request_SOURCES = $(rps_test_src)
107 test_rps.c
108test_rps_seed_request_LDADD = $(ld_rps_test_lib) 107test_rps_seed_request_LDADD = $(ld_rps_test_lib)
109 108
110gnunet_rps_profiler_SOURCES = \ 109gnunet_rps_profiler_SOURCES = $(rps_test_src)
111 test_rps.c
112gnunet_rps_profiler_LDADD = $(ld_rps_test_lib) 110gnunet_rps_profiler_LDADD = $(ld_rps_test_lib)
113 111
114EXTRA_DIST = \ 112EXTRA_DIST = \