aboutsummaryrefslogtreecommitdiff
path: root/src/scalarproduct/Makefile.am
diff options
context:
space:
mode:
authorChristian Fuchs <christian.fuchs@cfuchs.net>2013-10-18 23:13:19 +0000
committerChristian Fuchs <christian.fuchs@cfuchs.net>2013-10-18 23:13:19 +0000
commitee34e30d52f46b6a90578bd48172536392d2d5bf (patch)
tree2050c6befda04274c666d5ca5072150ee7e9b570 /src/scalarproduct/Makefile.am
parent36a80c833a5d5eb8f30460bb484cac01bdd9b65c (diff)
downloadgnunet-ee34e30d52f46b6a90578bd48172536392d2d5bf.tar.gz
gnunet-ee34e30d52f46b6a90578bd48172536392d2d5bf.zip
removed final non functional dead leftover code from gaurav... may that code be forgotten
testcases now do better logging together with make check made testcases a bit more tolerat for really slow systems (5 seconds should suffice even on older systems) activated new checks in Makefile
Diffstat (limited to 'src/scalarproduct/Makefile.am')
-rw-r--r--src/scalarproduct/Makefile.am51
1 files changed, 10 insertions, 41 deletions
diff --git a/src/scalarproduct/Makefile.am b/src/scalarproduct/Makefile.am
index c4c56a802..4bfdfcd7d 100644
--- a/src/scalarproduct/Makefile.am
+++ b/src/scalarproduct/Makefile.am
@@ -53,46 +53,15 @@ libgnunetscalarproduct_la_LIBADD = \
53libgnunetscalarproduct_la_LDFLAGS = \ 53libgnunetscalarproduct_la_LDFLAGS = \
54 $(GN_LIB_LDFLAGS) 54 $(GN_LIB_LDFLAGS)
55 55
56#check_PROGRAMS = \ 56EXTRA_DIST = \
57# test_scalarproduct_api_regression \ 57 test_scalarproduct.conf \
58# test_scalarproduct_api \ 58 $(check_SCRIPTS)
59# test_scalarproduct_api_4peers 59
60#FIXME unfinished 60check_SCRIPTS = \
61#test_scalarproduct_api_regression2 61 test_scalarproduct.sh \
62 62 test_scalarproduct_negative.sh \
63 test_scalarproduct_negativezero.sh
64
63if ENABLE_TEST_RUN 65if ENABLE_TEST_RUN
64 TESTS = $(check_PROGRAMS) 66 TESTS = $(check_SCRIPTS)
65endif 67endif
66
67test_scalarproduct_api_SOURCES = \
68 test_scalarproduct_api.c
69test_scalarproduct_api_LDADD = \
70 $(top_builddir)/src/util/libgnunetutil.la \
71 $(top_builddir)/src/scalarproduct/libgnunetscalarproduct.la \
72 -lgcrypt
73
74#FIXME unfinished
75#test_scalarproduct_api_regression2_SOURCES = \
76# test_scalarproduct_api_regression2.c
77#test_scalarproduct_api_regression2_LDADD = \
78# $(top_builddir)/src/scalarproduct/libgnunetscalarproduct.la \
79# $(top_builddir)/src/util/libgnunetutil.la \
80# -lgcrypt
81
82test_scalarproduct_api_regression_SOURCES = \
83 test_scalarproduct_api_regression.c
84test_scalarproduct_api_regression_LDADD = \
85 $(top_builddir)/src/util/libgnunetutil.la \
86 $(top_builddir)/src/scalarproduct/libgnunetscalarproduct.la \
87 -lgcrypt
88
89test_scalarproduct_api_4peers_SOURCES = \
90 test_scalarproduct_api_4peers.c
91test_scalarproduct_api_4peers_LDADD = \
92 $(top_builddir)/src/util/libgnunetutil.la \
93 $(top_builddir)/src/scalarproduct/libgnunetscalarproduct.la \
94 -lgcrypt
95
96EXTRA_DIST = \
97 test_scalarproduct.conf
98