aboutsummaryrefslogtreecommitdiff
path: root/src/scalarproduct/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-12-24 19:34:53 +0000
committerChristian Grothoff <christian@grothoff.org>2013-12-24 19:34:53 +0000
commitf1d741415d9af284955122c931118f2bca5ba2d0 (patch)
tree23b70808091aa1abaee37614b18647742b4de5c1 /src/scalarproduct/Makefile.am
parentd26b19c91736433a783ce22b2d95ed490b6d9ca6 (diff)
downloadgnunet-f1d741415d9af284955122c931118f2bca5ba2d0.tar.gz
gnunet-f1d741415d9af284955122c931118f2bca5ba2d0.zip
-make sure to link against right libgcrypt, enable abort of gnunet-revocation even if identity service is not running
Diffstat (limited to 'src/scalarproduct/Makefile.am')
-rw-r--r--src/scalarproduct/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/scalarproduct/Makefile.am b/src/scalarproduct/Makefile.am
index 11a937378..0bdc76e3e 100644
--- a/src/scalarproduct/Makefile.am
+++ b/src/scalarproduct/Makefile.am
@@ -29,6 +29,7 @@ gnunet_scalarproduct_SOURCES = \
29gnunet_scalarproduct_LDADD = \ 29gnunet_scalarproduct_LDADD = \
30 $(top_builddir)/src/util/libgnunetutil.la \ 30 $(top_builddir)/src/util/libgnunetutil.la \
31 $(top_builddir)/src/scalarproduct/libgnunetscalarproduct.la \ 31 $(top_builddir)/src/scalarproduct/libgnunetscalarproduct.la \
32 $(LIBGCRYPT_LIBS) \
32 -lgcrypt \ 33 -lgcrypt \
33 $(GN_LIBINTL) 34 $(GN_LIBINTL)
34gnunet_scalarproduct_DEPENDENCIES = \ 35gnunet_scalarproduct_DEPENDENCIES = \
@@ -40,6 +41,7 @@ gnunet_service_scalarproduct_LDADD = \
40 $(top_builddir)/src/util/libgnunetutil.la \ 41 $(top_builddir)/src/util/libgnunetutil.la \
41 $(top_builddir)/src/mesh/libgnunetmesh.la \ 42 $(top_builddir)/src/mesh/libgnunetmesh.la \
42 $(top_builddir)/src/set/libgnunetset.la \ 43 $(top_builddir)/src/set/libgnunetset.la \
44 $(LIBGCRYPT_LIBS) \
43 -lgcrypt \ 45 -lgcrypt \
44 $(GN_LIBINTL) 46 $(GN_LIBINTL)
45 47
@@ -49,6 +51,7 @@ libgnunetscalarproduct_la_SOURCES = \
49libgnunetscalarproduct_la_LIBADD = \ 51libgnunetscalarproduct_la_LIBADD = \
50 $(top_builddir)/src/util/libgnunetutil.la \ 52 $(top_builddir)/src/util/libgnunetutil.la \
51 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 53 $(top_builddir)/src/statistics/libgnunetstatistics.la \
54 $(LIBGCRYPT_LIBS) \
52 -lgcrypt \ 55 -lgcrypt \
53 $(LTLIBINTL) 56 $(LTLIBINTL)
54libgnunetscalarproduct_la_LDFLAGS = \ 57libgnunetscalarproduct_la_LDFLAGS = \