aboutsummaryrefslogtreecommitdiff
path: root/src/social/Makefile.am
diff options
context:
space:
mode:
authorGabor X Toth <*@tg-x.net>2014-05-27 11:10:35 +0000
committerGabor X Toth <*@tg-x.net>2014-05-27 11:10:35 +0000
commitcfeccc1b56def35ac586ac2c09ac70b523b59ef5 (patch)
treee0cb2abc1ce4c11514c29eb5c0c067443b3a6fbd /src/social/Makefile.am
parent10f2f102658f935148475d5aa2b29afd8a4e85c2 (diff)
downloadgnunet-cfeccc1b56def35ac586ac2c09ac70b523b59ef5.tar.gz
gnunet-cfeccc1b56def35ac586ac2c09ac70b523b59ef5.zip
add social service
Diffstat (limited to 'src/social/Makefile.am')
-rw-r--r--src/social/Makefile.am78
1 files changed, 78 insertions, 0 deletions
diff --git a/src/social/Makefile.am b/src/social/Makefile.am
new file mode 100644
index 000000000..04184dbc6
--- /dev/null
+++ b/src/social/Makefile.am
@@ -0,0 +1,78 @@
1AM_CPPFLAGS = -I$(top_srcdir)/src/include
2
3pkgcfgdir= $(pkgdatadir)/config.d/
4
5libexecdir= $(pkglibdir)/libexec/
6
7pkgcfg_DATA = \
8 social.conf
9
10
11if MINGW
12 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
13endif
14
15if USE_COVERAGE
16 AM_CFLAGS = --coverage -O0
17 XLIB = -lgcov
18endif
19
20lib_LTLIBRARIES = libgnunetsocial.la
21
22libgnunetsocial_la_SOURCES = \
23 social_api.c social.h
24libgnunetsocial_la_LIBADD = \
25 $(top_builddir)/src/util/libgnunetutil.la \
26 $(top_builddir)/src/env/libgnunetenv.la \
27 $(GN_LIBINTL) $(XLIB)
28libgnunetsocial_la_LDFLAGS = \
29 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
30 -version-info 0:0:0
31libgnunetsocial_la_DEPENDENCIES = \
32 $(top_builddir)/src/util/libgnunetutil.la \
33 $(top_builddir)/src/env/libgnunetenv.la
34
35bin_PROGRAMS =
36
37libexec_PROGRAMS = \
38 gnunet-service-social
39
40gnunet_service_social_SOURCES = \
41 gnunet-service-social.c
42gnunet_service_social_LDADD = \
43 $(top_builddir)/src/util/libgnunetutil.la \
44 $(top_builddir)/src/statistics/libgnunetstatistics.la \
45 $(top_builddir)/src/psyc/libgnunetpsyc.la \
46 $(GN_LIBINTL)
47gnunet_service_social_DEPENDENCIES = \
48 $(top_builddir)/src/util/libgnunetutil.la \
49 $(top_builddir)/src/statistics/libgnunetstatistics.la \
50 $(top_builddir)/src/psyc/libgnunetpsyc.la
51gnunet_service_social_CFLAGS = $(AM_CFLAGS)
52
53
54if HAVE_TESTING
55check_PROGRAMS = \
56 test_social
57endif
58
59if ENABLE_TEST_RUN
60AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;
61TESTS = $(check_PROGRAMS)
62endif
63
64test_social_SOURCES = \
65 test_social.c
66test_social_LDADD = \
67 libgnunetsocial.la \
68 $(top_builddir)/src/testing/libgnunettesting.la \
69 $(top_builddir)/src/env/libgnunetenv.la \
70 $(top_builddir)/src/util/libgnunetutil.la
71test_social_DEPENDENCIES = \
72 libgnunetsocial.la \
73 $(top_builddir)/src/testing/libgnunettesting.la \
74 $(top_builddir)/src/env/libgnunetenv.la \
75 $(top_builddir)/src/util/libgnunetutil.la
76
77EXTRA_DIST = \
78 test_social.conf