aboutsummaryrefslogtreecommitdiff
path: root/src/testing/Makefile.am
diff options
context:
space:
mode:
authorBart Polot <bart@net.in.tum.de>2011-11-05 01:56:35 +0000
committerBart Polot <bart@net.in.tum.de>2011-11-05 01:56:35 +0000
commit23ea0db15ba89a9603c9f2a433635f0edbb92e54 (patch)
treeda112b9cbf73566a838df0c6c907dcb4ba8947ff /src/testing/Makefile.am
parent13dd29b19c5d0d30901444a358f3331a76b3da5c (diff)
downloadgnunet-23ea0db15ba89a9603c9f2a433635f0edbb92e54.tar.gz
gnunet-23ea0db15ba89a9603c9f2a433635f0edbb92e54.zip
Added testcase for 2dtorus scenario from dht and mesh
Diffstat (limited to 'src/testing/Makefile.am')
-rw-r--r--src/testing/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/testing/Makefile.am b/src/testing/Makefile.am
index 88102e112..008692fbd 100644
--- a/src/testing/Makefile.am
+++ b/src/testing/Makefile.am
@@ -62,6 +62,7 @@ check_PROGRAMS = \
62 test_testing_topology_line \ 62 test_testing_topology_line \
63 test_testing_topology_blacklist \ 63 test_testing_topology_blacklist \
64 test_testing_group_remote \ 64 test_testing_group_remote \
65 test_testing_2dtorus \
65 test_testing_topology_ring \ 66 test_testing_topology_ring \
66 test_testing_topology_2d_torus \ 67 test_testing_topology_2d_torus \
67 test_testing_topology_small_world_ring \ 68 test_testing_topology_small_world_ring \
@@ -78,7 +79,8 @@ TESTS = \
78 test_testing_reconnect \ 79 test_testing_reconnect \
79 test_testing_group \ 80 test_testing_group \
80 test_testing_peergroup \ 81 test_testing_peergroup \
81 test_testing_topology_clique 82 test_testing_topology_clique \
83 test_testing_2dtorus
82endif 84endif
83 85
84test_testing_SOURCES = \ 86test_testing_SOURCES = \
@@ -172,6 +174,12 @@ test_testing_group_remote_LDADD = \
172 $(top_builddir)/src/testing/libgnunettesting.la \ 174 $(top_builddir)/src/testing/libgnunettesting.la \
173 $(top_builddir)/src/util/libgnunetutil.la 175 $(top_builddir)/src/util/libgnunetutil.la
174 176
177test_testing_2dtorus_SOURCES = \
178 test_testing_2dtorus.c
179test_testing_2dtorus_LDADD = \
180 $(top_builddir)/src/testing/libgnunettesting.la \
181 $(top_builddir)/src/util/libgnunetutil.la
182
175test_testing_topology_ring_SOURCES = \ 183test_testing_topology_ring_SOURCES = \
176 test_testing_topology.c 184 test_testing_topology.c
177test_testing_topology_ring_LDADD = \ 185test_testing_topology_ring_LDADD = \
@@ -234,6 +242,7 @@ EXTRA_DIST = \
234 test_testing_data.conf \ 242 test_testing_data.conf \
235 test_testing_connect_peer1.conf \ 243 test_testing_connect_peer1.conf \
236 test_testing_connect_peer2.conf \ 244 test_testing_connect_peer2.conf \
245 test_testing_2dtorus.conf \
237 test_testing_data_topology_clique.conf \ 246 test_testing_data_topology_clique.conf \
238 test_testing_data_topology_clique_random.conf \ 247 test_testing_data_topology_clique_random.conf \
239 test_testing_data_topology_clique_minimum.conf \ 248 test_testing_data_topology_clique_minimum.conf \