aboutsummaryrefslogtreecommitdiff
path: root/src/testing/Makefile.am
diff options
context:
space:
mode:
authorNathan S. Evans <evans@in.tum.de>2011-07-08 17:12:05 +0000
committerNathan S. Evans <evans@in.tum.de>2011-07-08 17:12:05 +0000
commit4608cc37d729cff2cdd998053d3e75fda73d892a (patch)
tree75033edef3c1fa1389ed4a7ce0ca2625ef1b8901 /src/testing/Makefile.am
parente60aaddfc196474cc0df128dc88645413a9d1e34 (diff)
downloadgnunet-4608cc37d729cff2cdd998053d3e75fda73d892a.tar.gz
gnunet-4608cc37d729cff2cdd998053d3e75fda73d892a.zip
expensive tests flag
Diffstat (limited to 'src/testing/Makefile.am')
-rw-r--r--src/testing/Makefile.am34
1 files changed, 19 insertions, 15 deletions
diff --git a/src/testing/Makefile.am b/src/testing/Makefile.am
index 2b1778876..878cffa27 100644
--- a/src/testing/Makefile.am
+++ b/src/testing/Makefile.am
@@ -9,6 +9,25 @@ if USE_COVERAGE
9 XLIB = -lgcov 9 XLIB = -lgcov
10endif 10endif
11 11
12if HAVE_EXPENSIVE_TESTS
13 EXPENSIVE_TESTS = \
14 test_testing_topology_stability \
15 test_testing_topology_clique_random \
16 test_testing_topology_clique_minimum \
17 test_testing_topology_clique_dfs \
18 test_testing_topology_churn \
19 test_testing_topology_line
20 test_testing_topology_blacklist \
21 test_testing_group_remote \
22 test_testing_topology_ring \
23 test_testing_topology_2d_torus \
24 test_testing_topology_small_world_ring \
25 test_testing_topology_small_world_torus \
26 test_testing_topology_erdos_renyi \
27 test_testing_topology_internat \
28 test_testing_topology_scale_free
29endif
30
12lib_LTLIBRARIES = libgnunettesting.la 31lib_LTLIBRARIES = libgnunettesting.la
13 32
14libgnunettesting_la_SOURCES = \ 33libgnunettesting_la_SOURCES = \
@@ -55,21 +74,6 @@ TESTS = \
55 test_testing_group \ 74 test_testing_group \
56 test_testing_peergroup \ 75 test_testing_peergroup \
57 test_testing_topology_clique 76 test_testing_topology_clique
58# test_testing_topology_stability \
59# test_testing_topology_clique_random \
60# test_testing_topology_clique_minimum \
61# test_testing_topology_clique_dfs \
62# test_testing_topology_churn \
63# test_testing_topology_line
64# test_testing_topology_blacklist \
65# test_testing_group_remote \
66# test_testing_topology_ring \
67# test_testing_topology_2d_torus \
68# test_testing_topology_small_world_ring \
69# test_testing_topology_small_world_torus \
70# test_testing_topology_erdos_renyi \
71# test_testing_topology_internat \
72# test_testing_topology_scale_free
73endif 77endif
74 78
75test_testing_SOURCES = \ 79test_testing_SOURCES = \