aboutsummaryrefslogtreecommitdiff
path: root/src/testing/Makefile.am
diff options
context:
space:
mode:
authorNathan S. Evans <evans@in.tum.de>2010-06-28 16:41:11 +0000
committerNathan S. Evans <evans@in.tum.de>2010-06-28 16:41:11 +0000
commit9748ddd31e98f2775851c8b24a735ba67d31e87a (patch)
treefdff70d7a8c35f227b403e80aeee5290054b1591 /src/testing/Makefile.am
parentceae03698d503c88e96d18984e11079cb95a2184 (diff)
downloadgnunet-9748ddd31e98f2775851c8b24a735ba67d31e87a.tar.gz
gnunet-9748ddd31e98f2775851c8b24a735ba67d31e87a.zip
add test case for NO topology restrictions, connect in ring. good for maximum number of peers testing
Diffstat (limited to 'src/testing/Makefile.am')
-rw-r--r--src/testing/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/testing/Makefile.am b/src/testing/Makefile.am
index 163b4f9c9..3f68411f5 100644
--- a/src/testing/Makefile.am
+++ b/src/testing/Makefile.am
@@ -38,6 +38,7 @@ check_PROGRAMS = \
38 test_testing_topology_small_world_torus \ 38 test_testing_topology_small_world_torus \
39 test_testing_topology_erdos_renyi \ 39 test_testing_topology_erdos_renyi \
40 test_testing_topology_internat \ 40 test_testing_topology_internat \
41 test_testing_topology_none \
41 test_testing_topology_scale_free 42 test_testing_topology_scale_free
42 43
43TESTS = \ 44TESTS = \
@@ -168,6 +169,12 @@ test_testing_topology_scale_free_SOURCES = \
168test_testing_topology_scale_free_LDADD = \ 169test_testing_topology_scale_free_LDADD = \
169 $(top_builddir)/src/testing/libgnunettesting.la \ 170 $(top_builddir)/src/testing/libgnunettesting.la \
170 $(top_builddir)/src/util/libgnunetutil.la 171 $(top_builddir)/src/util/libgnunetutil.la
172
173test_testing_topology_none_SOURCES = \
174 test_testing_topology.c
175test_testing_topology_none_LDADD = \
176 $(top_builddir)/src/testing/libgnunettesting.la \
177 $(top_builddir)/src/util/libgnunetutil.la
171 178
172 179
173EXTRA_DIST = \ 180EXTRA_DIST = \