aboutsummaryrefslogtreecommitdiff
path: root/src/testing/Makefile.am
diff options
context:
space:
mode:
authorNathan S. Evans <evans@in.tum.de>2011-04-06 09:40:36 +0000
committerNathan S. Evans <evans@in.tum.de>2011-04-06 09:40:36 +0000
commitb24caf06a3d147b2362c210c4e7385b83c9f582b (patch)
tree29306a4e3ede82b3b68935773a769ca217232316 /src/testing/Makefile.am
parent626665da9b8b1861a1e09ca91e599ec44f915c9c (diff)
downloadgnunet-b24caf06a3d147b2362c210c4e7385b83c9f582b.tar.gz
gnunet-b24caf06a3d147b2362c210c4e7385b83c9f582b.zip
peergroup initial version with test case
Diffstat (limited to 'src/testing/Makefile.am')
-rw-r--r--src/testing/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/testing/Makefile.am b/src/testing/Makefile.am
index 1d7806a2a..fb78fbeb8 100644
--- a/src/testing/Makefile.am
+++ b/src/testing/Makefile.am
@@ -27,6 +27,7 @@ check_PROGRAMS = \
27 test_testing_connect \ 27 test_testing_connect \
28 test_testing_reconnect \ 28 test_testing_reconnect \
29 test_testing_group \ 29 test_testing_group \
30 test_testing_peergroup \
30 test_testing_topology_stability \ 31 test_testing_topology_stability \
31 test_testing_topology_clique \ 32 test_testing_topology_clique \
32 test_testing_topology_clique_random \ 33 test_testing_topology_clique_random \
@@ -51,6 +52,7 @@ TESTS = \
51 test_testing_connect \ 52 test_testing_connect \
52 test_testing_reconnect \ 53 test_testing_reconnect \
53 test_testing_group \ 54 test_testing_group \
55 test_testing_peergroup \
54 test_testing_topology_clique 56 test_testing_topology_clique
55# test_testing_topology_stability \ 57# test_testing_topology_stability \
56# test_testing_topology_clique_random \ 58# test_testing_topology_clique_random \
@@ -92,6 +94,12 @@ test_testing_group_SOURCES = \
92test_testing_group_LDADD = \ 94test_testing_group_LDADD = \
93 $(top_builddir)/src/testing/libgnunettesting.la \ 95 $(top_builddir)/src/testing/libgnunettesting.la \
94 $(top_builddir)/src/util/libgnunetutil.la 96 $(top_builddir)/src/util/libgnunetutil.la
97
98test_testing_peergroup_SOURCES = \
99 test_testing_peergroup.c
100test_testing_peergroup_LDADD = \
101 $(top_builddir)/src/testing/libgnunettesting.la \
102 $(top_builddir)/src/util/libgnunetutil.la
95 103
96test_testing_topology_clique_SOURCES = \ 104test_testing_topology_clique_SOURCES = \
97 test_testing_topology.c 105 test_testing_topology.c