aboutsummaryrefslogtreecommitdiff
path: root/src/testing/Makefile.am
diff options
context:
space:
mode:
authort3sserakt <t3ss@posteo.de>2021-03-04 10:41:01 +0100
committert3sserakt <t3ss@posteo.de>2021-03-04 10:42:39 +0100
commite5d31aa52e4983bffce3eca6ca601bbb8f4a302a (patch)
tree1878b4c6595b4b3d402988c1df772adf48908622 /src/testing/Makefile.am
parent46111957db87028c369ea4792b9c533a9dd09a33 (diff)
downloadgnunet-e5d31aa52e4983bffce3eca6ca601bbb8f4a302a.tar.gz
gnunet-e5d31aa52e4983bffce3eca6ca601bbb8f4a302a.zip
- first try to integrate GNU Taler command style testing
Diffstat (limited to 'src/testing/Makefile.am')
-rw-r--r--src/testing/Makefile.am25
1 files changed, 24 insertions, 1 deletions
diff --git a/src/testing/Makefile.am b/src/testing/Makefile.am
index 2b599f55b..f7aa1f896 100644
--- a/src/testing/Makefile.am
+++ b/src/testing/Makefile.am
@@ -15,7 +15,14 @@ lib_LTLIBRARIES = \
15 libgnunettesting.la 15 libgnunettesting.la
16 16
17libgnunettesting_la_SOURCES = \ 17libgnunettesting_la_SOURCES = \
18 testing.c 18 testing.c \
19 testing_api_cmd_batch.c \
20 testing_api_cmd_hello_world.c \
21 testing_api_cmd_hello_world_birth.c \
22 testing_api_loop.c \
23 testing_api_trait_cmd.c \
24 testing_api_trait_process.c \
25 testing_api_traits.c
19libgnunettesting_la_LIBADD = \ 26libgnunettesting_la_LIBADD = \
20 $(top_builddir)/src/arm/libgnunetarm.la \ 27 $(top_builddir)/src/arm/libgnunetarm.la \
21 $(top_builddir)/src/util/libgnunetutil.la \ 28 $(top_builddir)/src/util/libgnunetutil.la \
@@ -48,8 +55,10 @@ list_keys_LDADD = \
48 55
49 56
50check_PROGRAMS = \ 57check_PROGRAMS = \
58 test_testing_hello_world \
51 test_testing_portreservation \ 59 test_testing_portreservation \
52 test_testing_servicestartup \ 60 test_testing_servicestartup \
61 test_testing_ng_peerstartup \
53 test_testing_peerstartup \ 62 test_testing_peerstartup \
54 test_testing_peerstartup2 \ 63 test_testing_peerstartup2 \
55 test_testing_sharedservices 64 test_testing_sharedservices
@@ -57,18 +66,32 @@ check_PROGRAMS = \
57if ENABLE_TEST_RUN 66if ENABLE_TEST_RUN
58AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; 67AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
59TESTS = \ 68TESTS = \
69 test_testing_hello_world \
60 test_testing_portreservation \ 70 test_testing_portreservation \
71 test_testing_ng_peerstartup \
61 test_testing_peerstartup \ 72 test_testing_peerstartup \
62 test_testing_peerstartup2 \ 73 test_testing_peerstartup2 \
63 test_testing_servicestartup 74 test_testing_servicestartup
64endif 75endif
65 76
77test_testing_helloworld_SOURCES = \
78 test_testing_hello_world
79test_testing_portreservation_LDADD = \
80 libgnunettesting.la \
81 $(top_builddir)/src/util/libgnunetutil.la
82
66test_testing_portreservation_SOURCES = \ 83test_testing_portreservation_SOURCES = \
67 test_testing_portreservation.c 84 test_testing_portreservation.c
68test_testing_portreservation_LDADD = \ 85test_testing_portreservation_LDADD = \
69 libgnunettesting.la \ 86 libgnunettesting.la \
70 $(top_builddir)/src/util/libgnunetutil.la 87 $(top_builddir)/src/util/libgnunetutil.la
71 88
89test_testing_ng_peerstartup_SOURCES = \
90 test_testing_ng_peerstartup.c
91test_testing_ng_peerstartup_LDADD = \
92 libgnunettesting.la \
93 $(top_builddir)/src/util/libgnunetutil.la
94
72test_testing_peerstartup_SOURCES = \ 95test_testing_peerstartup_SOURCES = \
73 test_testing_peerstartup.c 96 test_testing_peerstartup.c
74test_testing_peerstartup_LDADD = \ 97test_testing_peerstartup_LDADD = \