aboutsummaryrefslogtreecommitdiff
path: root/src/testing/Makefile.am
diff options
context:
space:
mode:
authort3sserakt <t3ss@posteo.de>2021-08-17 19:57:12 +0200
committert3sserakt <t3ss@posteo.de>2021-08-17 19:57:12 +0200
commit32a8c505c1fa27bb43c4e7c8d288566d51417f56 (patch)
tree0328fe50b6a099b5020fe6d1e01cbd6b96ecd18a /src/testing/Makefile.am
parent1e063cd73452396778cf00127346b9b08a922317 (diff)
downloadgnunet-32a8c505c1fa27bb43c4e7c8d288566d51417f56.tar.gz
gnunet-32a8c505c1fa27bb43c4e7c8d288566d51417f56.zip
- moved test code from testbed to testing
Diffstat (limited to 'src/testing/Makefile.am')
-rw-r--r--src/testing/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/src/testing/Makefile.am b/src/testing/Makefile.am
index 8b28e6e23..15469a310 100644
--- a/src/testing/Makefile.am
+++ b/src/testing/Makefile.am
@@ -11,10 +11,43 @@ pkgcfgdir= $(pkgdatadir)/config.d/
11dist_pkgcfg_DATA = \ 11dist_pkgcfg_DATA = \
12 testing.conf 12 testing.conf
13 13
14libexec_PROGRAMS = \
15 gnunet-cmds-helper
16
17plugindir = $(libdir)/gnunet
18
19plugin_LTLIBRARIES = \
20 libgnunet_test_testing_plugin_testcmd.la
21
14lib_LTLIBRARIES = \ 22lib_LTLIBRARIES = \
15 libgnunettesting.la 23 libgnunettesting.la
16 24
25gnunet_cmds_helper_SOURCES = \
26 gnunet-cmds-helper.c
27gnunet_cmds_helper_LDADD = $(XLIB) \
28 $(top_builddir)/src/util/libgnunetutil.la \
29 libgnunettesting.la \
30 $(LTLIBINTL) $(Z_LIBS)
31
32libgnunet_test_testing_plugin_testcmd_la_SOURCES = \
33 test_testing_plugin_testcmd.c
34libgnunet_test_testing_plugin_testcmd_la_LIBADD = \
35 $(top_builddir)/src/util/libgnunetutil.la \
36 $(top_builddir)/src/arm/libgnunetarm.la \
37 libgnunettesting.la \
38 $(top_builddir)/src/statistics/libgnunetstatistics.la \
39 $(LTLIBINTL)
40libgnunet_test_testing_plugin_testcmd_la_LDFLAGS = \
41 $(GN_PLUGIN_LDFLAGS)
42
17libgnunettesting_la_SOURCES = \ 43libgnunettesting_la_SOURCES = \
44 testing_api_cmd_local_test_finished.c \
45 testing_api_cmd_send_peer_ready.c \
46 testing_api_cmd_block_until_all_peers_started.c \
47 testing_api_cmd_netjail_start.c \
48 testing_api_cmd_netjail_start_testsystem.c \
49 testing_api_cmd_netjail_stop_testsystem.c \
50 testing_api_cmd_netjail_stop.c \
18 testing.c testing.h \ 51 testing.c testing.h \
19 testing_api_cmd_system_create.c \ 52 testing_api_cmd_system_create.c \
20 testing_api_cmd_batch.c \ 53 testing_api_cmd_batch.c \
@@ -56,6 +89,7 @@ list_keys_LDADD = \
56 89
57 90
58check_PROGRAMS = \ 91check_PROGRAMS = \
92 test_testing_api_cmd_netjail \
59 test_testing_hello_world \ 93 test_testing_hello_world \
60 test_testing_portreservation \ 94 test_testing_portreservation \
61 test_testing_servicestartup \ 95 test_testing_servicestartup \
@@ -66,6 +100,7 @@ check_PROGRAMS = \
66if ENABLE_TEST_RUN 100if ENABLE_TEST_RUN
67AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; 101AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
68TESTS = \ 102TESTS = \
103 test_testing_api_cmd_netjail \
69 test_testing_hello_world \ 104 test_testing_hello_world \
70 test_testing_portreservation \ 105 test_testing_portreservation \
71 test_testing_peerstartup \ 106 test_testing_peerstartup \
@@ -73,6 +108,12 @@ TESTS = \
73 test_testing_servicestartup 108 test_testing_servicestartup
74endif 109endif
75 110
111test_testing_api_cmd_netjail_SOURCES = \
112 test_testing_api_cmd_netjail.c
113test_testing_api_cmd_netjail_LDADD = \
114 libgnunettesting.la \
115 $(top_builddir)/src/util/libgnunetutil.la
116
76test_testing_hello_world_SOURCES = \ 117test_testing_hello_world_SOURCES = \
77 test_testing_hello_world.c 118 test_testing_hello_world.c
78test_testing_hello_world_LDADD = \ 119test_testing_hello_world_LDADD = \