aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-12-01 11:49:59 +0000
committerng0 <ng0@n0.is>2019-12-01 11:49:59 +0000
commit79ff68acae7e4774881d6bc53fc5c639da4a2e7b (patch)
treed4de2dfe836accb82ba0f838803035589469b7ea /src/transport/Makefile.am
parent435596a7cb2e5b9adbb8de90f3f917a61d089a1b (diff)
downloadgnunet-79ff68acae7e4774881d6bc53fc5c639da4a2e7b.tar.gz
gnunet-79ff68acae7e4774881d6bc53fc5c639da4a2e7b.zip
transport: initial commit for bluetooth and wlan in netbsd.
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index e77220d50..bbf51058e 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -92,6 +92,19 @@ if LINUX
92 WLAN_QUOTA_TEST = test_quota_compliance_wlan \ 92 WLAN_QUOTA_TEST = test_quota_compliance_wlan \
93 test_quota_compliance_wlan_asymmetric 93 test_quota_compliance_wlan_asymmetric
94endif 94endif
95if XBSD
96 WLAN_BIN = gnunet-helper-transport-wlan
97 WLAN_BIN_DUMMY = gnunet-helper-transport-wlan-dummy
98 WLAN_BIN_SENDER = gnunet-transport-wlan-sender
99 WLAN_BIN_RECEIVER = gnunet-transport-wlan-receiver
100 WLAN_PLUGIN_LA = libgnunet_plugin_transport_wlan.la
101 WLAN_PLUGIN_TEST = test_plugin_wlan
102 WLAN_API_TEST = test_transport_api_wlan
103 WLAN_TIMEOUT_TEST = test_transport_api_timeout_wlan
104 WLAN_REL_TEST = test_transport_api_reliability_wlan
105 WLAN_QUOTA_TEST = test_quota_compliance_wlan \
106 test_quota_compliance_wlan_asymmetric
107endif
95 108
96if LINUX 109if LINUX
97if HAVE_LIBBLUETOOTH 110if HAVE_LIBBLUETOOTH
@@ -105,6 +118,18 @@ if HAVE_LIBBLUETOOTH
105 test_quota_compliance_bluetooth_asymmetric 118 test_quota_compliance_bluetooth_asymmetric
106endif 119endif
107endif 120endif
121if XBSD
122if HAVE_LIBBLUETOOTH
123 BT_BIN = gnunet-helper-transport-bluetooth
124 BT_PLUGIN_LA = libgnunet_plugin_transport_bluetooth.la
125 BT_PLUGIN_TEST = test_plugin_bluetooth
126 BT_API_TEST = test_transport_api_bluetooth
127 BT_TIMEOUT_TEST = test_transport_api_timeout_bluetooth
128 BT_REL_TEST = test_transport_api_reliability_bluetooth
129 BT_QUOTA_TEST = test_quota_compliance_bluetooth \
130 test_quota_compliance_bluetooth_asymmetric
131endif
132endif
108 133
109# end of HAVE_EXPERIMENTAL 134# end of HAVE_EXPERIMENTAL
110endif 135endif