aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorSchanzenbach, Martin <mschanzenbach@posteo.de>2019-12-31 14:39:56 +0900
committerSchanzenbach, Martin <mschanzenbach@posteo.de>2019-12-31 14:39:56 +0900
commit65b645e3c3910401d43d922d46096aa22c6de9e7 (patch)
tree1661af3f33c2087dd46937ed8d1d5219c7e082fe /src/transport/Makefile.am
parent658ba3f2b74a7b5e4ec92211cded45cdf6af8105 (diff)
downloadgnunet-65b645e3c3910401d43d922d46096aa22c6de9e7.tar.gz
gnunet-65b645e3c3910401d43d922d46096aa22c6de9e7.zip
add backchannel test; fix udp basic
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am23
1 files changed, 21 insertions, 2 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 7dbff2d44..c37a34ab7 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -599,7 +599,9 @@ check_PROGRAMS += \
599 test_communicator_basic-unix \ 599 test_communicator_basic-unix \
600 test_communicator_basic-tcp \ 600 test_communicator_basic-tcp \
601 test_communicator_basic-udp \ 601 test_communicator_basic-udp \
602 test_communicator_rekey-tcp 602 test_communicator_rekey-tcp \
603 test_communicator_rekey-udp \
604 test_communicator_backchannel-udp
603endif 605endif
604endif 606endif
605 607
@@ -813,6 +815,19 @@ test_communicator_rekey_tcp_LDADD = \
813 $(top_builddir)/src/testing/libgnunettesting.la \ 815 $(top_builddir)/src/testing/libgnunettesting.la \
814 $(top_builddir)/src/util/libgnunetutil.la 816 $(top_builddir)/src/util/libgnunetutil.la
815 817
818test_communicator_rekey_udp_SOURCES = \
819 test_communicator_basic.c
820test_communicator_rekey_udp_LDADD = \
821 libgnunettransporttesting2.la \
822 $(top_builddir)/src/testing/libgnunettesting.la \
823 $(top_builddir)/src/util/libgnunetutil.la
824
825test_communicator_backchannel_udp_SOURCES = \
826 test_communicator_basic.c
827test_communicator_backchannel_udp_LDADD = \
828 libgnunettransporttesting2.la \
829 $(top_builddir)/src/testing/libgnunettesting.la \
830 $(top_builddir)/src/util/libgnunetutil.la
816endif 831endif
817 832
818test_plugin_unix_SOURCES = \ 833test_plugin_unix_SOURCES = \
@@ -1519,4 +1534,8 @@ test_communicator_basic_tcp_peer2.conf \
1519test_communicator_basic_udp_peer1.conf \ 1534test_communicator_basic_udp_peer1.conf \
1520test_communicator_basic_udp_peer2.conf \ 1535test_communicator_basic_udp_peer2.conf \
1521test_communicator_rekey_tcp_peer1.conf \ 1536test_communicator_rekey_tcp_peer1.conf \
1522test_communicator_rekey_tcp_peer2.conf 1537test_communicator_rekey_tcp_peer2.conf \
1538test_communicator_rekey_udp_peer1.conf \
1539test_communicator_rekey_udp_peer2.conf \
1540test_communicator_backchannel_udp_peer1.conf \
1541test_communicator_backchannel_udp_peer2.conf