aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorJulius Bünger <buenger@mytum.de>2019-04-18 01:08:54 +0200
committerJulius Bünger <buenger@mytum.de>2019-04-18 01:09:53 +0200
commit689458cd3f23833a8c26b2bb8161be773b5075e4 (patch)
treee4100c449c69614bca5ef3e2423579c54df9df51 /src/transport/Makefile.am
parent89ab4a8ab5c8bcff2c5744b28499c468229ce119 (diff)
downloadgnunet-689458cd3f23833a8c26b2bb8161be773b5075e4.tar.gz
gnunet-689458cd3f23833a8c26b2bb8161be773b5075e4.zip
TNG: Add first steps for communicator testing
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am27
1 files changed, 22 insertions, 5 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 53fd9c973..c9b23b6c4 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -141,7 +141,6 @@ endif
141 141
142noinst_PROGRAMS = \ 142noinst_PROGRAMS = \
143 gnunet-transport-profiler \ 143 gnunet-transport-profiler \
144 gnunet-communicator-unix \
145 gnunet-communicator-tcp \ 144 gnunet-communicator-tcp \
146 gnunet-communicator-udp \ 145 gnunet-communicator-udp \
147 gnunet-service-tng \ 146 gnunet-service-tng \
@@ -149,7 +148,8 @@ noinst_PROGRAMS = \
149 $(WLAN_BIN_RECEIVER) 148 $(WLAN_BIN_RECEIVER)
150 149
151if HAVE_TESTING 150if HAVE_TESTING
152TESTING_LIBS = libgnunettransporttesting.la 151TESTING_LIBS = libgnunettransporttesting.la \
152 libgnunettransporttesting2.la
153endif 153endif
154 154
155lib_LTLIBRARIES = \ 155lib_LTLIBRARIES = \
@@ -177,6 +177,14 @@ libgnunettransporttesting_la_LIBADD = \
177libgnunettransporttesting_la_LDFLAGS = \ 177libgnunettransporttesting_la_LDFLAGS = \
178 $(GN_LIB_LDFLAGS) 178 $(GN_LIB_LDFLAGS)
179 179
180libgnunettransporttesting2_la_SOURCES = \
181 transport-testing2.c transport-testing2.h
182libgnunettransporttesting2_la_LIBADD = \
183 libgnunettransport.la \
184 $(top_builddir)/src/util/libgnunetutil.la
185libgnunettransporttesting2_la_LDFLAGS = \
186 $(GN_LIB_LDFLAGS)
187
180libgnunettransport_la_SOURCES = \ 188libgnunettransport_la_SOURCES = \
181 transport.h \ 189 transport.h \
182 transport_api_address_to_string.c \ 190 transport_api_address_to_string.c \
@@ -249,7 +257,8 @@ libexec_PROGRAMS = \
249 $(WLAN_BIN) \ 257 $(WLAN_BIN) \
250 $(WLAN_BIN_DUMMY) \ 258 $(WLAN_BIN_DUMMY) \
251 $(BT_BIN) \ 259 $(BT_BIN) \
252 gnunet-service-transport 260 gnunet-service-transport \
261 gnunet-communicator-unix
253 262
254 263
255 264
@@ -595,7 +604,8 @@ check_PROGRAMS = \
595 $(HTTP_QUOTA_TEST) \ 604 $(HTTP_QUOTA_TEST) \
596 $(HTTPS_QUOTA_TEST) \ 605 $(HTTPS_QUOTA_TEST) \
597 $(WLAN_QUOTA_TEST) \ 606 $(WLAN_QUOTA_TEST) \
598 $(BT_QUOTA_TEST) 607 $(BT_QUOTA_TEST) \
608 test_communicator_unix
599if HAVE_GETOPT_BINARY 609if HAVE_GETOPT_BINARY
600check_PROGRAMS += \ 610check_PROGRAMS += \
601test_transport_api_slow_ats 611test_transport_api_slow_ats
@@ -664,7 +674,8 @@ TESTS = \
664 $(HTTP_API_TIMEOUT_TEST) \ 674 $(HTTP_API_TIMEOUT_TEST) \
665 $(HTTPS_API_TIMEOUT_TEST) \ 675 $(HTTPS_API_TIMEOUT_TEST) \
666 $(WLAN_TIMEOUT_TEST) \ 676 $(WLAN_TIMEOUT_TEST) \
667 $(BT_TIMEOUT_TEST) 677 $(BT_TIMEOUT_TEST) \
678 test_communicator_udp
668if HAVE_GETOPT_BINARY 679if HAVE_GETOPT_BINARY
669TESTS += \ 680TESTS += \
670test_transport_api_slow_ats 681test_transport_api_slow_ats
@@ -778,6 +789,12 @@ test_plugin_udp_LDADD = \
778 $(top_builddir)/src/util/libgnunetutil.la \ 789 $(top_builddir)/src/util/libgnunetutil.la \
779 libgnunettransporttesting.la 790 libgnunettransporttesting.la
780 791
792test_communicator_udp_SOURCES = \
793 test_communicator_udp.c
794test_communicator_udp_LDADD = \
795 libgnunettransporttesting2.la \
796 $(top_builddir)/src/util/libgnunetutil.la
797
781test_plugin_unix_SOURCES = \ 798test_plugin_unix_SOURCES = \
782 test_plugin_transport.c 799 test_plugin_transport.c
783test_plugin_unix_LDADD = \ 800test_plugin_unix_LDADD = \