aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2019-04-03 14:41:20 +0200
committerChristian Grothoff <christian@grothoff.org>2019-04-03 14:41:20 +0200
commit9859b3162a9fd7c9cc0c19582b04dd7f1c1f9408 (patch)
tree1fdda481fdfcea8d0833e13b237d829ef260197a /src/transport/Makefile.am
parentda083d77e1b70766d7067abf6cbc06e6c2cb6341 (diff)
downloadgnunet-9859b3162a9fd7c9cc0c19582b04dd7f1c1f9408.tar.gz
gnunet-9859b3162a9fd7c9cc0c19582b04dd7f1c1f9408.zip
remove xt/xu plugins, no longer needed for anything
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am31
1 files changed, 0 insertions, 31 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 9cf16ddb6..cd31f7cd7 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -378,12 +378,6 @@ plugin_LTLIBRARIES = \
378 $(WLAN_PLUGIN_LA) \ 378 $(WLAN_PLUGIN_LA) \
379 $(BT_PLUGIN_LA) 379 $(BT_PLUGIN_LA)
380 380
381if HAVE_EXPERIMENTAL
382plugin_LTLIBRARIES += \
383 libgnunet_plugin_transport_xt.la \
384 libgnunet_plugin_transport_xu.la
385endif
386
387# Note: real plugins of course need to be added 381# Note: real plugins of course need to be added
388# to the plugin_LTLIBRARIES above 382# to the plugin_LTLIBRARIES above
389noinst_LTLIBRARIES = \ 383noinst_LTLIBRARIES = \
@@ -401,18 +395,6 @@ libgnunet_plugin_transport_tcp_la_LIBADD = \
401libgnunet_plugin_transport_tcp_la_LDFLAGS = \ 395libgnunet_plugin_transport_tcp_la_LDFLAGS = \
402 $(GN_PLUGIN_LDFLAGS) 396 $(GN_PLUGIN_LDFLAGS)
403 397
404libgnunet_plugin_transport_xt_la_SOURCES = \
405 plugin_transport_xt.c
406libgnunet_plugin_transport_xt_la_LIBADD = \
407 $(top_builddir)/src/hello/libgnunethello.la \
408 $(top_builddir)/src/statistics/libgnunetstatistics.la \
409 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
410 $(top_builddir)/src/nat/libgnunetnatnew.la \
411 $(top_builddir)/src/util/libgnunetutil.la \
412 $(LTLIBINTL)
413libgnunet_plugin_transport_xt_la_LDFLAGS = \
414 $(GN_PLUGIN_LDFLAGS)
415
416libgnunet_plugin_transport_template_la_SOURCES = \ 398libgnunet_plugin_transport_template_la_SOURCES = \
417 plugin_transport_template.c 399 plugin_transport_template.c
418libgnunet_plugin_transport_template_la_LIBADD = \ 400libgnunet_plugin_transport_template_la_LIBADD = \
@@ -461,19 +443,6 @@ libgnunet_plugin_transport_udp_la_LIBADD = \
461libgnunet_plugin_transport_udp_la_LDFLAGS = \ 443libgnunet_plugin_transport_udp_la_LDFLAGS = \
462 $(GN_PLUGIN_LDFLAGS) 444 $(GN_PLUGIN_LDFLAGS)
463 445
464libgnunet_plugin_transport_xu_la_SOURCES = \
465 plugin_transport_xu.c plugin_transport_xu.h
466libgnunet_plugin_transport_xu_la_LIBADD = \
467 $(top_builddir)/src/hello/libgnunethello.la \
468 $(top_builddir)/src/fragmentation/libgnunetfragmentation.la \
469 $(top_builddir)/src/statistics/libgnunetstatistics.la \
470 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
471 $(top_builddir)/src/nat/libgnunetnatnew.la \
472 $(top_builddir)/src/util/libgnunetutil.la \
473 $(LTLIBINTL)
474libgnunet_plugin_transport_xu_la_LDFLAGS = \
475 $(GN_PLUGIN_LDFLAGS)
476
477libgnunet_plugin_transport_unix_la_SOURCES = \ 446libgnunet_plugin_transport_unix_la_SOURCES = \
478 plugin_transport_unix.c 447 plugin_transport_unix.c
479libgnunet_plugin_transport_unix_la_LIBADD = \ 448libgnunet_plugin_transport_unix_la_LIBADD = \