aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-10-17 13:49:49 +0000
committerng0 <ng0@n0.is>2019-10-17 13:49:49 +0000
commit9d41ec39756a783c53bb06581ea189c95e08c4d6 (patch)
tree08263348bc5cbeaa8e0a5dc21fcf0fdaabb7184a /src/transport/Makefile.am
parent22ad43e23641318de7f50084aa816a6fda14d7ec (diff)
downloadgnunet-9d41ec39756a783c53bb06581ea189c95e08c4d6.tar.gz
gnunet-9d41ec39756a783c53bb06581ea189c95e08c4d6.zip
Add support for doas.
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 0f5b2e8be..178ecc737 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -93,11 +93,19 @@ if LINUX
93 test_quota_compliance_wlan_asymmetric 93 test_quota_compliance_wlan_asymmetric
94endif 94endif
95 95
96if HAVE_SUDO
97SUDO_OR_DOAS_BINARY= $(SUDO_BINARY)
98else
99if HAVE_DOAS_BINARY
100SUDO_OR_DOAS_BINARY= $(DOAS_BINARY)
101endif
102endif
103
96if LINUX 104if LINUX
97install-exec-hook: 105install-exec-hook:
98 $(top_srcdir)/src/transport/install-wlan-helper.sh $(DESTDIR)$(libexecdir) $(SUDO_BINARY) || true 106 $(top_srcdir)/src/transport/install-wlan-helper.sh $(DESTDIR)$(libexecdir) $(SUDO_OR_DOAS_BINARY) || true
99if HAVE_LIBBLUETOOTH 107if HAVE_LIBBLUETOOTH
100 $(top_srcdir)/src/transport/install-bluetooth-helper.sh $(DESTDIR)$(libexecdir) $(SUDO_BINARY) || true 108 $(top_srcdir)/src/transport/install-bluetooth-helper.sh $(DESTDIR)$(libexecdir) $(SUDO_OR_DOAS_BINARY) || true
101endif 109endif
102else 110else
103install-exec-hook: 111install-exec-hook: