aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorSchanzenbach, Martin <mschanzenbach@posteo.de>2019-12-12 21:02:35 +0100
committerSchanzenbach, Martin <mschanzenbach@posteo.de>2019-12-12 21:02:35 +0100
commita9fadbb9d0012cd7b65bd0c5cf3196f1fc54d3e8 (patch)
treee77523f08e34a5e2bdba489dca680b0ed8a720e0 /src/transport/Makefile.am
parentee7f0517b2212e7e8215bc5a64b756356cd16cb1 (diff)
downloadgnunet-a9fadbb9d0012cd7b65bd0c5cf3196f1fc54d3e8.tar.gz
gnunet-a9fadbb9d0012cd7b65bd0c5cf3196f1fc54d3e8.zip
make udp transport experimental
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am43
1 files changed, 41 insertions, 2 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 45b6977ab..5069e95b6 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -369,7 +369,9 @@ gnunet_service_tng_LDADD = \
369 369
370plugin_LTLIBRARIES = \ 370plugin_LTLIBRARIES = \
371 libgnunet_plugin_transport_tcp.la \ 371 libgnunet_plugin_transport_tcp.la \
372if HAVE_EXPERIMENTAL
372 libgnunet_plugin_transport_udp.la \ 373 libgnunet_plugin_transport_udp.la \
374endif
373 $(UNIX_PLUGIN_LA) \ 375 $(UNIX_PLUGIN_LA) \
374 $(HTTP_CLIENT_PLUGIN_LA) \ 376 $(HTTP_CLIENT_PLUGIN_LA) \
375 $(HTTPS_CLIENT_PLUGIN_LA) \ 377 $(HTTPS_CLIENT_PLUGIN_LA) \
@@ -429,6 +431,7 @@ libgnunet_plugin_transport_bluetooth_la_LDFLAGS = \
429libgnunet_plugin_transport_bluetooth_la_CFLAGS = \ 431libgnunet_plugin_transport_bluetooth_la_CFLAGS = \
430 $(AM_CFLAGS) -DBUILD_BLUETOOTH 432 $(AM_CFLAGS) -DBUILD_BLUETOOTH
431 433
434if HAVE_EXPERIMENTAL
432libgnunet_plugin_transport_udp_la_SOURCES = \ 435libgnunet_plugin_transport_udp_la_SOURCES = \
433 plugin_transport_udp.c plugin_transport_udp.h \ 436 plugin_transport_udp.c plugin_transport_udp.h \
434 plugin_transport_udp_broadcasting.c 437 plugin_transport_udp_broadcasting.c
@@ -442,6 +445,7 @@ libgnunet_plugin_transport_udp_la_LIBADD = \
442 $(LTLIBINTL) 445 $(LTLIBINTL)
443libgnunet_plugin_transport_udp_la_LDFLAGS = \ 446libgnunet_plugin_transport_udp_la_LDFLAGS = \
444 $(GN_PLUGIN_LDFLAGS) 447 $(GN_PLUGIN_LDFLAGS)
448endif
445 449
446libgnunet_plugin_transport_unix_la_SOURCES = \ 450libgnunet_plugin_transport_unix_la_SOURCES = \
447 plugin_transport_unix.c 451 plugin_transport_unix.c
@@ -519,11 +523,15 @@ libgnunet_plugin_transport_https_server_la_CFLAGS = \
519if HAVE_TESTING 523if HAVE_TESTING
520check_PROGRAMS = \ 524check_PROGRAMS = \
521 test_transport_address_switch_tcp \ 525 test_transport_address_switch_tcp \
526if HAVE_EXPERIMENTAL
522 test_transport_address_switch_udp \ 527 test_transport_address_switch_udp \
528endif
523 test_transport_testing_startstop \ 529 test_transport_testing_startstop \
524 test_transport_testing_restart \ 530 test_transport_testing_restart \
525 test_plugin_tcp \ 531 test_plugin_tcp \
532if HAVE_EXPERIMENTAL
526 test_plugin_udp \ 533 test_plugin_udp \
534endif
527 $(UNIX_TEST) \ 535 $(UNIX_TEST) \
528 $(WLAN_PLUGIN_TEST) \ 536 $(WLAN_PLUGIN_TEST) \
529 $(BT_PLUGIN_TEST) \ 537 $(BT_PLUGIN_TEST) \
@@ -540,12 +548,16 @@ check_PROGRAMS = \
540 test_transport_api_timeout_tcp \ 548 test_transport_api_timeout_tcp \
541 test_transport_api_limited_sockets_tcp \ 549 test_transport_api_limited_sockets_tcp \
542 test_transport_api_tcp_nat \ 550 test_transport_api_tcp_nat \
551if HAVE_EXPERIMENTAL
543 test_transport_api_udp \ 552 test_transport_api_udp \
544 test_transport_api_timeout_udp \ 553 test_transport_api_timeout_udp \
554endif
545 $(UNIX_PLUGIN_TEST) \ 555 $(UNIX_PLUGIN_TEST) \
546 $(UNIX_PLUGIN_TIMEOUT_TEST) \ 556 $(UNIX_PLUGIN_TIMEOUT_TEST) \
547 $(UNIX_API_ABSTRACT_TEST) \ 557 $(UNIX_API_ABSTRACT_TEST) \
558if HAVE_EXPERIMENTAL
548 test_transport_api_udp_nat \ 559 test_transport_api_udp_nat \
560endif
549 $(HTTP_API_TEST) \ 561 $(HTTP_API_TEST) \
550 $(HTTP_REVERSE_API_TEST) \ 562 $(HTTP_REVERSE_API_TEST) \
551 $(HTTP_API_TIMEOUT_TEST) \ 563 $(HTTP_API_TIMEOUT_TEST) \
@@ -570,7 +582,9 @@ check_PROGRAMS = \
570 test_transport_api_manipulation_cfg \ 582 test_transport_api_manipulation_cfg \
571 test_transport_api_reliability_tcp \ 583 test_transport_api_reliability_tcp \
572 test_transport_api_reliability_tcp_nat \ 584 test_transport_api_reliability_tcp_nat \
585if HAVE_EXPERIMENTAL
573 test_transport_api_reliability_udp \ 586 test_transport_api_reliability_udp \
587endif
574 $(UNIX_REL_TEST) \ 588 $(UNIX_REL_TEST) \
575 $(HTTP_REL_TEST) \ 589 $(HTTP_REL_TEST) \
576 $(HTTPS_REL_TEST) \ 590 $(HTTPS_REL_TEST) \
@@ -580,7 +594,9 @@ check_PROGRAMS = \
580 $(BT_UREL_TEST) \ 594 $(BT_UREL_TEST) \
581 test_quota_compliance_tcp \ 595 test_quota_compliance_tcp \
582 test_quota_compliance_tcp_asymmetric \ 596 test_quota_compliance_tcp_asymmetric \
597if HAVE_EXPERIMENTAL
583 test_quota_compliance_udp \ 598 test_quota_compliance_udp \
599endif
584 $(UNIX_QUOTA_TEST) \ 600 $(UNIX_QUOTA_TEST) \
585 $(HTTP_QUOTA_TEST) \ 601 $(HTTP_QUOTA_TEST) \
586 $(HTTPS_QUOTA_TEST) \ 602 $(HTTPS_QUOTA_TEST) \
@@ -598,13 +614,17 @@ if ENABLE_TEST_RUN
598AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; 614AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
599TESTS = \ 615TESTS = \
600 test_transport_address_switch_tcp \ 616 test_transport_address_switch_tcp \
617if HAVE_EXPERIMENTAL
601 test_transport_address_switch_udp \ 618 test_transport_address_switch_udp \
619endif
602 $(HTTP_SWITCH) \ 620 $(HTTP_SWITCH) \
603 $(HTTPS_SWITCH) \ 621 $(HTTPS_SWITCH) \
604 test_transport_testing_startstop \ 622 test_transport_testing_startstop \
605 test_transport_testing_restart \ 623 test_transport_testing_restart \
606 test_plugin_tcp \ 624 test_plugin_tcp \
625if HAVE_EXPERIMENTAL
607 test_plugin_udp \ 626 test_plugin_udp \
627endif
608 $(UNIX_TEST) \ 628 $(UNIX_TEST) \
609 $(WLAN_PLUGIN_TEST) \ 629 $(WLAN_PLUGIN_TEST) \
610 $(BT_PLUGIN_TEST) \ 630 $(BT_PLUGIN_TEST) \
@@ -615,10 +635,14 @@ TESTS = \
615 test_transport_api_restart_2peers \ 635 test_transport_api_restart_2peers \
616 test_transport_api_limited_sockets_tcp \ 636 test_transport_api_limited_sockets_tcp \
617 test_transport_api_tcp_nat \ 637 test_transport_api_tcp_nat \
638if HAVE_EXPERIMENTAL
618 test_transport_api_udp \ 639 test_transport_api_udp \
640endif
619 $(UNIX_PLUGIN_TEST) \ 641 $(UNIX_PLUGIN_TEST) \
620 $(UNIX_API_ABSTRACT_TEST) \ 642 $(UNIX_API_ABSTRACT_TEST) \
643if HAVE_EXPERIMENTAL
621 test_transport_api_udp_nat \ 644 test_transport_api_udp_nat \
645endif
622 $(HTTP_API_TEST) \ 646 $(HTTP_API_TEST) \
623 $(HTTPS_API_TEST) \ 647 $(HTTPS_API_TEST) \
624 $(WLAN_API_TEST) \ 648 $(WLAN_API_TEST) \
@@ -636,7 +660,9 @@ TESTS = \
636 test_transport_api_manipulation_cfg \ 660 test_transport_api_manipulation_cfg \
637 test_transport_api_reliability_tcp \ 661 test_transport_api_reliability_tcp \
638 test_transport_api_reliability_tcp_nat \ 662 test_transport_api_reliability_tcp_nat \
663if HAVE_EXPERIMENTAL
639 test_transport_api_reliability_udp \ 664 test_transport_api_reliability_udp \
665endif
640 $(UNIX_REL_TEST) \ 666 $(UNIX_REL_TEST) \
641 $(HTTP_REL_TEST) \ 667 $(HTTP_REL_TEST) \
642 $(HTTPS_REL_TEST) \ 668 $(HTTPS_REL_TEST) \
@@ -646,12 +672,16 @@ TESTS = \
646 $(BT_UREL_TEST) \ 672 $(BT_UREL_TEST) \
647 test_quota_compliance_tcp \ 673 test_quota_compliance_tcp \
648 test_quota_compliance_tcp_asymmetric \ 674 test_quota_compliance_tcp_asymmetric \
675if HAVE_EXPERIMENTAL
649 test_quota_compliance_udp \ 676 test_quota_compliance_udp \
677endif
650 $(UNIX_QUOTA_TEST) \ 678 $(UNIX_QUOTA_TEST) \
651 $(HTTP_QUOTA_TEST) \ 679 $(HTTP_QUOTA_TEST) \
652 $(HTTPS_QUOTA_TEST) \ 680 $(HTTPS_QUOTA_TEST) \
653 test_transport_api_timeout_tcp \ 681 test_transport_api_timeout_tcp \
682if HAVE_EXPERIMENTAL
654 test_transport_api_timeout_udp \ 683 test_transport_api_timeout_udp \
684endif
655 $(UNIX_PLUGIN_TIMEOUT_TEST) \ 685 $(UNIX_PLUGIN_TIMEOUT_TEST) \
656 $(HTTP_API_TIMEOUT_TEST) \ 686 $(HTTP_API_TIMEOUT_TEST) \
657 $(HTTPS_API_TIMEOUT_TEST) \ 687 $(HTTPS_API_TIMEOUT_TEST) \
@@ -761,6 +791,7 @@ test_plugin_tcp_LDADD = \
761 $(top_builddir)/src/util/libgnunetutil.la \ 791 $(top_builddir)/src/util/libgnunetutil.la \
762 libgnunettransporttesting.la 792 libgnunettransporttesting.la
763 793
794if HAVE_EXPERIMENTAL
764test_plugin_udp_SOURCES = \ 795test_plugin_udp_SOURCES = \
765 test_plugin_transport.c 796 test_plugin_transport.c
766test_plugin_udp_LDADD = \ 797test_plugin_udp_LDADD = \
@@ -769,6 +800,7 @@ test_plugin_udp_LDADD = \
769 $(top_builddir)/src/hello/libgnunethello.la \ 800 $(top_builddir)/src/hello/libgnunethello.la \
770 $(top_builddir)/src/util/libgnunetutil.la \ 801 $(top_builddir)/src/util/libgnunetutil.la \
771 libgnunettransporttesting.la 802 libgnunettransporttesting.la
803endif
772 804
773test_communicator_unix_SOURCES = \ 805test_communicator_unix_SOURCES = \
774 test_communicator_unix.c 806 test_communicator_unix.c
@@ -980,6 +1012,7 @@ test_transport_api_reliability_wlan_LDADD = \
980 $(top_builddir)/src/util/libgnunetutil.la \ 1012 $(top_builddir)/src/util/libgnunetutil.la \
981 libgnunettransporttesting.la 1013 libgnunettransporttesting.la
982 1014
1015if HAVE_EXPERIMENTAL
983test_transport_api_udp_SOURCES = \ 1016test_transport_api_udp_SOURCES = \
984 test_transport_api.c 1017 test_transport_api.c
985test_transport_api_udp_LDADD = \ 1018test_transport_api_udp_LDADD = \
@@ -1003,6 +1036,7 @@ test_transport_api_udp_nat_LDADD = \
1003 $(top_builddir)/src/hello/libgnunethello.la \ 1036 $(top_builddir)/src/hello/libgnunethello.la \
1004 $(top_builddir)/src/util/libgnunetutil.la \ 1037 $(top_builddir)/src/util/libgnunetutil.la \
1005 libgnunettransporttesting.la 1038 libgnunettransporttesting.la
1039endif
1006 1040
1007test_transport_api_unix_SOURCES = \ 1041test_transport_api_unix_SOURCES = \
1008 test_transport_api.c 1042 test_transport_api.c
@@ -1143,6 +1177,7 @@ test_transport_api_reliability_unix_LDADD = \
1143 $(top_builddir)/src/util/libgnunetutil.la \ 1177 $(top_builddir)/src/util/libgnunetutil.la \
1144 libgnunettransporttesting.la 1178 libgnunettransporttesting.la
1145 1179
1180if HAVE_EXPERIMENTAL
1146test_transport_api_reliability_udp_SOURCES = \ 1181test_transport_api_reliability_udp_SOURCES = \
1147 test_transport_api_reliability.c 1182 test_transport_api_reliability.c
1148test_transport_api_reliability_udp_LDADD = \ 1183test_transport_api_reliability_udp_LDADD = \
@@ -1150,6 +1185,7 @@ test_transport_api_reliability_udp_LDADD = \
1150 $(top_builddir)/src/hello/libgnunethello.la \ 1185 $(top_builddir)/src/hello/libgnunethello.la \
1151 $(top_builddir)/src/util/libgnunetutil.la \ 1186 $(top_builddir)/src/util/libgnunetutil.la \
1152 libgnunettransporttesting.la 1187 libgnunettransporttesting.la
1188endif
1153 1189
1154if LINUX 1190if LINUX
1155test_transport_api_wlan_SOURCES = \ 1191test_transport_api_wlan_SOURCES = \
@@ -1182,7 +1218,8 @@ test_transport_address_switch_tcp_LDADD = \
1182 $(top_builddir)/src/util/libgnunetutil.la \ 1218 $(top_builddir)/src/util/libgnunetutil.la \
1183 libgnunettransporttesting.la 1219 libgnunettransporttesting.la
1184 1220
1185 test_transport_address_switch_udp_SOURCES = \ 1221if HAVE_EXPERIMENTAL
1222test_transport_address_switch_udp_SOURCES = \
1186 test_transport_address_switch.c 1223 test_transport_address_switch.c
1187test_transport_address_switch_udp_LDADD = \ 1224test_transport_address_switch_udp_LDADD = \
1188 libgnunettransport.la \ 1225 libgnunettransport.la \
@@ -1190,7 +1227,7 @@ test_transport_address_switch_udp_LDADD = \
1190 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 1227 $(top_builddir)/src/statistics/libgnunetstatistics.la \
1191 $(top_builddir)/src/util/libgnunetutil.la \ 1228 $(top_builddir)/src/util/libgnunetutil.la \
1192 libgnunettransporttesting.la 1229 libgnunettransporttesting.la
1193 1230endif
1194 1231
1195 test_transport_address_switch_http_SOURCES = \ 1232 test_transport_address_switch_http_SOURCES = \
1196 test_transport_address_switch.c 1233 test_transport_address_switch.c
@@ -1230,6 +1267,7 @@ test_quota_compliance_tcp_asymmetric_LDADD = \
1230 $(top_builddir)/src/util/libgnunetutil.la \ 1267 $(top_builddir)/src/util/libgnunetutil.la \
1231 libgnunettransporttesting.la 1268 libgnunettransporttesting.la
1232 1269
1270if HAVE_EXPERIMENTAL
1233test_quota_compliance_udp_SOURCES = \ 1271test_quota_compliance_udp_SOURCES = \
1234 test_quota_compliance.c 1272 test_quota_compliance.c
1235test_quota_compliance_udp_LDADD = \ 1273test_quota_compliance_udp_LDADD = \
@@ -1239,6 +1277,7 @@ test_quota_compliance_udp_LDADD = \
1239 $(top_builddir)/src/nt/libgnunetnt.la \ 1277 $(top_builddir)/src/nt/libgnunetnt.la \
1240 $(top_builddir)/src/util/libgnunetutil.la \ 1278 $(top_builddir)/src/util/libgnunetutil.la \
1241 libgnunettransporttesting.la 1279 libgnunettransporttesting.la
1280endif
1242 1281
1243test_quota_compliance_unix_SOURCES = \ 1282test_quota_compliance_unix_SOURCES = \
1244 test_quota_compliance.c 1283 test_quota_compliance.c